about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/haskell-modules/configuration-common.nix4
-rw-r--r--pkgs/development/haskell-modules/patches/lzma-tests.patch18
2 files changed, 10 insertions, 12 deletions
diff --git a/pkgs/development/haskell-modules/configuration-common.nix b/pkgs/development/haskell-modules/configuration-common.nix
index bf489d623943..7b4425869b17 100644
--- a/pkgs/development/haskell-modules/configuration-common.nix
+++ b/pkgs/development/haskell-modules/configuration-common.nix
@@ -508,7 +508,7 @@ self: super: {
   # https://github.com/alphaHeavy/lzma-enumerator/issues/3
   lzma-enumerator = dontCheck super.lzma-enumerator;
 
-  # https://github.com/haskell-hvr/lzma/issues/8
+  # https://github.com/haskell-hvr/lzma/pull/11
   lzma = appendPatch super.lzma ./patches/lzma-tests.patch;
 
   # https://github.com/BNFC/bnfc/issues/140
@@ -1040,4 +1040,4 @@ self: super: {
   amazonka-test = super.amazonka-test.overrideScope amazonkaOverrides;
 in {
   inherit amazonka amazonka-core amazonka-test;
-})
\ No newline at end of file
+})
diff --git a/pkgs/development/haskell-modules/patches/lzma-tests.patch b/pkgs/development/haskell-modules/patches/lzma-tests.patch
index e4e327ab6bbc..db9e62ee3c5f 100644
--- a/pkgs/development/haskell-modules/patches/lzma-tests.patch
+++ b/pkgs/development/haskell-modules/patches/lzma-tests.patch
@@ -1,13 +1,11 @@
 --- a/lzma.cabal
 +++ b/lzma.cabal
-@@ -70,8 +70,8 @@ test-suite lzma-tests
-                      , base
-                      , bytestring
+@@ -76,7 +76,7 @@
    -- additional dependencies that require version bounds
--  build-depends:       HUnit                      >= 1.2      && <1.4
--                     , QuickCheck                 >= 2.8      && <2.9
-+  build-depends:       HUnit                      >= 1.2      && <2
-+                     , QuickCheck                 >= 2.8      && <3
-                      , tasty                      >= 0.10     && <0.12
-                      , tasty-hunit                == 0.9.*
-                      , tasty-quickcheck           >= 0.8.3.2  && < 0.9
+   build-depends:       HUnit                      >= 1.2      && <1.7
+                      , QuickCheck                 >= 2.8      && <2.11
+-                     , tasty                      >= 0.10     && <0.13
++                     , tasty                      >= 0.10     && <1.1
+                      , tasty-hunit                >= 0.9      && <0.11
+                      , tasty-quickcheck           >= 0.8.3.2  && <0.10
+