about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/python-modules/can/default.nix7
1 files changed, 1 insertions, 6 deletions
diff --git a/pkgs/development/python-modules/can/default.nix b/pkgs/development/python-modules/can/default.nix
index b9d2b4b7751a..8aa80a750678 100644
--- a/pkgs/development/python-modules/can/default.nix
+++ b/pkgs/development/python-modules/can/default.nix
@@ -24,12 +24,7 @@ buildPythonPackage rec {
   };
 
   propagatedBuildInputs = [ wrapt pyserial aenum ] ++ lib.optional (pythonOlder "3.5") typing;
-  checkInputs = [ nose mock pytest pytest-timeout hypothesis future ];
-
-  # Tests won't work with hypothesis 4.7.3 under Python 2. So skip the tests in
-  # that case. This clause can be removed once hypothesis has been upgraded in
-  # nixpkgs.
-  doCheck = !(isPy27 && (hypothesis.version == "4.7.3"));
+  checkInputs = [ nose mock pytest hypothesis future ];
 
   # Add the scripts to PATH
   checkPhase = ''