about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/compilers/ghcjs/head_stage2.nix1
-rw-r--r--pkgs/development/haskell-modules/configuration-nix.nix2
-rw-r--r--pkgs/development/haskell-modules/generic-builder.nix3
-rw-r--r--pkgs/development/libraries/libproxy/default.nix10
-rw-r--r--pkgs/development/libraries/nix-plugins/default.nix10
-rw-r--r--pkgs/development/libraries/oracle-instantclient/default.nix50
-rw-r--r--pkgs/development/libraries/qt-5/5.8/qttools/cmake-paths.patch5
-rw-r--r--pkgs/development/tools/scalafmt/default.nix4
8 files changed, 58 insertions, 27 deletions
diff --git a/pkgs/development/compilers/ghcjs/head_stage2.nix b/pkgs/development/compilers/ghcjs/head_stage2.nix
index d4247f51b3e3..5808891d4303 100644
--- a/pkgs/development/compilers/ghcjs/head_stage2.nix
+++ b/pkgs/development/compilers/ghcjs/head_stage2.nix
@@ -382,6 +382,7 @@
         version = "1.24.0.0";
         src = "${ghcjsBoot}/boot/cabal/Cabal";
         doCheck = false;
+        hyperlinkSource = false;
         libraryHaskellDepends = [
           array base binary bytestring containers deepseq directory filepath
           pretty process time unix
diff --git a/pkgs/development/haskell-modules/configuration-nix.nix b/pkgs/development/haskell-modules/configuration-nix.nix
index 017f2ea7637a..f03fc73387f3 100644
--- a/pkgs/development/haskell-modules/configuration-nix.nix
+++ b/pkgs/development/haskell-modules/configuration-nix.nix
@@ -239,6 +239,8 @@ self: super: builtins.intersectAttrs super {
       }
     );
 
+  llvm-hs = super.llvm-hs.override { llvm-config = pkgs.llvm_4; };
+
   # Needs help finding LLVM.
   spaceprobe = addBuildTool super.spaceprobe self.llvmPackages.llvm;
 
diff --git a/pkgs/development/haskell-modules/generic-builder.nix b/pkgs/development/haskell-modules/generic-builder.nix
index 1f5d97941ce5..d39e1bacd71d 100644
--- a/pkgs/development/haskell-modules/generic-builder.nix
+++ b/pkgs/development/haskell-modules/generic-builder.nix
@@ -125,7 +125,6 @@ let
   ] ++ optionals (enableDeadCodeElimination && (stdenv.lib.versionOlder "8.0.1" ghc.version)) [
      "--ghc-option=-split-sections"
   ] ++ optionals isGhcjs [
-    "--with-hsc2hs=${nativeGhc}/bin/hsc2hs"
     "--ghcjs"
   ] ++ optionals isCross ([
     "--configure-option=--host=${ghc.cross.config}"
@@ -150,6 +149,8 @@ let
                      buildTools ++ libraryToolDepends ++ executableToolDepends ++
                      optionals (allPkgconfigDepends != []) ([pkgconfig] ++ allPkgconfigDepends) ++
                      optionals doCheck (testDepends ++ testHaskellDepends ++ testSystemDepends ++ testToolDepends) ++
+                     # ghcjs's hsc2hs calls out to the native hsc2hs
+                     optional isGhcjs nativeGhc ++
                      optionals withBenchmarkDepends (benchmarkDepends ++ benchmarkHaskellDepends ++ benchmarkSystemDepends ++ benchmarkToolDepends);
   allBuildInputs = propagatedBuildInputs ++ otherBuildInputs;
 
diff --git a/pkgs/development/libraries/libproxy/default.nix b/pkgs/development/libraries/libproxy/default.nix
index 97929d29b377..163357a0c0f8 100644
--- a/pkgs/development/libraries/libproxy/default.nix
+++ b/pkgs/development/libraries/libproxy/default.nix
@@ -1,5 +1,5 @@
 { stdenv, lib, fetchFromGitHub, pkgconfig, cmake
-, dbus, networkmanager, spidermonkey_1_8_5 }:
+, dbus, networkmanager, webkitgtk214x, pcre, python2 }:
 
 stdenv.mkDerivation rec {
   name = "libproxy-${version}";
@@ -16,7 +16,13 @@ stdenv.mkDerivation rec {
 
   nativeBuildInputs = [ pkgconfig cmake ];
 
-  buildInputs = [ dbus networkmanager spidermonkey_1_8_5 ];
+  buildInputs = [ dbus networkmanager webkitgtk214x pcre ];
+
+  cmakeFlags = [
+    "-DWITH_WEBKIT3=ON"
+    "-DWITH_MOZJS=OFF"
+    "-DPYTHON_SITEPKG_DIR=$(out)/${python2.sitePackages}"
+  ];
 
   meta = with stdenv.lib; {
     platforms = platforms.linux;
diff --git a/pkgs/development/libraries/nix-plugins/default.nix b/pkgs/development/libraries/nix-plugins/default.nix
index 6b61dbf75187..2dcc7e9a53dd 100644
--- a/pkgs/development/libraries/nix-plugins/default.nix
+++ b/pkgs/development/libraries/nix-plugins/default.nix
@@ -1,5 +1,5 @@
-{ stdenv, fetchFromGitHub, nix }:
-let version = "2.0.3"; in
+{ stdenv, fetchFromGitHub, nix, boehmgc }:
+let version = "2.0.7"; in
 stdenv.mkDerivation {
   name = "nix-plugins-${version}";
 
@@ -7,12 +7,10 @@ stdenv.mkDerivation {
     owner = "shlevy";
     repo = "nix-plugins";
     rev = version;
-    sha256 = "033w4m9ah127sfls7zqzpp2b1wdzsvzzk3bnkv6jyi31bws7hadp";
+    sha256 = "1q4ydp2w114wbfm41m4qgrabha7ifa17xyz5dr137vvnj6njp4vs";
   };
 
-  buildInputs = [ nix ];
-
-  buildFlags = [ "NIX_INCLUDE=${nix.dev}/include" ];
+  buildFlags = [ "NIX_INCLUDE=${nix.dev}/include" "GC_INCLUDE=${boehmgc.dev}/include" ];
 
   installFlags = [ "PREFIX=$(out)" ];
 
diff --git a/pkgs/development/libraries/oracle-instantclient/default.nix b/pkgs/development/libraries/oracle-instantclient/default.nix
index c29a5da9f21a..d0085752623d 100644
--- a/pkgs/development/libraries/oracle-instantclient/default.nix
+++ b/pkgs/development/libraries/oracle-instantclient/default.nix
@@ -1,29 +1,39 @@
-{ stdenv, requireFile, libelf, gcc, glibc, patchelf, unzip, rpmextract, libaio }:
+{ stdenv, requireFile, libelf, gcc, glibc, patchelf, unzip, rpmextract, libaio
+, odbcSupport ? false, unixODBC
+}:
 
-let requireSource = version: part: hash: (requireFile rec {
-  name = "oracle-instantclient12.1-${part}-${version}.x86_64.rpm";
-  message = ''
-    This Nix expression requires that ${name} already
-    be part of the store. Download the file
-    manually at
+assert odbcSupport -> unixODBC != null;
 
-    http://www.oracle.com/technetwork/topics/linuxx86-64soft-092277.html
+let optional = stdenv.lib.optional;
+    optionalString  = stdenv.lib.optionalString;
+    requireSource = version: part: hash: (requireFile rec {
+      name = "oracle-instantclient12.1-${part}-${version}.x86_64.rpm";
+      message = ''
+        This Nix expression requires that ${name} already
+        be part of the store. Download the file
+        manually at
 
-    and add it to the Nix store with the following command:
+        http://www.oracle.com/technetwork/topics/linuxx86-64soft-092277.html
 
-    nix-prefetch-url file://${name} ${hash} --type sha256
-'';
-  url = "http://www.oracle.com/technetwork/topics/linuxx86-64soft-092277.html";
-  sha256 = hash;
-}); in stdenv.mkDerivation rec {
+        and add it to the Nix store using either:
+          nix-store --add-fixed sha256 ${name}
+        or
+          nix-prefetch-url --type sha256 file:///path/to/${name}
+      '';
+      url = "http://www.oracle.com/technetwork/topics/linuxx86-64soft-092277.html";
+      sha256 = hash;
+    });
+in stdenv.mkDerivation rec {
   version = "12.1.0.2.0-1";
   name = "oracle-instantclient-${version}";
 
   srcBase = (requireSource version "basic" "f0e51e247cc3f210b950fd939ab1f696de9ca678d1eb179ba49ac73acb9a20ed");
   srcDevel = (requireSource version "devel" "13b638882f07d6cfc06c85dc6b9eb5cac37064d3d594194b6b09d33483a08296");
   srcSqlplus = (requireSource version "sqlplus" "16d87w1lii0ag47c8srnr7v4wfm9q4hy6gka8m3v6gp9cc065vam");
+  srcOdbc = optionalString odbcSupport (requireSource version "odbc" "d3aa1a4957a2f15ced05921dab551ba823aa7925d8fcb58d5b3a7f624e4df063");
 
-  buildInputs = [ glibc patchelf rpmextract ];
+  buildInputs = [ glibc patchelf rpmextract ] ++
+    optional odbcSupport unixODBC;
 
   buildCommand = ''
     mkdir -p "${name}"
@@ -31,6 +41,9 @@ let requireSource = version: part: hash: (requireFile rec {
     ${rpmextract}/bin/rpmextract "${srcBase}"
     ${rpmextract}/bin/rpmextract "${srcDevel}"
     ${rpmextract}/bin/rpmextract "${srcSqlplus}"
+    ${optionalString odbcSupport ''
+        ${rpmextract}/bin/rpmextract "${srcOdbc}"
+    ''}
 
     mkdir -p "$out/"{bin,include,lib,"share/${name}/demo/"}
     mv "usr/share/oracle/12.1/client64/demo/"* "$out/share/${name}/demo/"
@@ -46,6 +59,13 @@ let requireSource = version: part: hash: (requireFile rec {
                $lib
     done
 
+    for lib in $out/lib/libsqora*; do
+      test -f $lib || continue
+      chmod +x $lib
+      patchelf --force-rpath --set-rpath "$out/lib:${unixODBC}/lib" \
+               $lib
+    done
+
     for exe in $out/bin/sqlplus; do
       patchelf --set-interpreter $(cat $NIX_CC/nix-support/dynamic-linker) \
                --force-rpath --set-rpath "$out/lib:${libaio}/lib" \
diff --git a/pkgs/development/libraries/qt-5/5.8/qttools/cmake-paths.patch b/pkgs/development/libraries/qt-5/5.8/qttools/cmake-paths.patch
index 3d557c4c023b..dfcba9045a75 100644
--- a/pkgs/development/libraries/qt-5/5.8/qttools/cmake-paths.patch
+++ b/pkgs/development/libraries/qt-5/5.8/qttools/cmake-paths.patch
@@ -18,7 +18,7 @@ Index: qttools-opensource-src-5.8.0/src/assistant/help/Qt5HelpConfigExtras.cmake
      _qt5_Help_check_file_exists(${imported_location})
  
      set_target_properties(Qt5::qcollectiongenerator PROPERTIES
-@@ -17,11 +16,7 @@ endif()
+@@ -17,11 +16,10 @@ endif()
  if (NOT TARGET Qt5::qhelpgenerator)
      add_executable(Qt5::qhelpgenerator IMPORTED)
  
@@ -28,6 +28,9 @@ Index: qttools-opensource-src-5.8.0/src/assistant/help/Qt5HelpConfigExtras.cmake
 -    set(imported_location \"$${CMAKE_BIN_DIR}qhelpgenerator$$CMAKE_BIN_SUFFIX\")
 -!!ENDIF
 +    set(imported_location \"@NIX_OUT@/$${CMAKE_BIN_DIR}qhelpgenerator$$CMAKE_BIN_SUFFIX\")
++    if(NOT EXISTS \"${imported_location}\")
++        set(imported_location \"@NIX_DEV@/$${CMAKE_BIN_DIR}qhelpgenerator$$CMAKE_BIN_SUFFIX\")
++    endif()
      _qt5_Help_check_file_exists(${imported_location})
  
      set_target_properties(Qt5::qhelpgenerator PROPERTIES
diff --git a/pkgs/development/tools/scalafmt/default.nix b/pkgs/development/tools/scalafmt/default.nix
index 2c763072c294..b0d02cb8233a 100644
--- a/pkgs/development/tools/scalafmt/default.nix
+++ b/pkgs/development/tools/scalafmt/default.nix
@@ -1,13 +1,13 @@
 { stdenv, fetchurl, unzip, jre }:
 
 stdenv.mkDerivation rec {
-  version = "0.6.6";
+  version = "0.6.7";
   baseName = "scalafmt";
   name = "${baseName}-${version}";
 
   src = fetchurl {
     url = "https://github.com/scalameta/scalafmt/releases/download/v${version}/${baseName}.tar.gz";
-    sha256 = "143g288m6xr93pavbym2y6f8gvihsf53fnzjra6ln1s39n9h205n";
+    sha256 = "122x4a5x8024s7qqqs7vx8kz1x18q2l6alcvpzvsqkc304ybhfmh";
   };
 
   unpackPhase = "tar xvzf $src";