about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/tools/analysis/radare2-cutter/default.nix9
1 files changed, 8 insertions, 1 deletions
diff --git a/pkgs/development/tools/analysis/radare2-cutter/default.nix b/pkgs/development/tools/analysis/radare2-cutter/default.nix
index 299ef7f350ac..4aec0f65783a 100644
--- a/pkgs/development/tools/analysis/radare2-cutter/default.nix
+++ b/pkgs/development/tools/analysis/radare2-cutter/default.nix
@@ -33,7 +33,14 @@ stdenv.mkDerivation rec {
   nativeBuildInputs = [ qmake pkgconfig makeWrapper ];
   buildInputs = [ qtbase qtsvg qtwebengine radare2 python3 ];
 
-  qmakeFlags = [ "CONFIG+=link_pkgconfig" "PKGCONFIG+=r_core" ];
+  qmakeFlags = [
+    "CONFIG+=link_pkgconfig"
+    "PKGCONFIG+=r_core"
+    # Leaving this enabled doesn't break build but generates errors
+    # at runtime (to console) about being unable to load needed bits.
+    # Disable until can be looked at.
+    "CUTTER_ENABLE_JUPYTER=false"
+  ];
 
   # Fix crash on startup in some situations
   postInstall = ''