summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/compilers/gcc/4.6/builder.sh9
-rw-r--r--pkgs/development/compilers/gcc/4.6/default.nix10
2 files changed, 9 insertions, 10 deletions
diff --git a/pkgs/development/compilers/gcc/4.6/builder.sh b/pkgs/development/compilers/gcc/4.6/builder.sh
index 2f655ece1703..2bb185417390 100644
--- a/pkgs/development/compilers/gcc/4.6/builder.sh
+++ b/pkgs/development/compilers/gcc/4.6/builder.sh
@@ -243,13 +243,4 @@ postInstall() {
     eval "$postInstallGhdl"
 }
 
-
-if test -z "$targetConfig" && test -z "$crossConfig"; then
-    if test -z "$profiledCompiler"; then
-        buildFlags="bootstrap $buildFlags"
-    else    
-        buildFlags="profiledbootstrap $buildFlags"
-    fi
-fi
-
 genericBuild
diff --git a/pkgs/development/compilers/gcc/4.6/default.nix b/pkgs/development/compilers/gcc/4.6/default.nix
index e27f1a47f9c1..9a15faeaf1db 100644
--- a/pkgs/development/compilers/gcc/4.6/default.nix
+++ b/pkgs/development/compilers/gcc/4.6/default.nix
@@ -153,6 +153,8 @@ let version = "4.6.3";
       "-stage-final";
     crossNameAddon = if (cross != null) then "-${cross.config}" + stageNameAddon else "";
 
+  bootstrap = cross == null && !stdenv.isArm && !stdenv.isMips;
+
 in
 
 # We need all these X libraries when building AWT with GTK+.
@@ -227,7 +229,7 @@ stdenv.mkDerivation ({
         ''
     else null;
 
-  inherit noSysDirs profiledCompiler staticCompiler langJava crossStageStatic
+  inherit noSysDirs staticCompiler langJava crossStageStatic
     libcCross crossMingw;
 
   buildNativeInputs = [ texinfo which gettext ]
@@ -294,10 +296,15 @@ stdenv.mkDerivation ({
     ${if langAda then " --enable-libada" else ""}
     ${if (cross == null && stdenv.isi686) then "--with-arch=i686" else ""}
     ${if cross != null then crossConfigureFlags else ""}
+    ${if !bootstrap then "--disable-bootstrap" else ""}
   ";
 
   targetConfig = if (cross != null) then cross.config else null;
 
+  buildFlags = if bootstrap then
+    (if profiledCompiler then "profiledbootstrap" else "bootstrap")
+    else "";
+
   installTargets =
     if stripped
     then "install-strip"
@@ -347,6 +354,7 @@ stdenv.mkDerivation ({
       ${if cross != null then crossConfigureFlags else ""}
       --target=${stdenv.cross.config}
     '';
+    buildFlags = "";
   };