summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/libraries/gnutls/3.6.nix4
-rw-r--r--pkgs/development/libraries/libatomic_ops/default.nix2
-rw-r--r--pkgs/development/libraries/libseccomp/default.nix2
-rw-r--r--pkgs/development/libraries/poppler/default.nix45
-rw-r--r--pkgs/development/libraries/poppler/qt4.nix44
-rw-r--r--pkgs/development/python-modules/asgiref/default.nix22
-rw-r--r--pkgs/development/python-modules/bibtexparser/default.nix25
-rw-r--r--pkgs/development/python-modules/binaryornot/default.nix27
-rw-r--r--pkgs/development/python-modules/cram/default.nix16
-rw-r--r--pkgs/development/python-modules/curtsies/default.nix8
-rw-r--r--pkgs/development/python-modules/daphne/default.nix26
-rw-r--r--pkgs/development/python-modules/dbf/default.nix9
-rw-r--r--pkgs/development/python-modules/ecpy/default.nix5
-rw-r--r--pkgs/development/python-modules/faker/default.nix8
-rw-r--r--pkgs/development/python-modules/green/default.nix26
-rw-r--r--pkgs/development/python-modules/konfig/default.nix48
-rw-r--r--pkgs/development/python-modules/natsort/default.nix8
-rw-r--r--pkgs/development/python-modules/networkx/default.nix16
-rw-r--r--pkgs/development/python-modules/pomegranate/default.nix5
-rw-r--r--pkgs/development/python-modules/prov/default.nix16
-rw-r--r--pkgs/development/python-modules/pytest-mock/default.nix7
-rw-r--r--pkgs/development/python-modules/pytest-xdist/default.nix4
-rw-r--r--pkgs/development/python-modules/rednose/default.nix24
-rw-r--r--pkgs/development/python-modules/termstyle/default.nix20
-rw-r--r--pkgs/development/python-modules/text-unidecode/default.nix23
-rw-r--r--pkgs/development/python-modules/xdot/default.nix21
-rw-r--r--pkgs/development/tools/build-managers/meson/setup-hook.sh2
27 files changed, 104 insertions, 359 deletions
diff --git a/pkgs/development/libraries/gnutls/3.6.nix b/pkgs/development/libraries/gnutls/3.6.nix
index 7fb1af70a289..35344dfde7df 100644
--- a/pkgs/development/libraries/gnutls/3.6.nix
+++ b/pkgs/development/libraries/gnutls/3.6.nix
@@ -1,11 +1,11 @@
 { callPackage, fetchurl, ... } @ args:
 
 callPackage ./generic.nix (args // rec {
-  version = "3.6.2";
+  version = "3.6.1";
 
   src = fetchurl {
     url = "mirror://gnupg/gnutls/v3.6/gnutls-${version}.tar.xz";
-    sha256 = "07wdffklwmxpa9i50sh5nwrc5ajb47skrldm6rzjc0jf4dxxpmdw";
+    sha256 = "1vdsir53ddxyapnxh5fpnfyij3scx3818iri4hl07g4lk4n0vc90";
   };
 
   # Skip two tests introduced in 3.5.11.  Probable reasons of failure:
diff --git a/pkgs/development/libraries/libatomic_ops/default.nix b/pkgs/development/libraries/libatomic_ops/default.nix
index fe4cd3ca0a97..714e9361440c 100644
--- a/pkgs/development/libraries/libatomic_ops/default.nix
+++ b/pkgs/development/libraries/libatomic_ops/default.nix
@@ -12,8 +12,6 @@ stdenv.mkDerivation rec {
     sha256 ="1rif2hjscq5mh639nsnjhb90c01gnmy1sbmj6x6hsn1xmpnj95r1";
   };
 
-  outputs = [ "out" "dev" "doc" ];
-
   # https://github.com/ivmai/libatomic_ops/pull/32
   patches = if hostPlatform.isRiscV then [ ./riscv.patch ] else null;
 
diff --git a/pkgs/development/libraries/libseccomp/default.nix b/pkgs/development/libraries/libseccomp/default.nix
index d953fd12e68b..023c51c2b14f 100644
--- a/pkgs/development/libraries/libseccomp/default.nix
+++ b/pkgs/development/libraries/libseccomp/default.nix
@@ -9,8 +9,6 @@ stdenv.mkDerivation rec {
     sha256 = "0mdiyfljrkfl50q1m3ws8yfcyfjwf1zgkvcva8ffcwncji18zhkz";
   };
 
-  outputs = [ "out" "lib" "dev" "man" ];
-
   buildInputs = [ getopt makeWrapper ];
 
   patchPhase = ''
diff --git a/pkgs/development/libraries/poppler/default.nix b/pkgs/development/libraries/poppler/default.nix
index 9a3d24fc0b28..5fcb7d386faf 100644
--- a/pkgs/development/libraries/poppler/default.nix
+++ b/pkgs/development/libraries/poppler/default.nix
@@ -1,22 +1,24 @@
-{ stdenv, lib, fetchurl, cmake, ninja, pkgconfig, libiconv, libintlOrEmpty
+{ stdenv, lib, fetchurl, fetchpatch, pkgconfig, libiconv, libintlOrEmpty
 , zlib, curl, cairo, freetype, fontconfig, lcms, libjpeg, openjpeg
 , withData ? true, poppler_data
+, qt4Support ? false, qt4 ? null
 , qt5Support ? false, qtbase ? null
 , introspectionSupport ? false, gobjectIntrospection ? null
 , utils ? false
 , minimal ? false, suffix ? "glib"
+, hostPlatform
 }:
 
 let # beware: updates often break cups-filters build
-  version = "0.62.0";
-  mkFlag = optset: flag: "-DENABLE_${flag}=${if optset then "on" else "off"}";
+  version = "0.56.0";
+  sha256 = "0wviayidfv2ix2ql0d4nl9r1ia6qi5kc1nybd9vjx27dk7gvm7c6";
 in
 stdenv.mkDerivation rec {
   name = "poppler-${suffix}-${version}";
 
   src = fetchurl {
     url = "${meta.homepage}/poppler-${version}.tar.xz";
-    sha256 = "1ii9ly1pngyvs0aiq2wxpya08hidpl54y7nsb8b1vxnnskgp76jv";
+    inherit sha256;
   };
 
   outputs = [ "out" "dev" ];
@@ -27,19 +29,36 @@ stdenv.mkDerivation rec {
   propagatedBuildInputs = with lib;
     [ zlib freetype fontconfig libjpeg openjpeg ]
     ++ optionals (!minimal) [ cairo lcms curl ]
+    ++ optional qt4Support qt4
     ++ optional qt5Support qtbase
     ++ optional introspectionSupport gobjectIntrospection;
 
-  nativeBuildInputs = [ cmake ninja pkgconfig ];
+  nativeBuildInputs = [ pkgconfig ];
 
-  cmakeFlags = [
-    (mkFlag true "XPDF_HEADERS")
-    (mkFlag (!minimal) "GLIB")
-    (mkFlag (!minimal) "CPP")
-    (mkFlag (!minimal) "LIBCURL")
-    (mkFlag utils "UTILS")
-    (mkFlag qt5Support "QT5")
-  ];
+  NIX_CFLAGS_COMPILE = [ "-DQT_NO_DEBUG" ];
+
+  CXXFLAGS = lib.optional qt5Support "-std=c++11";
+
+  configureFlags = with lib;
+    [
+      "--enable-xpdf-headers"
+      "--enable-libcurl"
+      "--enable-zlib"
+      "--enable-build-type=release"
+    ]
+    ++ optionals minimal [
+      "--disable-poppler-glib" "--disable-poppler-cpp"
+      "--disable-libcurl"
+    ]
+    ++ optional (!utils) "--disable-utils"
+    ++ optional introspectionSupport "--enable-introspection";
+
+  enableParallelBuilding = true;
+
+  crossAttrs.postPatch =
+    # there are tests using `strXXX_s` functions that are missing apparently
+    stdenv.lib.optionalString (hostPlatform.libc or null == "msvcrt")
+      "sed '/^SUBDIRS =/s/ test / /' -i Makefile.in";
 
   meta = with lib; {
     homepage = https://poppler.freedesktop.org/;
diff --git a/pkgs/development/libraries/poppler/qt4.nix b/pkgs/development/libraries/poppler/qt4.nix
deleted file mode 100644
index c82a543413e2..000000000000
--- a/pkgs/development/libraries/poppler/qt4.nix
+++ /dev/null
@@ -1,44 +0,0 @@
-# TODO: get rid of this (https://github.com/NixOS/nixpkgs/issues/32883)
-{ stdenv, lib, fetchurl, cmake, ninja, pkgconfig, libiconv, libintlOrEmpty
-, zlib, curl, cairo, freetype, fontconfig, lcms2, libjpeg, openjpeg
-, poppler_data, qt4
-}:
-
-let
-  # Last version supporting QT4
-  version = "0.61.1";
-in
-stdenv.mkDerivation rec {
-  name = "poppler-qt4-${version}";
-
-  src = fetchurl {
-    url = "${meta.homepage}/poppler-${version}.tar.xz";
-    sha256 = "1afdrxxkaivvviazxkg5blsf2x24sjkfj92ib0d3q5pm8dihjrhj";
-  };
-
-  outputs = [ "out" "dev" ];
-
-  buildInputs = [ libiconv poppler_data ] ++ libintlOrEmpty;
-
-  propagatedBuildInputs = [ zlib freetype fontconfig libjpeg openjpeg cairo lcms2 curl qt4 ];
-
-  nativeBuildInputs = [ cmake ninja pkgconfig ];
-
-  cmakeFlags = [
-    "-DENABLE_XPDF_HEADERS=on"
-    "-DENABLE_UTILS=off"
-  ];
-
-  meta = with lib; {
-    homepage = https://poppler.freedesktop.org/;
-    description = "A PDF rendering library";
-
-    longDescription = ''
-      Poppler is a PDF rendering library based on the xpdf-3.0 code base.
-    '';
-
-    license = licenses.gpl2;
-    platforms = platforms.all;
-    maintainers = with maintainers; [ ttuegel ];
-  };
-}
diff --git a/pkgs/development/python-modules/asgiref/default.nix b/pkgs/development/python-modules/asgiref/default.nix
index 2b3be05d0608..223f53698e95 100644
--- a/pkgs/development/python-modules/asgiref/default.nix
+++ b/pkgs/development/python-modules/asgiref/default.nix
@@ -1,23 +1,15 @@
-{ stdenv, buildPythonPackage, fetchFromGitHub, async-timeout, pytest, pytest-asyncio }:
+{ stdenv, buildPythonPackage, fetchurl, six }:
 buildPythonPackage rec {
-  version = "2.1.6";
+  version = "2.1.5";
   pname = "asgiref";
+  name = "${pname}-${version}";
 
-  # PyPI tarball doesn't include tests directory
-  src = fetchFromGitHub {
-    owner = "django";
-    repo = pname;
-    rev = version;
-    sha256 = "12p1i2ai03x2hx6b3i7xgicyfi2x11is6pkbdac4jpz7fmbz3zlh";
+  src = fetchurl {
+    url = "mirror://pypi/a/asgiref/${name}.tar.gz";
+    sha256 = "1a46196df28c67e046a54cc537ce5a8f6a59eb68649f54680d7e4fc3b113ab1b";
   };
 
-  propagatedBuildInputs = [ async-timeout ];
-
-  checkInputs = [ pytest pytest-asyncio ];
-
-  checkPhase = ''
-    py.test
-  '';
+  propagatedBuildInputs = [ six ];
 
   meta = with stdenv.lib; {
     description = "Reference ASGI adapters and channel layers";
diff --git a/pkgs/development/python-modules/bibtexparser/default.nix b/pkgs/development/python-modules/bibtexparser/default.nix
index 06d7c689e659..50e389a9e14b 100644
--- a/pkgs/development/python-modules/bibtexparser/default.nix
+++ b/pkgs/development/python-modules/bibtexparser/default.nix
@@ -1,31 +1,20 @@
 { lib
 , buildPythonPackage
-, fetchFromGitHub
-, pyparsing
-, future
-, nose
-, glibcLocales
+, fetchPypi
 }:
 
 buildPythonPackage rec {
   pname = "bibtexparser";
   version = "1.0.1";
+  name = "${pname}-${version}";
 
-  # PyPI tarball does not ship tests
-  src = fetchFromGitHub {
-    owner = "sciunto-org";
-    repo = "python-${pname}";
-    rev = "v${version}";
-    sha256 = "0lmlarkfbq2hp1wa04a62245jr2mqizqsdlgilj5aq6vy92gr6ai";
+  src = fetchPypi {
+    inherit pname version;
+    sha256 = "cc41cdd8332c2bf44b97daf1f135f4f267c3b744c33976655cd270b66f964c0a";
   };
 
-  propagatedBuildInputs = [ pyparsing future ];
-
-  checkInputs = [ nose glibcLocales ];
-
-  checkPhase = ''
-    LC_ALL="en_US.UTF-8" nosetests
-  '';
+  # No tests in archive
+  doCheck = false;
 
   meta = {
     description = "Bibtex parser for python 2.7 and 3.3 and newer";
diff --git a/pkgs/development/python-modules/binaryornot/default.nix b/pkgs/development/python-modules/binaryornot/default.nix
deleted file mode 100644
index 2f0b01a5c23d..000000000000
--- a/pkgs/development/python-modules/binaryornot/default.nix
+++ /dev/null
@@ -1,27 +0,0 @@
-{ lib, buildPythonPackage, fetchPypi, chardet, hypothesis }:
-
-buildPythonPackage rec {
-  pname = "binaryornot";
-  version = "0.4.4";
-
-  src = fetchPypi {
-    inherit pname version;
-    sha256 = "359501dfc9d40632edc9fac890e19542db1a287bbcfa58175b66658392018061";
-  };
-
-  prePatch = ''
-    # See https://github.com/audreyr/binaryornot/issues/40
-    substituteInPlace tests/test_check.py \
-      --replace "average_size=512" "average_size=128"
-  '';
-
-  propagatedBuildInputs = [ chardet ];
-
-  checkInputs = [ hypothesis ];
-
-  meta = with lib; {
-    homepage = https://github.com/audreyr/binaryornot;
-    description = "Ultra-lightweight pure Python package to check if a file is binary or text";
-    license = licenses.bsd3;
-  };
-}
diff --git a/pkgs/development/python-modules/cram/default.nix b/pkgs/development/python-modules/cram/default.nix
index 232a4a19fd85..c0fc5b177e0a 100644
--- a/pkgs/development/python-modules/cram/default.nix
+++ b/pkgs/development/python-modules/cram/default.nix
@@ -1,10 +1,11 @@
-{stdenv, lib, buildPythonPackage, fetchPypi, bash, which, writeText}:
+{stdenv, lib, buildPythonPackage, fetchPypi, coverage, bash, which, writeText}:
 
 buildPythonPackage rec {
+  name = "${pname}-${version}";
   version = "0.7";
   pname = "cram";
 
-  checkInputs = [ which ];
+  buildInputs = [ coverage which ];
 
   src = fetchPypi {
     inherit pname version;
@@ -12,13 +13,20 @@ buildPythonPackage rec {
   };
 
   postPatch = ''
-    patchShebangs scripts/cram
     substituteInPlace tests/test.t \
       --replace "/bin/bash" "${bash}/bin/bash"
   '';
 
+  # This testing is copied from Makefile. Simply using `make test` doesn't work
+  # because it uses the unpatched `scripts/cram` executable which has a bad
+  # shebang. Also, for some reason, coverage fails on one file so let's just
+  # ignore that one.
   checkPhase = ''
-    scripts/cram tests
+    # scripts/cram tests
+    #COVERAGE=${coverage}/bin/coverage $out/bin/cram tests
+    #${coverage}/bin/coverage report --fail-under=100
+    COVERAGE=coverage $out/bin/cram tests
+    coverage report --fail-under=100 --omit="*/_encoding.py,*/__main__.py"
   '';
 
   meta = {
diff --git a/pkgs/development/python-modules/curtsies/default.nix b/pkgs/development/python-modules/curtsies/default.nix
index d29ad1d64745..8d6052c5299f 100644
--- a/pkgs/development/python-modules/curtsies/default.nix
+++ b/pkgs/development/python-modules/curtsies/default.nix
@@ -1,4 +1,4 @@
-{ stdenv, buildPythonPackage, fetchPypi, blessings, mock, nose, pyte, wcwidth, typing }:
+{ stdenv, buildPythonPackage, fetchPypi, blessings, mock, nose, pyte, pytest, wcwidth }:
 
 buildPythonPackage rec {
   pname = "curtsies";
@@ -8,12 +8,12 @@ buildPythonPackage rec {
     sha256 = "89c802ec051d01dec6fc983e9856a3706e4ea8265d2940b1f6d504a9e26ed3a9";
   };
 
-  propagatedBuildInputs = [ blessings wcwidth typing ];
+  propagatedBuildInputs = [ blessings wcwidth pyte ];
 
-  checkInputs = [ mock pyte nose ];
+  checkInputs = [ nose mock pytest ];
 
   checkPhase = ''
-    nosetests tests
+    py.test
   '';
 
   meta = with stdenv.lib; {
diff --git a/pkgs/development/python-modules/daphne/default.nix b/pkgs/development/python-modules/daphne/default.nix
index 7fafee56b422..86b00ca74085 100644
--- a/pkgs/development/python-modules/daphne/default.nix
+++ b/pkgs/development/python-modules/daphne/default.nix
@@ -1,31 +1,19 @@
-{ stdenv, buildPythonPackage, isPy3k, fetchFromGitHub
-, asgiref, autobahn, twisted, pytestrunner
-, hypothesis, pytest, pytest-asyncio
+{ stdenv, buildPythonPackage, fetchPypi,
+  asgiref, autobahn, twisted, hypothesis
 }:
 buildPythonPackage rec {
   pname = "daphne";
+  name = "${pname}-${version}";
   version = "2.0.3";
 
-  disabled = !isPy3k;
-
-  src = fetchFromGitHub {
-    owner = "django";
-    repo = pname;
-    rev = version;
-    sha256 = "1rdnzpgyk5cnx4xc3c7k11v2x9xpihgjpq14fib80jfpcqggw687";
+  src = fetchPypi {
+    inherit pname version;
+    sha256 = "bb2075ce35ca00f2e5440cc034dfebd5c00d346de62ea45f099db089b868c31f";
   };
 
-  nativeBuildInputs = [ pytestrunner ];
-
+  buildInputs = [ hypothesis ];
   propagatedBuildInputs = [ asgiref autobahn twisted ];
 
-  checkInputs = [ hypothesis pytest pytest-asyncio ];
-
-  checkPhase = ''
-    # Other tests fail, seems to be due to filesystem access
-    py.test -k "test_cli or test_utils"
-  '';
-
   meta = with stdenv.lib; {
     description = "Django ASGI (HTTP/WebSocket) server";
     license = licenses.bsd3;
diff --git a/pkgs/development/python-modules/dbf/default.nix b/pkgs/development/python-modules/dbf/default.nix
index ac8087be63ed..2343ea2918b1 100644
--- a/pkgs/development/python-modules/dbf/default.nix
+++ b/pkgs/development/python-modules/dbf/default.nix
@@ -1,24 +1,21 @@
-{ stdenv, fetchPypi, buildPythonPackage, aenum, isPy3k, pythonOlder, enum34, python }:
+{ stdenv, fetchPypi, buildPythonPackage, aenum, isPy3k }:
 
 buildPythonPackage rec {
     pname = "dbf";
     version = "0.96.8";
+    name = "${pname}-${version}";
 
     src = fetchPypi {
       inherit pname version;
       sha256 = "1z8n7s4cka6x9ybh4qpfhj51v2qrk38h2f06npizzhm0hmn6r3v1";
     };
 
-    propagatedBuildInputs = [ aenum ] ++ stdenv.lib.optional (pythonOlder "3.4") [ enum34 ];
+    propagatedBuildInputs = [ aenum ];
 
     doCheck = !isPy3k;
     # tests are not yet ported.
     # https://groups.google.com/forum/#!topic/python-dbase/96rx2xmCG4w
 
-    checkPhase = ''
-      ${python.interpreter} dbf/test.py
-    '';
-
     meta = with stdenv.lib; {
       description = "Pure python package for reading/writing dBase, FoxPro, and Visual FoxPro .dbf files";
       homepage    = "https://pypi.python.org/pypi/dbf";
diff --git a/pkgs/development/python-modules/ecpy/default.nix b/pkgs/development/python-modules/ecpy/default.nix
index 277a5cece567..84830e7f2b83 100644
--- a/pkgs/development/python-modules/ecpy/default.nix
+++ b/pkgs/development/python-modules/ecpy/default.nix
@@ -1,13 +1,12 @@
-{ stdenv, fetchPypi, buildPythonPackage, isPy3k, hidapi
+{ stdenv, fetchPypi, buildPythonPackage, hidapi
 , pycrypto, pillow, protobuf, future, ecpy
 }:
 
 buildPythonPackage rec {
+  name = "${pname}-${version}";
   pname = "ECPy";
   version = "0.8.3";
 
-  disabled = !isPy3k;
-
   src = fetchPypi {
     inherit pname version;
     sha256 = "ef3d95419d53368f52fb7d4b883b8df0dfc2dd19a76243422d24981c3e5f27bd";
diff --git a/pkgs/development/python-modules/faker/default.nix b/pkgs/development/python-modules/faker/default.nix
index 55750f5bf3b4..2d459d625d0a 100644
--- a/pkgs/development/python-modules/faker/default.nix
+++ b/pkgs/development/python-modules/faker/default.nix
@@ -1,6 +1,6 @@
 { lib, buildPythonPackage, fetchPypi, pythonOlder,
   # Build inputs
-  dateutil, six, text-unidecode, ipaddress ? null,
+  dateutil, six, ipaddress ? null,
   # Test inputs
   email_validator, nose, mock, ukpostcodeparser }:
 
@@ -8,11 +8,12 @@ assert pythonOlder "3.3" -> ipaddress != null;
 
 buildPythonPackage rec {
   pname = "Faker";
-  version = "0.8.11";
+  version = "0.8.8";
+  name = "${pname}-${version}";
 
   src = fetchPypi {
     inherit pname version;
-    sha256 = "126kdy6lj10rwgchzz0lzjabx0zcyskamhn0qib67k69fcksjmq8";
+    sha256 = "e928cf853ef69d7471421f2a3716a1239e43de0fa9855f4016ee0c9f1057328a";
   };
 
   checkInputs = [
@@ -25,7 +26,6 @@ buildPythonPackage rec {
   propagatedBuildInputs = [
     dateutil
     six
-    text-unidecode
   ] ++ lib.optional (pythonOlder "3.3") ipaddress;
 
   meta = with lib; {
diff --git a/pkgs/development/python-modules/green/default.nix b/pkgs/development/python-modules/green/default.nix
deleted file mode 100644
index fa09e4ded214..000000000000
--- a/pkgs/development/python-modules/green/default.nix
+++ /dev/null
@@ -1,26 +0,0 @@
-{ lib, buildPythonPackage, fetchPypi, isPy3k, colorama, coverage, termstyle, unidecode, mock, backports_shutil_get_terminal_size }:
-
-buildPythonPackage rec {
-  pname = "green";
-  version = "2.12.0";
-
-  src = fetchPypi {
-    inherit pname version;
-    sha256 = "8cdd2934eff754c9664f373ee0d77cb1cb35dbbf3b719b8ae3b059718db875df";
-  };
-
-  prePatch = ''
-    # See https://github.com/CleanCut/green/pull/182
-    substituteInPlace setup.py --replace python-termstyle termstyle
-  '';
-
-  propagatedBuildInputs = [
-    colorama coverage termstyle unidecode
-  ] ++ lib.optionals (!isPy3k) [ mock backports_shutil_get_terminal_size ];
-
-  meta = with lib; {
-    description = "Python test runner";
-    homepage = https://github.com/CleanCut/green;
-    license = licenses.mit;
-  };
-}
diff --git a/pkgs/development/python-modules/konfig/default.nix b/pkgs/development/python-modules/konfig/default.nix
deleted file mode 100644
index e7062bad5ee7..000000000000
--- a/pkgs/development/python-modules/konfig/default.nix
+++ /dev/null
@@ -1,48 +0,0 @@
-{ lib, buildPythonPackage, fetchFromGitHub, isPy3k, writeText, configparser, six, pytest, glibcLocales }:
-
-buildPythonPackage rec {
-  pname = "konfig";
-  version = "1.1";
-
-  # konfig unconditionaly depend on configparser, even if it is part of
-  # the standard library in python 3.2 or above.
-  disabled = isPy3k;
-
-  # PyPI tarball is missing utf8.ini, required for tests
-  src = fetchFromGitHub {
-    owner = "mozilla-services";
-    repo = pname;
-    rev = version;
-    sha256 = "1h780fbrv275dcik4cs3rincza805z6q726b48r4a0qmh5d8160c";
-  };
-
-  propagatedBuildInputs = [ configparser six ];
-
-  patches = [ (writeText "konfig.patch" ''
-    diff --git a/setup.py b/setup.py
-    index 96fd858..bb4db06 100644
-    --- a/setup.py
-    +++ b/setup.py
-    @@ -20,7 +20,7 @@ setup(name='konfig',
-           author_email="tarek@mozilla.com",
-           include_package_data=True,
-           install_requires = [
-    -        'configparser', 'argparse', 'six'
-    +        'configparser', 'six'
-           ],
-           zip_safe=False,
-           classifiers=classifiers,
-  '') ];
-
-  checkInputs = [ pytest glibcLocales ];
-
-  checkPhase = ''
-    LC_ALL=en_US.utf8 pytest -v konfig/tests
-  '';
-
-  meta = with lib; {
-    description = "Yet Another Config Parser";
-    homepage    = "https://github.com/mozilla-services/konfig";
-    license     = licenses.mpl20;
-  };
-}
diff --git a/pkgs/development/python-modules/natsort/default.nix b/pkgs/development/python-modules/natsort/default.nix
index 3e4b0d1368b7..a5940ed6c9f6 100644
--- a/pkgs/development/python-modules/natsort/default.nix
+++ b/pkgs/development/python-modules/natsort/default.nix
@@ -1,9 +1,12 @@
 { lib
 , buildPythonPackage
 , pythonOlder
+, isPy35
+, isPy36
 , fetchPypi
 , hypothesis
 , pytestcache
+, pytestcov
 , pytestflakes
 , pytestpep8
 , pytest
@@ -16,9 +19,10 @@ buildPythonPackage rec {
   pname = "natsort";
   version = "5.2.0";
 
-  checkInputs = [
+  buildInputs = [
     hypothesis
     pytestcache
+    pytestcov
     pytestflakes
     pytestpep8
     pytest
@@ -37,7 +41,7 @@ buildPythonPackage rec {
   # testing based on project's tox.ini
   checkPhase = ''
     pytest --doctest-modules natsort
-    pytest --flakes --pep8
+    pytest --flakes --pep8 --cov natsort --cov-report term-missing
   '';
 
   meta = {
diff --git a/pkgs/development/python-modules/networkx/default.nix b/pkgs/development/python-modules/networkx/default.nix
index 3388aef9cef1..f6fc4139c858 100644
--- a/pkgs/development/python-modules/networkx/default.nix
+++ b/pkgs/development/python-modules/networkx/default.nix
@@ -3,24 +3,32 @@
 , fetchPypi
 , nose
 , decorator
+, isPy36
+, isPyPy
 }:
 
 buildPythonPackage rec {
   pname = "networkx";
-  version = "2.1";
+  version = "1.11";
+
+  # Currently broken on PyPy.
+  # https://github.com/networkx/networkx/pull/1361
+  disabled = isPyPy;
 
   src = fetchPypi {
     inherit pname version;
-    extension = "zip";
-    sha256 = "64272ca418972b70a196cb15d9c85a5a6041f09a2f32e0d30c0255f25d458bb1";
+    sha256 = "1f74s56xb4ggixiq0vxyfxsfk8p20c7a099lpcf60izv1php03hd";
   };
 
   checkInputs = [ nose ];
   propagatedBuildInputs = [ decorator ];
 
+  # 17 failures with 3.6 https://github.com/networkx/networkx/issues/2396#issuecomment-304437299
+  doCheck = !(isPy36);
+
   meta = {
     homepage = "https://networkx.github.io/";
     description = "Library for the creation, manipulation, and study of the structure, dynamics, and functions of complex networks";
     license = lib.licenses.bsd3;
   };
-}
+}
\ No newline at end of file
diff --git a/pkgs/development/python-modules/pomegranate/default.nix b/pkgs/development/python-modules/pomegranate/default.nix
index e611e2ea5b10..77b373de259a 100644
--- a/pkgs/development/python-modules/pomegranate/default.nix
+++ b/pkgs/development/python-modules/pomegranate/default.nix
@@ -3,6 +3,7 @@
 buildPythonPackage rec {
   pname = "pomegranate";
   version = "0.8.1";
+  name  = "${pname}-${version}";
   
   src = fetchFromGitHub {
     repo = pname;
@@ -20,9 +21,5 @@ buildPythonPackage rec {
     homepage = https://github.com/jmschrei/pomegranate;
     license = licenses.mit;
     maintainers = with maintainers; [ rybern ];
-
-    # "pomegranate does not yet work with networkx 2.0"
-    # see https://github.com/jmschrei/pomegranate/issues/209
-    broken = true; 
   };
 }
diff --git a/pkgs/development/python-modules/prov/default.nix b/pkgs/development/python-modules/prov/default.nix
index f5f5b719b060..8866382ea8f2 100644
--- a/pkgs/development/python-modules/prov/default.nix
+++ b/pkgs/development/python-modules/prov/default.nix
@@ -7,8 +7,6 @@
 , six
 , pydotplus
 , rdflib
-, pydot
-, glibcLocales
 }:
 
 buildPythonPackage rec {
@@ -20,10 +18,6 @@ buildPythonPackage rec {
     sha256 = "640dc158d931403bc6c1a0ad80702caae71f810bac21f90ec605865c8444b7bb";
   };
 
-  prePatch = ''
-    substituteInPlace setup.py --replace "six==1.10.0" "six>=1.10.0"
-  '';
-
   propagatedBuildInputs = [
     lxml
     networkx
@@ -32,15 +26,7 @@ buildPythonPackage rec {
     pydotplus
     rdflib
   ];
-
-  checkInputs = [
-    pydot
-    glibcLocales
-  ];
-
-  preCheck = ''
-    export LC_ALL="en_US.utf-8"
-  '';
+  doCheck = false; # takes ~60 mins
 
   meta = with stdenv.lib; {
     description = "A Python library for W3C Provenance Data Model (PROV)";
diff --git a/pkgs/development/python-modules/pytest-mock/default.nix b/pkgs/development/python-modules/pytest-mock/default.nix
index 6b852583c7ed..51ec2a1f4cbc 100644
--- a/pkgs/development/python-modules/pytest-mock/default.nix
+++ b/pkgs/development/python-modules/pytest-mock/default.nix
@@ -1,4 +1,4 @@
-{ lib, buildPythonPackage, fetchPypi, fetchpatch, isPy3k, pytest, mock, setuptools_scm }:
+{ lib, buildPythonPackage, fetchPypi, isPy3k, pytest, mock, setuptools_scm }:
 
 buildPythonPackage rec {
   pname = "pytest-mock";
@@ -9,11 +9,6 @@ buildPythonPackage rec {
     sha256 = "8ed6c9ac6b7565b226b4da2da48876c9198d76401ec8d9c5e4c69b45423e33f8";
   };
 
-  patches = fetchpatch {
-    url = "${meta.homepage}/pull/107.patch";
-    sha256 = "07p7ra6lilfv04wyxc855zmfwxvnpmi9s0v6vh5bx769cj9jwxck";
-  };
-
   propagatedBuildInputs = [ pytest ] ++ lib.optional (!isPy3k) mock;
   nativeBuildInputs = [ setuptools_scm ];
 
diff --git a/pkgs/development/python-modules/pytest-xdist/default.nix b/pkgs/development/python-modules/pytest-xdist/default.nix
index 27aed12c3384..596ce38ed0ab 100644
--- a/pkgs/development/python-modules/pytest-xdist/default.nix
+++ b/pkgs/development/python-modules/pytest-xdist/default.nix
@@ -2,11 +2,11 @@
 
 buildPythonPackage rec {
   pname = "pytest-xdist";
-  version = "1.22.1";
+  version = "1.22.0";
 
   src = fetchPypi {
     inherit pname version;
-    sha256 = "fcd6f36bab93b0b24ec45ca12f798b9b3af71da826db0b0794b358d2f5c038de";
+    sha256 = "65228a859191f2c74ee68c127317eefe35eedd3d43fc1431f19240663b0cafcd";
   };
 
   nativeBuildInputs = [ setuptools_scm ];
diff --git a/pkgs/development/python-modules/rednose/default.nix b/pkgs/development/python-modules/rednose/default.nix
deleted file mode 100644
index d9736dcb6f39..000000000000
--- a/pkgs/development/python-modules/rednose/default.nix
+++ /dev/null
@@ -1,24 +0,0 @@
-{ lib, buildPythonPackage, fetchPypi, nose, six, colorama, termstyle }:
-
-buildPythonPackage rec {
-  pname = "rednose";
-  version = "1.3.0";
-
-  src = fetchPypi {
-    inherit pname version;
-    sha256 = "6da77917788be277b70259edc0bb92fc6f28fe268b765b4ea88206cc3543a3e1";
-  };
-
-  prePatch = ''
-    substituteInPlace setup.py --replace "six==1.10.0" "six>=1.10.0"
-  '';
-
-  checkInputs = [ six ];
-  propagatedBuildInputs = [ nose colorama termstyle ];
-
-  meta = with lib; {
-    description = "A python nose plugin adding color to console results";
-    homepage = https://github.com/JBKahn/rednose;
-    license = licenses.mit;
-  };
-}
diff --git a/pkgs/development/python-modules/termstyle/default.nix b/pkgs/development/python-modules/termstyle/default.nix
deleted file mode 100644
index 0a1c4e764129..000000000000
--- a/pkgs/development/python-modules/termstyle/default.nix
+++ /dev/null
@@ -1,20 +0,0 @@
-{ lib, buildPythonPackage, fetchPypi }:
-
-buildPythonPackage rec {
-  pname = "termstyle";
-  version = "0.1.11";
-
-  src = fetchPypi {
-    inherit pname version;
-    sha256 = "ef74b83698ea014112040cf32b1a093c1ab3d91c4dd18ecc03ec178fd99c9f9f";
-  };
-
-  # Only manual tests
-  doCheck = false;
-
-  meta = with lib; {
-    description = "Console colouring for python";
-    homepage = "https://pypi.python.org/pypi/python-termstyle/0.1.10";
-    license = licenses.bsdOriginal;
-  };
-}
diff --git a/pkgs/development/python-modules/text-unidecode/default.nix b/pkgs/development/python-modules/text-unidecode/default.nix
deleted file mode 100644
index 79ee34c733bc..000000000000
--- a/pkgs/development/python-modules/text-unidecode/default.nix
+++ /dev/null
@@ -1,23 +0,0 @@
-{ lib, buildPythonPackage, fetchPypi, pytest }:
-
-buildPythonPackage rec {
-  pname = "text-unidecode";
-  version = "1.1";
-
-  src = fetchPypi {
-    inherit pname version;
-    sha256 = "1l081m1w8ibbx684ca71ibdy68iwqsivy6rf6yqvysdclzldbbyh";
-  };
-
-  checkInputs = [ pytest ];
-
-  checkPhase = ''
-    py.test
-  '';
-
-  meta = with lib; {
-    description = "The most basic Text::Unidecode port";
-    homepage = https://github.com/kmike/text-unidecode;
-    license = licenses.artistic1;
-  };
-}
diff --git a/pkgs/development/python-modules/xdot/default.nix b/pkgs/development/python-modules/xdot/default.nix
deleted file mode 100644
index 526376a41632..000000000000
--- a/pkgs/development/python-modules/xdot/default.nix
+++ /dev/null
@@ -1,21 +0,0 @@
-{ lib, buildPythonPackage, fetchPypi
-, wrapGAppsHook, gobjectIntrospection, pygobject3, graphviz, gnome3 }:
-
-buildPythonPackage rec {
-  pname = "xdot";
-  version = "0.9";
-
-  src = fetchPypi {
-    inherit pname version;
-    sha256 = "01v9vmgdxz1q2m2vq2b4aqx4ycw7grc0l4is673ygvyg9rk02dx3";
-  };
-
-  nativeBuildInputs = [ wrapGAppsHook ];
-  propagatedBuildInputs = [ gobjectIntrospection pygobject3 graphviz gnome3.gtk ];
-
-  meta = with lib; {
-    description = "xdot.py is an interactive viewer for graphs written in Graphviz's dot";
-    homepage = https://github.com/jrfonseca/xdot.py;
-    license = licenses.lgpl3Plus;
-  };
-}
diff --git a/pkgs/development/tools/build-managers/meson/setup-hook.sh b/pkgs/development/tools/build-managers/meson/setup-hook.sh
index eeffa6bf6cf9..8f96e6146be0 100644
--- a/pkgs/development/tools/build-managers/meson/setup-hook.sh
+++ b/pkgs/development/tools/build-managers/meson/setup-hook.sh
@@ -29,7 +29,7 @@ fi
 mesonCheckPhase() {
     runHook preCheck
 
-    meson test --print-errorlogs
+    meson test
 
     runHook postCheck
 }