summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/libraries/dbus-sharp-glib/dbus-sharp-glib-1.0.nix1
-rw-r--r--pkgs/development/libraries/dbus-sharp-glib/default.nix1
-rw-r--r--pkgs/development/libraries/dbus-sharp/dbus-sharp-1.0.nix1
-rw-r--r--pkgs/development/libraries/dbus-sharp/default.nix1
-rw-r--r--pkgs/development/libraries/dclxvi/default.nix1
-rw-r--r--pkgs/development/libraries/enchant/default.nix5
-rw-r--r--pkgs/development/libraries/farstream/default.nix6
-rw-r--r--pkgs/development/libraries/giflib/libungif.nix6
-rw-r--r--pkgs/development/libraries/gobject-introspection/default.nix1
-rw-r--r--pkgs/development/libraries/hwloc/default.nix9
-rw-r--r--pkgs/development/ocaml-modules/elpi/default.nix4
-rw-r--r--pkgs/development/ocaml-modules/ulex/0.8/camlp5.patch72
-rw-r--r--pkgs/development/ocaml-modules/ulex/0.8/default.nix36
-rw-r--r--pkgs/development/ocaml-modules/ulex/0.8/meta_version.patch10
-rw-r--r--pkgs/development/tools/goa/default.nix6
-rw-r--r--pkgs/development/tools/goa/deps.nix67
16 files changed, 42 insertions, 185 deletions
diff --git a/pkgs/development/libraries/dbus-sharp-glib/dbus-sharp-glib-1.0.nix b/pkgs/development/libraries/dbus-sharp-glib/dbus-sharp-glib-1.0.nix
index 208288bfca1d..0f897d97467f 100644
--- a/pkgs/development/libraries/dbus-sharp-glib/dbus-sharp-glib-1.0.nix
+++ b/pkgs/development/libraries/dbus-sharp-glib/dbus-sharp-glib-1.0.nix
@@ -20,5 +20,6 @@ stdenv.mkDerivation rec {
   meta = with stdenv.lib; {
     description = "D-Bus for .NET: GLib integration module";
     platforms = platforms.linux;
+    license = licenses.mit;
   };
 }
diff --git a/pkgs/development/libraries/dbus-sharp-glib/default.nix b/pkgs/development/libraries/dbus-sharp-glib/default.nix
index ef1ddd9bfff5..cd020317f4c2 100644
--- a/pkgs/development/libraries/dbus-sharp-glib/default.nix
+++ b/pkgs/development/libraries/dbus-sharp-glib/default.nix
@@ -20,5 +20,6 @@ stdenv.mkDerivation rec {
   meta = with stdenv.lib; {
     description = "D-Bus for .NET: GLib integration module";
     platforms = platforms.linux;
+    license = licenses.mit;
   };
 }
diff --git a/pkgs/development/libraries/dbus-sharp/dbus-sharp-1.0.nix b/pkgs/development/libraries/dbus-sharp/dbus-sharp-1.0.nix
index 013913e52972..18ea3ad3ecb7 100644
--- a/pkgs/development/libraries/dbus-sharp/dbus-sharp-1.0.nix
+++ b/pkgs/development/libraries/dbus-sharp/dbus-sharp-1.0.nix
@@ -20,5 +20,6 @@ stdenv.mkDerivation rec {
   meta = with stdenv.lib; {
     description = "D-Bus for .NET";
     platforms = platforms.linux;
+    license = licenses.mit;
   };
 }
diff --git a/pkgs/development/libraries/dbus-sharp/default.nix b/pkgs/development/libraries/dbus-sharp/default.nix
index 855dd9f3832e..2704ef2de9fd 100644
--- a/pkgs/development/libraries/dbus-sharp/default.nix
+++ b/pkgs/development/libraries/dbus-sharp/default.nix
@@ -23,5 +23,6 @@ stdenv.mkDerivation rec {
   meta = with stdenv.lib; {
     description = "D-Bus for .NET";
     platforms = platforms.linux;
+    license = licenses.mit;
   };
 }
diff --git a/pkgs/development/libraries/dclxvi/default.nix b/pkgs/development/libraries/dclxvi/default.nix
index 47f3794f5ad5..1f8f9a4e69cc 100644
--- a/pkgs/development/libraries/dclxvi/default.nix
+++ b/pkgs/development/libraries/dclxvi/default.nix
@@ -31,5 +31,6 @@ stdenv.mkDerivation {
     description = "Naehrig, Niederhagen and Schwabe's pairings code, massaged into a shared library";
     maintainers = with maintainers; [ wkennington ];
     platforms = platforms.x86_64;
+    license = licenses.publicDomain;
   };
 }
diff --git a/pkgs/development/libraries/enchant/default.nix b/pkgs/development/libraries/enchant/default.nix
index c51475ecc2a9..a9446306d335 100644
--- a/pkgs/development/libraries/enchant/default.nix
+++ b/pkgs/development/libraries/enchant/default.nix
@@ -13,9 +13,10 @@ stdenv.mkDerivation rec {
   nativeBuildInputs = [ pkgconfig ];
   buildInputs = [ aspell glib hunspell hspell ];
 
-  meta = {
+  meta = with stdenv.lib; {
     description = "Generic spell checking library";
     homepage = http://www.abisource.com/enchant;
-    platforms = stdenv.lib.platforms.unix;
+    platforms = platforms.unix;
+    license = licenses.lgpl21;
   };
 }
diff --git a/pkgs/development/libraries/farstream/default.nix b/pkgs/development/libraries/farstream/default.nix
index 020d04542864..924fb52b0900 100644
--- a/pkgs/development/libraries/farstream/default.nix
+++ b/pkgs/development/libraries/farstream/default.nix
@@ -24,10 +24,10 @@ in stdenv.mkDerivation rec {
     gst-plugins-good gst-plugins-bad gst-libav
   ];
 
-  meta = {
+  meta = with stdenv.lib; {
     homepage = https://www.freedesktop.org/wiki/Software/Farstream;
     description = "Audio/Video Communications Framework formely known as farsight";
-    maintainers = [ ];
-    platforms = stdenv.lib.platforms.linux;
+    platforms = platforms.linux;
+    license = licenses.lgpl21;
   };
 }
diff --git a/pkgs/development/libraries/giflib/libungif.nix b/pkgs/development/libraries/giflib/libungif.nix
index 357ca751ccf1..6336d30aebad 100644
--- a/pkgs/development/libraries/giflib/libungif.nix
+++ b/pkgs/development/libraries/giflib/libungif.nix
@@ -9,7 +9,9 @@ stdenv.mkDerivation {
 
   hardeningDisable = [ "format" ];
 
-  meta = {
-    platforms = stdenv.lib.platforms.unix;
+  meta = with stdenv.lib; {
+    description = "Library and utilities for processing GIFs";
+    platforms = platforms.unix;
+    license = licenses.mit;
   };
 }
diff --git a/pkgs/development/libraries/gobject-introspection/default.nix b/pkgs/development/libraries/gobject-introspection/default.nix
index b2c0a9f89a48..482710f18df5 100644
--- a/pkgs/development/libraries/gobject-introspection/default.nix
+++ b/pkgs/development/libraries/gobject-introspection/default.nix
@@ -63,6 +63,7 @@ stdenv.mkDerivation rec {
     homepage    = http://live.gnome.org/GObjectIntrospection;
     maintainers = with maintainers; [ lovek323 lethalman ];
     platforms   = platforms.unix;
+    license = with licenses; [ gpl2 lgpl2 ];
 
     longDescription = ''
       GObject introspection is a middleware layer between C libraries (using
diff --git a/pkgs/development/libraries/hwloc/default.nix b/pkgs/development/libraries/hwloc/default.nix
index 90a16bcf7f94..8f38170d87e4 100644
--- a/pkgs/development/libraries/hwloc/default.nix
+++ b/pkgs/development/libraries/hwloc/default.nix
@@ -7,15 +7,16 @@ assert x11Support -> libX11 != null && cairo != null;
 with stdenv.lib;
 
 stdenv.mkDerivation rec {
-  name = "hwloc-1.11.10";
+  name = "hwloc-2.0.2";
 
   src = fetchurl {
-    url = "http://www.open-mpi.org/software/hwloc/v1.11/downloads/${name}.tar.bz2";
-    sha256 = "1ryibcng40xcq22lsj85fn2vcvrksdx9rr3wwxpq8dw37lw0is1b";
+    url = "http://www.open-mpi.org/software/hwloc/v2.0/downloads/${name}.tar.bz2";
+    sha256 = "1phc863d5b2fvwpyyq4mlh4rkjdslh6h0h197zmyk3prwrq7si8l";
   };
 
   configureFlags = [
     "--localstatedir=/var"
+    "--enable-netloc"
   ];
 
   # XXX: libX11 is not directly needed, but needed as a propagated dep of Cairo.
@@ -75,7 +76,7 @@ stdenv.mkDerivation rec {
     # http://www.open-mpi.org/projects/hwloc/license.php
     license = licenses.bsd3;
     homepage = https://www.open-mpi.org/projects/hwloc/;
-    maintainers = with maintainers; [ fpletz ];
+    maintainers = with maintainers; [ fpletz markuskowa ];
     platforms = platforms.all;
   };
 }
diff --git a/pkgs/development/ocaml-modules/elpi/default.nix b/pkgs/development/ocaml-modules/elpi/default.nix
index db188a720b88..3eecb9b45b7d 100644
--- a/pkgs/development/ocaml-modules/elpi/default.nix
+++ b/pkgs/development/ocaml-modules/elpi/default.nix
@@ -1,4 +1,4 @@
-{ stdenv, fetchFromGitHub, ocaml, findlib, camlp5_strict
+{ stdenv, fetchFromGitHub, ocaml, findlib, camlp5
 , ppx_tools_versioned, ppx_deriving, re
 }:
 
@@ -14,7 +14,7 @@ stdenv.mkDerivation rec {
 
   buildInputs = [ ocaml findlib ppx_tools_versioned ];
 
-  propagatedBuildInputs = [ camlp5_strict ppx_deriving re ];
+  propagatedBuildInputs = [ camlp5 ppx_deriving re ];
 
   createFindlibDestdir = true;
 
diff --git a/pkgs/development/ocaml-modules/ulex/0.8/camlp5.patch b/pkgs/development/ocaml-modules/ulex/0.8/camlp5.patch
deleted file mode 100644
index 2fa92527035e..000000000000
--- a/pkgs/development/ocaml-modules/ulex/0.8/camlp5.patch
+++ /dev/null
@@ -1,72 +0,0 @@
-Author: Stefano Zacchiroli <zack@debian.org>
-Description: build (and install) using camlp5 instead of camlp4
---- ulex0.8.orig/META
-+++ ulex0.8/META
-@@ -1,5 +1,5 @@
- version = "0.8"
--requires = "camlp4"
-+requires = "camlp5"
- description = "Runtime support for ulex"
- archive(byte) = "ulexing.cma"
- archive(native) = "ulexing.cmxa"
---- ulex0.8.orig/Makefile
-+++ ulex0.8/Makefile
-@@ -20,7 +20,7 @@
- 	ocamlopt -a -o ulexing.cmxa $(ULEXING)
- 
- pa_ulex.cma: $(ULEX)
--	ocamlc -a -o pa_ulex.cma -pp 'camlp4o pa_extend.cmo q_MLast.cmo' -I +camlp4 $(ULEX)
-+	ocamlc -a -o pa_ulex.cma -pp 'camlp5o pa_extend.cmo q_MLast.cmo' -I `camlp5 -where` $(ULEX)
- 
- pa_ulex.ml: pa_ulex.ml.src
- 	ocaml mk_pa_ulex.ml
-@@ -29,14 +29,14 @@
- 	rm -f *.cm* *~ test custom_ulexing *.o *.a *.html *.css pa_ulex.ml
- 
- view_test: pa_ulex.cma
--	camlp4o ./pa_ulex.cma pr_o.cmo -sep "\n" test.ml
-+	camlp5o ./pa_ulex.cma pr_o.cmo -sep "\n" test.ml
- 
- run_test: ulexing.cma pa_ulex.cma
--	ocamlc -o test -pp 'camlp4o ./pa_ulex.cma' ulexing.cma test.ml
-+	ocamlc -o test -pp 'camlp5o ./pa_ulex.cma' ulexing.cma test.ml
- 	./test
- 
- custom_ulexing: ulexing.cma pa_ulex.cma
--	ocamlc -o custom_ulexing -pp 'camlp4o ./pa_ulex.cma' ulexing.cma custom_ulexing.ml
-+	ocamlc -o custom_ulexing -pp 'camlp5o ./pa_ulex.cma' ulexing.cma custom_ulexing.ml
- 
- 
- doc:
---- ulex0.8.orig/README
-+++ ulex0.8/README
-@@ -142,7 +142,7 @@
- 
- Compilation of OCaml files with lexer specifications:
- 
--  ocamlfind ocamlc -c -package ulex -syntax camlp4o my_file.ml
-+  ocamlfind ocamlc -c -package ulex -syntax camlp5o my_file.ml
- 
- When linking, you must also include the ulex package:
-   ocamlfind ocamlc -o my_prog -linkpkg -package ulex my_file.cmo
---- ulex0.8.orig/mk_pa_ulex.ml
-+++ ulex0.8/mk_pa_ulex.ml
-@@ -1,10 +1,4 @@
- let s = float_of_string (String.sub (Sys.ocaml_version) 0 4) in
--if (s < 3.09) then (
-   print_endline "Old camlp4 (loc)";
-   Sys.command "sed s/_loc/loc/ < pa_ulex.ml.src > pa_ulex.ml"
--)
--else  (
--  print_endline "New camlp4 (_loc)";
--  Sys.command "cp pa_ulex.ml.src pa_ulex.ml"
--)
- 
---- ulex0.8.orig/pa_ulex.ml.src
-+++ ulex0.8/pa_ulex.ml.src
-@@ -1,4 +1,4 @@
--let _loc = (Lexing.dummy_pos,Lexing.dummy_pos)
-+let _loc = Stdpp.dummy_loc
- 
- (* Named regexp *)
- 
diff --git a/pkgs/development/ocaml-modules/ulex/0.8/default.nix b/pkgs/development/ocaml-modules/ulex/0.8/default.nix
deleted file mode 100644
index 6c0cf9214f29..000000000000
--- a/pkgs/development/ocaml-modules/ulex/0.8/default.nix
+++ /dev/null
@@ -1,36 +0,0 @@
-{stdenv, fetchurl, ocaml, findlib, camlp5 }:
-
-let
-  pname = "ulex";
-in
-
-if stdenv.lib.versionAtLeast ocaml.version "4.06"
-then throw "ulex-0.8 is not available for OCaml ${ocaml.version}"
-else
-
-stdenv.mkDerivation rec {
-  name = "${pname}-${version}";
-  version = "0.8";
-
-  src = fetchurl {
-    url = "http://www.cduce.org/download/old/${pname}-${version}.tar.gz";
-    sha256 = "19faabg8hzz155xlzmjwsl59d7slahb5m1l9zh1fqvvpp81r26cp";
-  };
-
-  buildInputs = [ocaml findlib camlp5];
-
-  createFindlibDestdir = true;
-
-  patches = [ ./meta_version.patch ./camlp5.patch ];
-
-  propagatedBuildInputs = [ camlp5 ];
-
-  buildFlags = "all all.opt";
-
-  meta = {
-    homepage = http://www.cduce.org/download.html;
-    description = "A lexer generator for Unicode and OCaml";
-    license = stdenv.lib.licenses.mit;
-    maintainers = [ stdenv.lib.maintainers.roconnor ];
-  };
-}
diff --git a/pkgs/development/ocaml-modules/ulex/0.8/meta_version.patch b/pkgs/development/ocaml-modules/ulex/0.8/meta_version.patch
deleted file mode 100644
index 7a39510cf0b4..000000000000
--- a/pkgs/development/ocaml-modules/ulex/0.8/meta_version.patch
+++ /dev/null
@@ -1,10 +0,0 @@
-Author: Stefano Zacchiroli <zack@debian.org>
-Description: fix a typo in the findlib package version number specified in META
---- ulex0.8.orig/META
-+++ ulex0.8/META
-@@ -1,4 +1,4 @@
--version = "0.7"
-+version = "0.8"
- requires = "camlp4"
- description = "Runtime support for ulex"
- archive(byte) = "ulexing.cma"
diff --git a/pkgs/development/tools/goa/default.nix b/pkgs/development/tools/goa/default.nix
index dfb603d101fc..7469d506244b 100644
--- a/pkgs/development/tools/goa/default.nix
+++ b/pkgs/development/tools/goa/default.nix
@@ -1,8 +1,8 @@
-{ stdenv, buildGoPackage, fetchFromGitHub, makeWrapper }:
+{ stdenv, buildGoPackage, fetchFromGitHub }:
 
 buildGoPackage rec {
   name = "goa-${version}";
-  version = "1.0.0";
+  version = "1.4.0";
 
   goPackagePath = "github.com/goadesign/goa";
   subPackages = [ "goagen" ];
@@ -11,7 +11,7 @@ buildGoPackage rec {
     owner = "goadesign";
     repo = "goa";
     rev = "v${version}";
-    sha256 = "13401jf907z3qh11h9clb3z0i0fshwkmhx11fq9z6vx01x8x2in1";
+    sha256 = "1qx3c7dyq5wqxidfrk3ywc55fk64najj63f2jmfisfq4ixgwxdw9";
   };
 
   goDeps = ./deps.nix;
diff --git a/pkgs/development/tools/goa/deps.nix b/pkgs/development/tools/goa/deps.nix
index 14e9234be8a2..d92489259055 100644
--- a/pkgs/development/tools/goa/deps.nix
+++ b/pkgs/development/tools/goa/deps.nix
@@ -1,39 +1,12 @@
-# This file was generated by go2nix.
+# This file was generated by https://github.com/kamilchm/go2nix v1.2.1
 [
   {
-    goPackagePath = "github.com/armon/go-metrics";
-    fetch = {
-      type = "git";
-      url = "https://github.com/armon/go-metrics";
-      rev = "3df31a1ada83e310c2e24b267c8e8b68836547b4";
-      sha256 = "1l99f1bzvdhyqhnsrpi1pd07bps0msilzilrd7m4w7i1m5kra529";
-    };
-  }
-  {
     goPackagePath = "github.com/dimfeld/httppath";
     fetch = {
       type = "git";
       url = "https://github.com/dimfeld/httppath";
-      rev = "c8e499c3ef3c3e272ed8bdcc1ccf39f73c88debc";
-      sha256 = "0452zvrzjvy8pk5q6ykivz2cks082r4lmh7hghscxfqw6gf3siwi";
-    };
-  }
-  {
-    goPackagePath = "github.com/dimfeld/httptreemux";
-    fetch = {
-      type = "git";
-      url = "https://github.com/dimfeld/httptreemux";
-      rev = "96acf0909c0b45ebf4a25a816cedc6d317e63679";
-      sha256 = "0f9qbm1b8l7b21i2v8vmjyzfwf1mgkvxlk5250bwkp5i8n4ml2r6";
-    };
-  }
-  {
-    goPackagePath = "github.com/goadesign/goa";
-    fetch = {
-      type = "git";
-      url = "https://github.com/goadesign/goa";
-      rev = "ea323df387ea68f8ac9fd79336f523c25e12c92e";
-      sha256 = "13401jf907z3qh11h9clb3z0i0fshwkmhx11fq9z6vx01x8x2in1";
+      rev = "ee938bf735983d53694d79138ad9820efff94c92";
+      sha256 = "1c1kic8g3r78g6h4xl8n2ac1waxsb9fqz40k20ypi08k24mv3ha9";
     };
   }
   {
@@ -41,8 +14,8 @@
     fetch = {
       type = "git";
       url = "https://github.com/manveru/faker";
-      rev = "717f7cf83fb78669bfab612749c2e8ff63d5be11";
-      sha256 = "1p6laz0hnb2vhfvam83rz6vl2amajqa6nifnsj2lg3mcs9ga8c0f";
+      rev = "9fbc68a78c4dbc7914e1a23f88f126bea4383b97";
+      sha256 = "1cnrf4wdjhxd9fryhlp2krl9acz6dzwic89gshs49pg3aajlf4dy";
     };
   }
   {
@@ -50,8 +23,8 @@
     fetch = {
       type = "git";
       url = "https://github.com/satori/go.uuid";
-      rev = "0aa62d5ddceb50dbcb909d790b5345affd3669b6";
-      sha256 = "1vfzfcspanxcbpdpv49580rh6kamzcs3lm70xnx724mkwi41zi8w";
+      rev = "36e9d2ebbde5e3f13ab2e25625fd453271d6522e";
+      sha256 = "0nc0ggn0a6bcwdrwinnx3z6889x65c20a2dwja0n8can3xblxs35";
     };
   }
   {
@@ -59,8 +32,8 @@
     fetch = {
       type = "git";
       url = "https://github.com/spf13/cobra";
-      rev = "9c28e4bbd74e5c3ed7aacbc552b2cab7cfdfe744";
-      sha256 = "02bgp0yy9bi05k2in9axqi3db1c6mjffdsmki51pn9iryxz4zkh3";
+      rev = "4dab30cb33e6633c33c787106bafbfbfdde7842d";
+      sha256 = "1g7p7c2azqaxbfkx5yaznk0z1inqnajlbwv921k6vh8i1xdblxk5";
     };
   }
   {
@@ -68,8 +41,8 @@
     fetch = {
       type = "git";
       url = "https://github.com/spf13/pflag";
-      rev = "c7e63cf4530bcd3ba943729cee0efeff2ebea63f";
-      sha256 = "197mlkgb01zk86fxfl8r8maymcxsspqblg7hmngjxf7ivdid1i1l";
+      rev = "1ce0cc6db4029d97571db82f85092fccedb572ce";
+      sha256 = "02wsc01npnpc7srqw7rzaihn2hjmrkfy2x412fxbb675j2hk9cx6";
     };
   }
   {
@@ -82,21 +55,12 @@
     };
   }
   {
-    goPackagePath = "golang.org/x/net";
-    fetch = {
-      type = "git";
-      url = "https://go.googlesource.com/net";
-      rev = "71a035914f99bb58fe82eac0f1289f10963d876c";
-      sha256 = "06m16c9vkwc8m2mcxcxa7p8mb26ikc810lgzd5m8k1r6lp3hc8wm";
-    };
-  }
-  {
     goPackagePath = "golang.org/x/tools";
     fetch = {
       type = "git";
       url = "https://go.googlesource.com/tools";
-      rev = "f1a397bba50dee815e8c73f3ec94ffc0e8df1a09";
-      sha256 = "1wy8nn2vg70n98g80i1zrk49129phyfbzxbicj748bmf82rnaxzg";
+      rev = "f60d9635b16a5a57b06eaa119614ba4df421966a";
+      sha256 = "1h587gvgwlpjdn8q3s8i1blfwfklqi0cpb0szj99w1mkgl0ads13";
     };
   }
   {
@@ -104,8 +68,9 @@
     fetch = {
       type = "git";
       url = "https://gopkg.in/yaml.v2";
-      rev = "31c299268d302dd0aa9a0dcf765a3d58971ac83f";
-      sha256 = "14jkpa8g0s448n2x5qdi05m59ncsdscby1wy2p089zxl9nqavm8h";
+      rev = "5420a8b6744d3b0345ab293f6fcba19c978f1183";
+      sha256 = "0dwjrs2lp2gdlscs7bsrmyc5yf6mm4fvgw71bzr9mv2qrd2q73s1";
     };
   }
 ]
+