summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/compilers/chicken/default.nix4
-rw-r--r--pkgs/development/libraries/libffi/default.nix12
2 files changed, 6 insertions, 10 deletions
diff --git a/pkgs/development/compilers/chicken/default.nix b/pkgs/development/compilers/chicken/default.nix
index a1eec63af561..3b9d4d391188 100644
--- a/pkgs/development/compilers/chicken/default.nix
+++ b/pkgs/development/compilers/chicken/default.nix
@@ -5,9 +5,9 @@ let
   platform = with stdenv;
     if isDarwin then "macosx"
     else if isCygwin then "cygwin"
-    else if isBSD then "bsd"
+    else if (isFreeBSD || isOpenBSD) then "bsd"
     else if isSunOS then "solaris"
-    else "linux";               # Should be a sane default
+    else "linux"; # Should be a sane default
   lib = stdenv.lib;
 in
 stdenv.mkDerivation {
diff --git a/pkgs/development/libraries/libffi/default.nix b/pkgs/development/libraries/libffi/default.nix
index cdcba4756aaa..a1f6716009ee 100644
--- a/pkgs/development/libraries/libffi/default.nix
+++ b/pkgs/development/libraries/libffi/default.nix
@@ -21,14 +21,13 @@ stdenv.mkDerivation rec {
 
   dontStrip = stdenv ? cross; # Don't run the native `strip' when cross-compiling.
 
-  postInstall =
-    # Install headers in the right place.
-    '' ln -s${if stdenv.isBSD then "" else "r"}v "$out/lib/"libffi*/include "$out/include"
-    '';
+  # Install headers in the right place.
+  postInstall = ''
+    ln -s${if (stdenv.isFreeBSD || stdenv.isOpenBSD || stdenv.isDarwin) then "" else "r"}v "$out/lib/"libffi*/include "$out/include"
+  '';
 
   meta = {
     description = "A foreign function call interface library";
-
     longDescription = ''
       The libffi library provides a portable, high level programming
       interface to various calling conventions.  This allows a
@@ -43,12 +42,9 @@ stdenv.mkDerivation rec {
       interface.  A layer must exist above libffi that handles type
       conversions for values passed between the two languages.
     '';
-
     homepage = http://sourceware.org/libffi/;
-
     # See http://github.com/atgreen/libffi/blob/master/LICENSE .
     license = stdenv.lib.licenses.free;
-
     maintainers = [ ];
     platforms = stdenv.lib.platforms.all;
   };