summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/tools/build-managers/qbs/default.nix41
1 files changed, 41 insertions, 0 deletions
diff --git a/pkgs/development/tools/build-managers/qbs/default.nix b/pkgs/development/tools/build-managers/qbs/default.nix
new file mode 100644
index 000000000000..dc2d545a7654
--- /dev/null
+++ b/pkgs/development/tools/build-managers/qbs/default.nix
@@ -0,0 +1,41 @@
+{ stdenv, qt5, fetchFromGitHub }:
+
+stdenv.mkDerivation rec {
+  name = "qbs-${version}";
+
+  version = "1.8";
+
+  src = fetchFromGitHub {
+    owner = "qt-labs";
+    repo = "qbs";
+    rev = "fa9c21d6908e0dad805113f570ac883c1dc5067a";
+    sha256 = "1manriz75rav1vldkk829yk1la9md4m872l5ykl9m982i9801d9g";
+  };
+
+  enableParallelBuilding = true;
+
+  buildInputs = with qt5; [
+    qtbase
+    qtscript
+  ];
+
+  installFlags = [ "INSTALL_ROOT=$(out)" ];
+
+  buildPhase = ''
+    # From http://doc.qt.io/qbs/building.html
+    qmake -r qbs.pro
+    make
+  '';
+
+  postInstall = ''
+    mv $out/usr/local/* "$out"
+  '';
+
+  meta = with stdenv.lib; {
+    description = "A tool that helps simplify the build process for developing projects across multiple platforms";
+    license = licenses.lgpl21;
+    maintainers = with maintainers; [ expipiplus1 ];
+    inherit version;
+    platforms = platforms.linux;
+  };
+}