summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/libraries/haskell/amqp/default.nix15
1 files changed, 11 insertions, 4 deletions
diff --git a/pkgs/development/libraries/haskell/amqp/default.nix b/pkgs/development/libraries/haskell/amqp/default.nix
index 70e86ef1ffb7..432d353a0af6 100644
--- a/pkgs/development/libraries/haskell/amqp/default.nix
+++ b/pkgs/development/libraries/haskell/amqp/default.nix
@@ -1,12 +1,19 @@
-{ cabal, binary, dataBinaryIeee754, network, text, xml }:
+{ cabal, binary, clock, dataBinaryIeee754, hspec, hspecExpectations
+, network, split, text, xml
+}:
 
 cabal.mkDerivation (self: {
   pname = "amqp";
-  version = "0.6.0";
-  sha256 = "0rfczmhf46sc3pxxb5gwv4ggsxkqkvdi4kkqdnrdpdhs7p41im2n";
+  version = "0.7.0";
+  sha256 = "09zazmbdw8nphbjkmixn2dpwdgkjqjfbn6jv522ykvrcnsn35kc4";
   isLibrary = true;
   isExecutable = true;
-  buildDepends = [ binary dataBinaryIeee754 network text xml ];
+  buildDepends = [
+    binary clock dataBinaryIeee754 network split text xml
+  ];
+  testDepends = [
+    binary dataBinaryIeee754 hspec hspecExpectations network split text
+  ];
   meta = {
     homepage = "https://github.com/hreinhardt/amqp";
     description = "Client library for AMQP servers (currently only RabbitMQ)";