summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/ocaml-modules/async/default.nix4
-rw-r--r--pkgs/development/ocaml-modules/async_extra/default.nix4
-rw-r--r--pkgs/development/ocaml-modules/async_unix/default.nix4
-rw-r--r--pkgs/development/ocaml-modules/janestreet/async-kernel.nix16
4 files changed, 22 insertions, 6 deletions
diff --git a/pkgs/development/ocaml-modules/async/default.nix b/pkgs/development/ocaml-modules/async/default.nix
index 2b84519036c7..2ddfc40b8f86 100644
--- a/pkgs/development/ocaml-modules/async/default.nix
+++ b/pkgs/development/ocaml-modules/async/default.nix
@@ -1,4 +1,4 @@
-{stdenv, buildOcaml, fetchurl, async_kernel,
+{stdenv, buildOcaml, fetchurl, async_kernel_p4,
  async_unix, async_extra, pa_ounit}:
 
 buildOcaml rec {
@@ -12,7 +12,7 @@ buildOcaml rec {
     sha256 = "ecc4ca939ab098e689332921b110dbaacd06d9f8d8bf697023dfff3ca37dc1e9";
   };
 
-  propagatedBuildInputs = [ async_kernel async_unix async_extra pa_ounit ];
+  propagatedBuildInputs = [ async_kernel_p4 async_unix async_extra pa_ounit ];
 
   meta = with stdenv.lib; {
     homepage = https://github.com/janestreet/async;
diff --git a/pkgs/development/ocaml-modules/async_extra/default.nix b/pkgs/development/ocaml-modules/async_extra/default.nix
index 2a6c74f93a78..fbb95a682f4d 100644
--- a/pkgs/development/ocaml-modules/async_extra/default.nix
+++ b/pkgs/development/ocaml-modules/async_extra/default.nix
@@ -1,4 +1,4 @@
-{stdenv, buildOcaml, fetchurl, async_kernel, async_unix,
+{stdenv, buildOcaml, fetchurl, async_kernel_p4, async_unix,
  bin_prot_p4, core_p4, custom_printf, fieldslib_p4, herelib, pa_ounit,
  pipebang, pa_test, sexplib_p4}:
 
@@ -14,7 +14,7 @@ buildOcaml rec {
   };
 
   buildInputs = [ pa_test pa_ounit ];
-  propagatedBuildInputs = [ async_kernel async_unix core_p4 bin_prot_p4 custom_printf
+  propagatedBuildInputs = [ async_kernel_p4 async_unix core_p4 bin_prot_p4 custom_printf
                             fieldslib_p4 herelib pipebang sexplib_p4 ];
 
   meta = with stdenv.lib; {
diff --git a/pkgs/development/ocaml-modules/async_unix/default.nix b/pkgs/development/ocaml-modules/async_unix/default.nix
index 545f7efd85a7..6119bcac876a 100644
--- a/pkgs/development/ocaml-modules/async_unix/default.nix
+++ b/pkgs/development/ocaml-modules/async_unix/default.nix
@@ -1,4 +1,4 @@
-{stdenv, buildOcaml, fetchurl, async_kernel,
+{stdenv, buildOcaml, fetchurl, async_kernel_p4,
  bin_prot_p4, comparelib, core_p4, fieldslib_p4, herelib, pa_ounit,
  pipebang, pa_test, sexplib_p4}:
 
@@ -15,7 +15,7 @@ buildOcaml rec {
 
   hasSharedObjects = true;
   buildInputs = [ pa_ounit ];
-  propagatedBuildInputs = [ async_kernel core_p4 bin_prot_p4 comparelib
+  propagatedBuildInputs = [ async_kernel_p4 core_p4 bin_prot_p4 comparelib
                             fieldslib_p4 herelib pipebang pa_test sexplib_p4 ];
 
    meta = with stdenv.lib; {
diff --git a/pkgs/development/ocaml-modules/janestreet/async-kernel.nix b/pkgs/development/ocaml-modules/janestreet/async-kernel.nix
new file mode 100644
index 000000000000..4d7213a8603e
--- /dev/null
+++ b/pkgs/development/ocaml-modules/janestreet/async-kernel.nix
@@ -0,0 +1,16 @@
+{stdenv, buildOcamlJane, fetchurl, core_kernel,
+ bin_prot, fieldslib,
+ sexplib, herelib, opam, js_build_tools, ocaml_oasis}:
+
+buildOcamlJane rec {
+  name = "async_kernel";
+  hash = "1n6ifbrq6q6hq8bxh6b9vhg11mv9r6jgp1b7vfw7mh5s2nrd4b60";
+  propagatedBuildInputs = [ core_kernel bin_prot fieldslib herelib sexplib ];
+
+  meta = with stdenv.lib; {
+    homepage = https://github.com/janestreet/async_kernel;
+    description = "Jane Street Capital's asynchronous execution library (core) ";
+    license = licenses.asl20;
+    maintainers = [ maintainers.maurer maintainers.ericbmerritt ];
+  };
+}