summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/haskell-modules/configuration-ghc-8.4.x.nix4
-rw-r--r--pkgs/development/libraries/libbsd/default.nix21
-rw-r--r--pkgs/development/libraries/poppler/default.nix7
-rw-r--r--pkgs/development/libraries/qt-5/mkDerivation.nix3
-rw-r--r--pkgs/development/libraries/qt-5/modules/qtbase.nix19
-rw-r--r--pkgs/development/python-modules/pandas/default.nix2
-rw-r--r--pkgs/development/python-modules/pandas/pandas-0.22.0-pytest-3.5.1.patch13
-rw-r--r--pkgs/development/tools/build-managers/sbt/default.nix4
-rw-r--r--pkgs/development/tools/godep/default.nix30
-rw-r--r--pkgs/development/tools/godep/deps.nix67
10 files changed, 46 insertions, 124 deletions
diff --git a/pkgs/development/haskell-modules/configuration-ghc-8.4.x.nix b/pkgs/development/haskell-modules/configuration-ghc-8.4.x.nix
index 55e80d7fb0c3..b0dc20128fc4 100644
--- a/pkgs/development/haskell-modules/configuration-ghc-8.4.x.nix
+++ b/pkgs/development/haskell-modules/configuration-ghc-8.4.x.nix
@@ -408,8 +408,8 @@ self: super: {
   # Older versions don't compile.
   base-compat = self.base-compat_0_10_1;
   brick = self.brick_0_37_1;
-  dhall = self.dhall_1_13_0;
-  dhall_1_13_0 = doJailbreak super.dhall_1_13_0;  # support ansi-terminal 0.8.x
+  dhall = self.dhall_1_14_0;
+  dhall_1_13_0 = doJailbreak super.dhall_1_14_0;  # support ansi-terminal 0.8.x
   HaTeX = self.HaTeX_3_19_0_0;
   hpack = self.hpack_0_28_2;
   hspec = dontCheck super.hspec_2_5_1;
diff --git a/pkgs/development/libraries/libbsd/default.nix b/pkgs/development/libraries/libbsd/default.nix
new file mode 100644
index 000000000000..114d3209b58a
--- /dev/null
+++ b/pkgs/development/libraries/libbsd/default.nix
@@ -0,0 +1,21 @@
+{ stdenv, fetchurl }:
+
+stdenv.mkDerivation rec {
+  name = "libbsd-${version}";
+  version = "0.9.1";
+
+  src = fetchurl {
+    url = "http://libbsd.freedesktop.org/releases/${name}.tar.xz";
+    sha256 = "1957w2wi7iqar978qlfsm220dwywnrh5m58nrnn9zmi74ds3bn2n";
+  };
+
+  patches = [];
+
+  meta = with stdenv.lib; {
+    description = "Common functions found on BSD systems, Freedesktop fork";
+    homepage = https://libbsd.freedesktop.org/;
+    license = licenses.bsd3;
+    platforms = platforms.linux;
+    maintainers = with maintainers; [ raskin ];
+  };
+}
diff --git a/pkgs/development/libraries/poppler/default.nix b/pkgs/development/libraries/poppler/default.nix
index 960a792822d3..bfc94e1fac8a 100644
--- a/pkgs/development/libraries/poppler/default.nix
+++ b/pkgs/development/libraries/poppler/default.nix
@@ -3,7 +3,7 @@
 , withData ? true, poppler_data
 , qt5Support ? false, qtbase ? null
 , introspectionSupport ? false, gobjectIntrospection ? null
-, utils ? false
+, utils ? false, nss ? null
 , minimal ? false, suffix ? "glib"
 }:
 
@@ -28,6 +28,7 @@ stdenv.mkDerivation rec {
     [ zlib freetype fontconfig libjpeg openjpeg ]
     ++ optionals (!minimal) [ cairo lcms curl ]
     ++ optional qt5Support qtbase
+    ++ optional utils nss
     ++ optional introspectionSupport gobjectIntrospection;
 
   nativeBuildInputs = [ cmake ninja pkgconfig ];
@@ -49,7 +50,9 @@ stdenv.mkDerivation rec {
     description = "A PDF rendering library";
 
     longDescription = ''
-      Poppler is a PDF rendering library based on the xpdf-3.0 code base.
+      Poppler is a PDF rendering library based on the xpdf-3.0 code
+      base. In addition it provides a number of tools that can be
+      installed separately.
     '';
 
     license = licenses.gpl2;
diff --git a/pkgs/development/libraries/qt-5/mkDerivation.nix b/pkgs/development/libraries/qt-5/mkDerivation.nix
index 53949ddd4925..96014cfbc779 100644
--- a/pkgs/development/libraries/qt-5/mkDerivation.nix
+++ b/pkgs/development/libraries/qt-5/mkDerivation.nix
@@ -16,9 +16,6 @@ let
       optional (!debug) "-DQT_NO_DEBUG"
       ++ lib.toList (args.NIX_CFLAGS_COMPILE or []);
 
-    configureFlags = [ "-no-framework" ]
-                  ++ (args.configureFlags or []);
-
     cmakeFlags =
       (args.cmakeFlags or [])
       ++ [
diff --git a/pkgs/development/libraries/qt-5/modules/qtbase.nix b/pkgs/development/libraries/qt-5/modules/qtbase.nix
index 28b250437d08..0c7af9e185dd 100644
--- a/pkgs/development/libraries/qt-5/modules/qtbase.nix
+++ b/pkgs/development/libraries/qt-5/modules/qtbase.nix
@@ -298,6 +298,7 @@ stdenv.mkDerivation {
           "-no-fontconfig"
           "-qt-freetype"
           "-qt-libpng"
+          "-no-framework"
         ]
       else
         [
@@ -373,24 +374,6 @@ stdenv.mkDerivation {
     ''
 
     + (
-      if stdenv.isDarwin
-      then
-        ''
-          fixDarwinDylibNames_rpath() {
-            local flags=()
-
-            for fn in "$@"; do
-              flags+=(-change "@rpath/$fn.framework/Versions/5/$fn" "$out/lib/$fn.framework/Versions/5/$fn")
-            done
-
-            for fn in "$@"; do
-              echo "$fn: fixing dylib"
-              install_name_tool -id "$out/lib/$fn.framework/Versions/5/$fn" "''${flags[@]}" "$out/lib/$fn.framework/Versions/5/$fn"
-            done
-          }
-          fixDarwinDylibNames_rpath "QtConcurrent" "QtPrintSupport" "QtCore" "QtSql" "QtDBus" "QtTest" "QtGui" "QtWidgets" "QtNetwork" "QtXml" "QtOpenGL"
-        ''
-      else
         # fixup .pc file (where to find 'moc' etc.)
         ''
           sed -i "$dev/lib/pkgconfig/Qt5Core.pc" \
diff --git a/pkgs/development/python-modules/pandas/default.nix b/pkgs/development/python-modules/pandas/default.nix
index 3f9188a6322a..cb497742e47a 100644
--- a/pkgs/development/python-modules/pandas/default.nix
+++ b/pkgs/development/python-modules/pandas/default.nix
@@ -55,6 +55,8 @@ in buildPythonPackage rec {
     xlwt
   ];
 
+  patches = [ ./pandas-0.22.0-pytest-3.5.1.patch ];
+
   # For OSX, we need to add a dependency on libcxx, which provides
   # `complex.h` and other libraries that pandas depends on to build.
   postPatch = optionalString isDarwin ''
diff --git a/pkgs/development/python-modules/pandas/pandas-0.22.0-pytest-3.5.1.patch b/pkgs/development/python-modules/pandas/pandas-0.22.0-pytest-3.5.1.patch
new file mode 100644
index 000000000000..cba71b91316a
--- /dev/null
+++ b/pkgs/development/python-modules/pandas/pandas-0.22.0-pytest-3.5.1.patch
@@ -0,0 +1,13 @@
+--- a/pandas/tests/io/test_pytables.py
++++ b/pandas/tests/io/test_pytables.py
+@@ -5028,8 +5028,8 @@ class TestHDFStore(Base):
+             with ensure_clean_path(self.path) as path:
+                 with catch_warnings(record=True):
+                     with pytest.raises(
+-                        ValueError, msg=("cannot have non-object label "
+-                                         "DataIndexableCol")):
++                        ValueError, message=("cannot have non-object label "
++                                             "DataIndexableCol")):
+                         df.to_hdf(path, 'df', format='table',
+                                   data_columns=True)
+ 
diff --git a/pkgs/development/tools/build-managers/sbt/default.nix b/pkgs/development/tools/build-managers/sbt/default.nix
index 04102e7e8f86..76d099625626 100644
--- a/pkgs/development/tools/build-managers/sbt/default.nix
+++ b/pkgs/development/tools/build-managers/sbt/default.nix
@@ -2,7 +2,7 @@
 
 stdenv.mkDerivation rec {
   name = "sbt-${version}";
-  version = "1.1.4";
+  version = "1.1.6";
 
   src = fetchurl {
     urls = [
@@ -10,7 +10,7 @@ stdenv.mkDerivation rec {
       "https://github.com/sbt/sbt/releases/download/v${version}/sbt-${version}.tgz"
       "https://cocl.us/sbt-${version}.tgz"
     ];
-    sha256 = "0hc361gb71psadx9gj78j0j60fw4sljjk8sl45hw6yzx3hmmkg9g";
+    sha256 = "1hb8gcf3shcp4a65pnlqdlp8j5as7prqvw3d0b5bnfjfi0qbaigm";
   };
 
   patchPhase = ''
diff --git a/pkgs/development/tools/godep/default.nix b/pkgs/development/tools/godep/default.nix
deleted file mode 100644
index 3503a6c2c625..000000000000
--- a/pkgs/development/tools/godep/default.nix
+++ /dev/null
@@ -1,30 +0,0 @@
-{ stdenv, lib, go, fetchurl, fetchgit, fetchhg, fetchbzr, fetchFromGitHub }:
-
-stdenv.mkDerivation rec {
-  version = "73";
-  name = "godep-${version}";
-
-  src = import ./deps.nix {
-    inherit stdenv lib fetchgit;
-  };
-
-  buildInputs = [ go ];
-
-  buildPhase = ''
-    export GOPATH=$src
-    go build -v -o godep github.com/tools/godep
-  '';
-
-  installPhase = ''
-    mkdir -p $out/bin
-    mv godep $out/bin
-  '';
-
-  meta = with stdenv.lib; {
-    description = "Dependency tool for go";
-    homepage = https://github.com/tools/godep;
-    license = licenses.bsd3;
-    maintainers = with maintainers; [ offline ];
-    platforms = platforms.unix;
-  };
-}
diff --git a/pkgs/development/tools/godep/deps.nix b/pkgs/development/tools/godep/deps.nix
deleted file mode 100644
index 10071fa51955..000000000000
--- a/pkgs/development/tools/godep/deps.nix
+++ /dev/null
@@ -1,67 +0,0 @@
-# This file was generated by go2nix.
-{ stdenv, lib, fetchgit }:
-
-let
-  goDeps = [
-    {
-      root = "github.com/kr/fs";
-      src = fetchgit {
-        url = "https://github.com/kr/fs.git";
-        rev = "2788f0dbd16903de03cb8186e5c7d97b69ad387b";
-        sha256 = "1c0fipl4rsh0v5liq1ska1dl83v3llab4k6lm8mvrx9c4dyp71ly";
-      };
-    }
-    {
-      root = "github.com/tools/godep";
-      src = fetchgit {
-        url = "https://github.com/tools/godep.git";
-        rev = "f4edf338389e6e2bde0e8307886718133dc0613e";
-        sha256 = "1jdza8kwnzdsh3layqjzy9dnr92xdg3kfhnzvqkq3p50vsdims9w";
-      };
-    }
-    {
-      root = "github.com/kr/pretty";
-      src = fetchgit {
-        url = "https://github.com/kr/pretty";
-        rev = "f31442d60e51465c69811e2107ae978868dbea5c";
-        sha256 = "12nczwymikxmivb10q5ml5yxrwpz9s8p6k4vqig9g9707yhpxrkh";
-      };
-    }
-    {
-      root = "github.com/kr/text";
-      src = fetchgit {
-        url = "https://github.com/kr/text";
-        rev = "6807e777504f54ad073ecef66747de158294b639";
-        sha256 = "1wkszsg08zar3wgspl9sc8bdsngiwdqmg3ws4y0bh02sjx5a4698";
-      };
-    }
-    {
-      root = "github.com/pmezard/go-difflib";
-      src = fetchgit {
-        url = "https://github.com/pmezard/go-difflib";
-        rev = "f78a839676152fd9f4863704f5d516195c18fc14";
-        sha256 = "1bws3qyy572b62i3wkwfr1aw1g2nwcim2sy42jqsvh9pajjsf1vz";
-      };
-    }
-    {
-      root = "golang.org/x/tools";
-      src = fetchgit {
-        url = "https://go.googlesource.com/tools";
-        rev = "1f1b3322f67af76803c942fd237291538ec68262";
-        sha256 = "0h2yarcvcgg1px20r8n58psra1czv0sgly5gins2q3wp25iql6gj";
-      };
-    }
-  ];
-
-in
-
-stdenv.mkDerivation rec {
-  name = "go-deps";
-
-  buildCommand =
-    lib.concatStrings
-      (map (dep: ''
-              mkdir -p $out/src/`dirname ${dep.root}`
-              ln -s ${dep.src} $out/src/${dep.root}
-            '') goDeps);
-}