summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/compilers/gcc/4.5/default.nix7
-rw-r--r--pkgs/development/compilers/gcc/4.8/default.nix7
-rw-r--r--pkgs/development/compilers/llvm/3.4/clang.nix1
-rw-r--r--pkgs/development/haskell-modules/configuration-common.nix6
-rw-r--r--pkgs/development/haskell-modules/configuration-hackage2nix.yaml1
-rw-r--r--pkgs/development/haskell-modules/configuration-nix.nix2
-rw-r--r--pkgs/development/haskell-modules/hackage-packages.nix346
-rw-r--r--pkgs/development/libraries/libqmatrixclient/default.nix6
-rw-r--r--pkgs/development/libraries/libtoxcore/default.nix7
-rw-r--r--pkgs/development/libraries/libxc/default.nix31
-rw-r--r--pkgs/development/python-modules/mygpoclient/default.nix31
-rw-r--r--pkgs/development/tools/analysis/rr/default.nix4
12 files changed, 402 insertions, 47 deletions
diff --git a/pkgs/development/compilers/gcc/4.5/default.nix b/pkgs/development/compilers/gcc/4.5/default.nix
index a312276b33e4..8f29d5f2cb14 100644
--- a/pkgs/development/compilers/gcc/4.5/default.nix
+++ b/pkgs/development/compilers/gcc/4.5/default.nix
@@ -382,8 +382,11 @@ stdenv.mkDerivation ({
       "-Wl,${libpthreadCross.TARGET_LDFLAGS}"
     ]);
 
-  passthru = { inherit langC langCC langAda langFortran langVhdl
-      enableMultilib version; isGNU = true; };
+  passthru = {
+    inherit langC langCC langAda langFortran langVhdl enableMultilib version;
+    isGNU = true;
+    hardeningUnsupportedFlags = [ "stackprotector" ];
+  };
 
   enableParallelBuilding = !langAda;
 
diff --git a/pkgs/development/compilers/gcc/4.8/default.nix b/pkgs/development/compilers/gcc/4.8/default.nix
index 91daeadba707..a28ad871ead2 100644
--- a/pkgs/development/compilers/gcc/4.8/default.nix
+++ b/pkgs/development/compilers/gcc/4.8/default.nix
@@ -459,8 +459,11 @@ stdenv.mkDerivation ({
       "-Wl,${libpthreadCross.TARGET_LDFLAGS}"
     ]);
 
-  passthru =
-    { inherit langC langCC langObjC langObjCpp langAda langFortran langVhdl langGo version; isGNU = true; };
+  passthru = {
+    inherit langC langCC langObjC langObjCpp langAda langFortran langVhdl langGo version;
+    isGNU = true;
+    hardeningUnsupportedFlags = [ "stackprotector" ];
+  };
 
   inherit enableParallelBuilding enableMultilib;
 
diff --git a/pkgs/development/compilers/llvm/3.4/clang.nix b/pkgs/development/compilers/llvm/3.4/clang.nix
index 741ecc3856f8..10510c750354 100644
--- a/pkgs/development/compilers/llvm/3.4/clang.nix
+++ b/pkgs/development/compilers/llvm/3.4/clang.nix
@@ -39,6 +39,7 @@ stdenv.mkDerivation {
     # GCC_INSTALL_PREFIX points here, so just use it even though it may not
     # actually be a gcc
     gcc = stdenv.cc.cc;
+    hardeningUnsupportedFlags = [ "stackprotector" ];
   };
 
   enableParallelBuilding = true;
diff --git a/pkgs/development/haskell-modules/configuration-common.nix b/pkgs/development/haskell-modules/configuration-common.nix
index cc86252a1aff..7eaecbc1b1ba 100644
--- a/pkgs/development/haskell-modules/configuration-common.nix
+++ b/pkgs/development/haskell-modules/configuration-common.nix
@@ -1015,7 +1015,9 @@ self: super: {
 
   # https://github.com/haskell/cabal/issues/4969
   haddock-library_1_4_4 = dontHaddock super.haddock-library_1_4_4;
+  haddock-api = super.haddock-api.override { haddock-library = self.haddock-library_1_4_4; };
+
+  # Jailbreak "unix-compat >=0.1.2 && <0.5".
+  darcs = overrideCabal super.darcs (drv: { preConfigure = "sed -i -e 's/unix-compat .*,/unix-compat,/' darcs.cabal"; });
 
-  haddock-api = super.haddock-api.override
-    { haddock-library = self.haddock-library_1_4_4; };
 }
diff --git a/pkgs/development/haskell-modules/configuration-hackage2nix.yaml b/pkgs/development/haskell-modules/configuration-hackage2nix.yaml
index 55d40020f8be..39064998c441 100644
--- a/pkgs/development/haskell-modules/configuration-hackage2nix.yaml
+++ b/pkgs/development/haskell-modules/configuration-hackage2nix.yaml
@@ -6382,7 +6382,6 @@ dont-distribute-packages:
   liquid:                                       [ i686-linux, x86_64-linux, x86_64-darwin ]
   liquidhaskell-cabal-demo:                     [ i686-linux, x86_64-linux, x86_64-darwin ]
   liquidhaskell-cabal:                          [ i686-linux, x86_64-linux, x86_64-darwin ]
-  liquidhaskell:                                [ i686-linux, x86_64-linux, x86_64-darwin ]
   list-mux:                                     [ i686-linux, x86_64-linux, x86_64-darwin ]
   list-prompt:                                  [ i686-linux, x86_64-linux, x86_64-darwin ]
   list-remote-forwards:                         [ i686-linux, x86_64-linux, x86_64-darwin ]
diff --git a/pkgs/development/haskell-modules/configuration-nix.nix b/pkgs/development/haskell-modules/configuration-nix.nix
index 96b1893206d2..2320d6a8752a 100644
--- a/pkgs/development/haskell-modules/configuration-nix.nix
+++ b/pkgs/development/haskell-modules/configuration-nix.nix
@@ -258,7 +258,7 @@ self: super: builtins.intersectAttrs super {
       }
     );
 
-  llvm-hs = super.llvm-hs.override { llvm-config = pkgs.llvm_4; };
+  llvm-hs = super.llvm-hs.override { llvm-config = pkgs.llvm_5; };
 
   # Needs help finding LLVM.
   spaceprobe = addBuildTool super.spaceprobe self.llvmPackages.llvm;
diff --git a/pkgs/development/haskell-modules/hackage-packages.nix b/pkgs/development/haskell-modules/hackage-packages.nix
index e80879fb9f61..5aa31e7e948c 100644
--- a/pkgs/development/haskell-modules/hackage-packages.nix
+++ b/pkgs/development/haskell-modules/hackage-packages.nix
@@ -29049,8 +29049,8 @@ self: {
      }:
      mkDerivation {
        pname = "ats-format";
-       version = "0.1.0.8";
-       sha256 = "0hgzcgdpi9y039f45slaali0az3mjzvm2vv49iw3yglm1gvqkfzj";
+       version = "0.1.0.10";
+       sha256 = "0q74j2mn85siix4msqjx0w0bly9f8dxjpbd0cwcyag8jj2gd6i62";
        isLibrary = true;
        isExecutable = true;
        enableSeparateDataOutput = true;
@@ -35042,8 +35042,8 @@ self: {
      }:
      mkDerivation {
        pname = "bittrex";
-       version = "0.4.0.0";
-       sha256 = "1ns9ygrsr63l1b791li4sx8cqijn1yqkl0a0k7fnqi2ny5z97mz6";
+       version = "0.5.0.0";
+       sha256 = "00h1khj8bs1yc7r9ji68xgxxfakk4p0y885k9jmf4wd5f5qi9j7m";
        isLibrary = true;
        isExecutable = true;
        libraryHaskellDepends = [
@@ -42502,6 +42502,34 @@ self: {
        hydraPlatforms = stdenv.lib.platforms.none;
      }) {};
 
+  "chart-unit_0_5_5_0" = callPackage
+    ({ mkDerivation, base, colour, containers, data-default
+     , diagrams-lib, diagrams-svg, foldl, formatting, lens, linear
+     , mwc-probability, mwc-random, numhask, numhask-range, palette
+     , primitive, protolude, scientific, SVGFonts, tasty, tasty-hspec
+     , tdigest, text
+     }:
+     mkDerivation {
+       pname = "chart-unit";
+       version = "0.5.5.0";
+       sha256 = "0hskfcg17h22fyprr9y264g6jz4lq1a7akqvdyji4fln61mqn07r";
+       isLibrary = true;
+       isExecutable = true;
+       libraryHaskellDepends = [
+         base colour data-default diagrams-lib diagrams-svg foldl formatting
+         lens linear numhask numhask-range palette scientific SVGFonts text
+       ];
+       executableHaskellDepends = [
+         base containers diagrams-lib diagrams-svg foldl formatting lens
+         mwc-probability mwc-random numhask primitive protolude tdigest text
+       ];
+       testHaskellDepends = [ base numhask tasty tasty-hspec text ];
+       homepage = "https://github.com/tonyday567/chart-unit#readme";
+       description = "Native haskell charts";
+       license = stdenv.lib.licenses.bsd3;
+       hydraPlatforms = stdenv.lib.platforms.none;
+     }) {};
+
   "chaselev-deque" = callPackage
     ({ mkDerivation, abstract-deque, abstract-deque-tests, array
      , atomic-primops, base, containers, ghc-prim, HUnit, test-framework
@@ -43104,6 +43132,8 @@ self: {
        pname = "chr-lang";
        version = "0.1.0.0";
        sha256 = "0rn2hv1a8jxzyg4qkbz0m9h0id3q353yg2j85pik49s00hnmqh3p";
+       revision = "1";
+       editedCabalFile = "0kcj8l96cb4drsiz57mxggc75mlabp5rsl01l743cadh7zyx0g95";
        isLibrary = true;
        isExecutable = true;
        libraryHaskellDepends = [
@@ -47432,8 +47462,8 @@ self: {
     ({ mkDerivation, base }:
      mkDerivation {
        pname = "composition-prelude";
-       version = "0.1.1.2";
-       sha256 = "1ii230d9v7mcpsax9x001ai0nw6pm50zsgyaw9d1s9s2pvf927wr";
+       version = "0.1.1.4";
+       sha256 = "1jnynldi9clzz9in9cjpl17z5yh18wcdal875aphdxd72bhb2yk7";
        libraryHaskellDepends = [ base ];
        homepage = "https://github.com/vmchale/composition-prelude#readme";
        description = "Higher-order function combinators";
@@ -68303,6 +68333,19 @@ self: {
        hydraPlatforms = stdenv.lib.platforms.none;
      }) {};
 
+  "explicit-constraint-lens" = callPackage
+    ({ mkDerivation, base, tasty, tasty-hunit }:
+     mkDerivation {
+       pname = "explicit-constraint-lens";
+       version = "0.1.0.0";
+       sha256 = "181frvmgv65rcjpiya4gswvpq9ahz97c8lalhgmwknx9jx5nqd98";
+       libraryHaskellDepends = [ base ];
+       testHaskellDepends = [ base tasty tasty-hunit ];
+       homepage = "https://github.com/leftaroundabout/explicit-constraint-lens";
+       description = "Fully-flexible polymorphic lenses, without any bizarre profunctors";
+       license = stdenv.lib.licenses.gpl3;
+     }) {};
+
   "explicit-determinant" = callPackage
     ({ mkDerivation, base }:
      mkDerivation {
@@ -69101,6 +69144,26 @@ self: {
        license = stdenv.lib.licenses.publicDomain;
      }) {};
 
+  "fast-combinatorics" = callPackage
+    ({ mkDerivation, arithmoi, base, Cabal, combinatorics
+     , composition-prelude, criterion, directory, hspec, http-client
+     , http-client-tls, tar, zlib
+     }:
+     mkDerivation {
+       pname = "fast-combinatorics";
+       version = "0.1.0.3";
+       sha256 = "1ch6lg4br3yk9n59rf5dcxbwlh0gi27zkqd2cbnkm1p33ik7bvdf";
+       setupHaskellDepends = [
+         base Cabal directory http-client http-client-tls tar zlib
+       ];
+       libraryHaskellDepends = [ base composition-prelude ];
+       testHaskellDepends = [ arithmoi base combinatorics hspec ];
+       benchmarkHaskellDepends = [ base combinatorics criterion ];
+       homepage = "https://github.com//fast-combinatorics#readme";
+       description = "Fast combinatorics";
+       license = stdenv.lib.licenses.bsd3;
+     }) {};
+
   "fast-digits" = callPackage
     ({ mkDerivation, base, criterion, digits, integer-gmp, QuickCheck
      , smallcheck, tasty, tasty-quickcheck, tasty-smallcheck
@@ -72571,6 +72634,19 @@ self: {
        license = stdenv.lib.licenses.bsd3;
      }) {};
 
+  "fmlist_0_9_1" = callPackage
+    ({ mkDerivation, base }:
+     mkDerivation {
+       pname = "fmlist";
+       version = "0.9.1";
+       sha256 = "0v83rxr4889c6m5djfp3vx450kzsj1wi5d0qmd7myvh7i0r4afqv";
+       libraryHaskellDepends = [ base ];
+       homepage = "https://github.com/sjoerdvisscher/fmlist";
+       description = "FoldMap lists";
+       license = stdenv.lib.licenses.bsd3;
+       hydraPlatforms = stdenv.lib.platforms.none;
+     }) {};
+
   "fmt" = callPackage
     ({ mkDerivation, base, base16-bytestring, base64-bytestring
      , bytestring, containers, criterion, deepseq, formatting, hspec
@@ -73433,8 +73509,8 @@ self: {
      }:
      mkDerivation {
        pname = "fortytwo";
-       version = "1.0.2";
-       sha256 = "15imj5ps040iz5abfnzjpgfq726j9c28bwwg06zbf07ji74dz190";
+       version = "1.0.3";
+       sha256 = "113z46b5dnf6z7bxw1a4vhr84w5pw0iridsi3wjimhjz0rr530cm";
        isLibrary = true;
        isExecutable = true;
        libraryHaskellDepends = [ ansi-terminal base text ];
@@ -91424,6 +91500,27 @@ self: {
        hydraPlatforms = stdenv.lib.platforms.none;
      }) {};
 
+  "haskell-dap" = callPackage
+    ({ mkDerivation, array, base, bytestring, containers, deepseq
+     , directory, filepath, ghc, ghc-boot, ghci, haskeline, process
+     , time, transformers, unix
+     }:
+     mkDerivation {
+       pname = "haskell-dap";
+       version = "0.0.1.0";
+       sha256 = "1wny1ab0x1wdaa8xhza478abyv1sd2pq4clc08bz3b2aa0qd13y8";
+       isLibrary = true;
+       isExecutable = true;
+       libraryHaskellDepends = [ base ];
+       executableHaskellDepends = [
+         array base bytestring containers deepseq directory filepath ghc
+         ghc-boot ghci haskeline process time transformers unix
+       ];
+       homepage = "https://github.com/phoityne/haskell-dap";
+       description = "haskell-dap is a GHCi having DAP interface";
+       license = stdenv.lib.licenses.bsd3;
+     }) {};
+
   "haskell-disque" = callPackage
     ({ mkDerivation, base, bytestring, hedis, string-conversions
      , transformers
@@ -98340,10 +98437,12 @@ self: {
        pname = "hidden-char";
        version = "0.1.0.2";
        sha256 = "167l83cn37mkq394pbanybz1kghnbim1m74fxskws1nclxr9747a";
+       revision = "2";
+       editedCabalFile = "1d0k297hxff31k0x5xbli6l7c151d2y9wq4w0x0prgagjc0l7z5n";
        libraryHaskellDepends = [ base ];
        testHaskellDepends = [ base hspec ];
        homepage = "https://github.com/rcook/hidden-char#readme";
-       description = "Provides getHiddenChar function";
+       description = "Provides cross-platform getHiddenChar function";
        license = stdenv.lib.licenses.mit;
        hydraPlatforms = stdenv.lib.platforms.none;
      }) {};
@@ -102061,8 +102160,8 @@ self: {
      }:
      mkDerivation {
        pname = "hoppy-generator";
-       version = "0.3.3";
-       sha256 = "18n48kkf6pcmcwb85a74kqh84aadpm1s9jv1r56b43rya8ra3mgw";
+       version = "0.3.4";
+       sha256 = "09vc23id1f30270c6q3wadckzvbqj4hvaxzy3wfbmhsqbrmmrfwh";
        libraryHaskellDepends = [
          base containers directory filepath haskell-src mtl
        ];
@@ -102076,8 +102175,8 @@ self: {
     ({ mkDerivation, base, Cabal, containers, directory, filepath }:
      mkDerivation {
        pname = "hoppy-runtime";
-       version = "0.3.1";
-       sha256 = "0cbnhpwy3m0l7gcarg7xr1f5y6nwdnfa269vvza0fm4fhf3lz6g5";
+       version = "0.3.2";
+       sha256 = "0ax4aqbnxc80dbj8f7hykgj5agn59nwv4icfwmb4knxj2qw35kg3";
        libraryHaskellDepends = [
          base Cabal containers directory filepath
        ];
@@ -118386,8 +118485,8 @@ self: {
      }:
      mkDerivation {
        pname = "juicy-gcode";
-       version = "0.1.0.3";
-       sha256 = "0czb1vb1nwn1wzx52vpvnpki2kfwwb775wg512rn46snm5wibvzv";
+       version = "0.1.0.4";
+       sha256 = "1nf30901jv226n7cpnbkqdh51gpmkzri79m271afzsgya3cs9gi5";
        isLibrary = false;
        isExecutable = true;
        executableHaskellDepends = [
@@ -126203,7 +126302,6 @@ self: {
        homepage = "https://github.com/ucsd-progsys/liquidhaskell";
        description = "Liquid Types for Haskell";
        license = stdenv.lib.licenses.bsd3;
-       hydraPlatforms = stdenv.lib.platforms.none;
      }) {inherit (pkgs) z3;};
 
   "liquidhaskell-cabal" = callPackage
@@ -127677,6 +127775,39 @@ self: {
        license = stdenv.lib.licenses.mit;
      }) {};
 
+  "log-warper_1_8_4" = callPackage
+    ({ mkDerivation, aeson, ansi-terminal, async, base, containers
+     , data-default, deepseq, directory, filepath, fmt, hspec, HUnit
+     , markdown-unlit, microlens, microlens-mtl, microlens-platform
+     , mmorph, monad-control, monad-loops, mtl, QuickCheck, text, time
+     , transformers, transformers-base, universum, unix
+     , unordered-containers, vector, yaml
+     }:
+     mkDerivation {
+       pname = "log-warper";
+       version = "1.8.4";
+       sha256 = "0dnqcp97qlsn2yq8nf779l1sm0p30bl15j9ivwrnaxb02kyws5pn";
+       isLibrary = true;
+       isExecutable = true;
+       libraryHaskellDepends = [
+         aeson ansi-terminal base containers deepseq directory filepath fmt
+         microlens-platform mmorph monad-control monad-loops mtl text time
+         transformers transformers-base universum unix unordered-containers
+         vector yaml
+       ];
+       executableHaskellDepends = [
+         base markdown-unlit microlens mtl text universum yaml
+       ];
+       testHaskellDepends = [
+         async base data-default directory filepath hspec HUnit
+         microlens-mtl QuickCheck universum unordered-containers
+       ];
+       homepage = "https://github.com/serokell/log-warper";
+       description = "Flexible, configurable, monadic and pretty logging";
+       license = stdenv.lib.licenses.mit;
+       hydraPlatforms = stdenv.lib.platforms.none;
+     }) {};
+
   "log2json" = callPackage
     ({ mkDerivation, base, containers, json, parsec }:
      mkDerivation {
@@ -136636,6 +136767,31 @@ self: {
        license = stdenv.lib.licenses.mit;
      }) {};
 
+  "mono-traversable_1_0_7_0" = callPackage
+    ({ mkDerivation, base, bytestring, containers, criterion, foldl
+     , hashable, hspec, HUnit, mwc-random, QuickCheck, semigroups, split
+     , text, transformers, unordered-containers, vector
+     , vector-algorithms
+     }:
+     mkDerivation {
+       pname = "mono-traversable";
+       version = "1.0.7.0";
+       sha256 = "0jfcw8xfizsva1w4h7546fryzqc1gnl1w3ki42nl41s1fdqfxibq";
+       libraryHaskellDepends = [
+         base bytestring containers hashable split text transformers
+         unordered-containers vector vector-algorithms
+       ];
+       testHaskellDepends = [
+         base bytestring containers foldl hspec HUnit QuickCheck semigroups
+         text transformers unordered-containers vector
+       ];
+       benchmarkHaskellDepends = [ base criterion mwc-random vector ];
+       homepage = "https://github.com/snoyberg/mono-traversable#readme";
+       description = "Type classes for mapping, folding, and traversing monomorphic containers";
+       license = stdenv.lib.licenses.mit;
+       hydraPlatforms = stdenv.lib.platforms.none;
+     }) {};
+
   "mono-traversable-instances" = callPackage
     ({ mkDerivation, base, comonad, containers, dlist, dlist-instances
      , mono-traversable, semigroupoids, semigroups, transformers
@@ -144971,6 +145127,25 @@ self: {
        license = stdenv.lib.licenses.bsd3;
      }) {};
 
+  "one-liner_0_9_2" = callPackage
+    ({ mkDerivation, base, bifunctors, contravariant, ghc-prim, HUnit
+     , profunctors, tagged, transformers
+     }:
+     mkDerivation {
+       pname = "one-liner";
+       version = "0.9.2";
+       sha256 = "1my7ykfbfgx8z4qcklqxacycs5hl736fqh5s22cdm19nhfqmcc5b";
+       libraryHaskellDepends = [
+         base bifunctors contravariant ghc-prim profunctors tagged
+         transformers
+       ];
+       testHaskellDepends = [ base contravariant HUnit ];
+       homepage = "https://github.com/sjoerdvisscher/one-liner";
+       description = "Constraint-based generics";
+       license = stdenv.lib.licenses.bsd3;
+       hydraPlatforms = stdenv.lib.platforms.none;
+     }) {};
+
   "one-time-password" = callPackage
     ({ mkDerivation, base, bytestring, cereal, cryptonite, memory
      , tasty, tasty-hunit, time
@@ -146104,8 +146279,8 @@ self: {
      }:
      mkDerivation {
        pname = "opn";
-       version = "0.1.2";
-       sha256 = "0x53kvcpbd9fh00zs8wdkb3xsl8hf1bsqgl83ci17di1jyg3m4ch";
+       version = "0.1.3";
+       sha256 = "17ysp1xzqbcr58ibzwf88bim58yyc309kf71jw66gn0brp0b0w1h";
        isLibrary = false;
        isExecutable = true;
        executableHaskellDepends = [
@@ -149070,12 +149245,12 @@ self: {
        license = stdenv.lib.licenses.bsd3;
      }) {};
 
-  "parser-combinators_0_3_0" = callPackage
+  "parser-combinators_0_4_0" = callPackage
     ({ mkDerivation, base }:
      mkDerivation {
        pname = "parser-combinators";
-       version = "0.3.0";
-       sha256 = "149x9qpcsr7yimkhsfcksdqx4clf555p51jkvqnr6wql5qi3w2p9";
+       version = "0.4.0";
+       sha256 = "1azkz0a6ikym02s8wydjcklp7rz8k512bs4s9lp9g1g03m0yj95i";
        libraryHaskellDepends = [ base ];
        homepage = "https://github.com/mrkkrp/parser-combinators";
        description = "Lightweight package providing commonly useful parser combinators";
@@ -158789,8 +158964,8 @@ self: {
      }:
      mkDerivation {
        pname = "propellor";
-       version = "5.1.0";
-       sha256 = "0bl1kb24s2bs7li096s4iwvd2wj188lb2y3cfymhgsyqj8c2fbzp";
+       version = "5.2.0";
+       sha256 = "06h1q1kx2ifbfpicb0ivp4x8pv1fn15x0v5wn1dygnbf862h9brh";
        isLibrary = true;
        isExecutable = true;
        libraryHaskellDepends = [
@@ -193536,8 +193711,8 @@ self: {
        pname = "test-framework";
        version = "0.8.1.1";
        sha256 = "0wxjgdvb1c4ykazw774zlx86550848wbsvgjgcrdzcgbb9m650vq";
-       revision = "2";
-       editedCabalFile = "1mp1h0fzwxa3xxnbw33lp8hj0rb8vwkd712r5ak8ny5nmawh2c9y";
+       revision = "3";
+       editedCabalFile = "1b6pi4j1dpcbiyx1bpfks29x293j02z7ashs2sdc8fhzbwsr9lxj";
        isLibrary = true;
        isExecutable = true;
        libraryHaskellDepends = [
@@ -193549,6 +193724,30 @@ self: {
        license = stdenv.lib.licenses.bsd3;
      }) {};
 
+  "test-framework_0_8_2_0" = callPackage
+    ({ mkDerivation, ansi-terminal, ansi-wl-pprint, base, bytestring
+     , containers, hostname, HUnit, libxml, old-locale, QuickCheck
+     , random, regex-posix, semigroups, time, xml
+     }:
+     mkDerivation {
+       pname = "test-framework";
+       version = "0.8.2.0";
+       sha256 = "1hhacrzam6b8f10hyldmjw8pb7frdxh04rfg3farxcxwbnhwgbpm";
+       libraryHaskellDepends = [
+         ansi-terminal ansi-wl-pprint base containers hostname old-locale
+         random regex-posix time xml
+       ];
+       testHaskellDepends = [
+         ansi-terminal ansi-wl-pprint base bytestring containers hostname
+         HUnit libxml old-locale QuickCheck random regex-posix semigroups
+         time xml
+       ];
+       homepage = "http://haskell.github.io/test-framework/";
+       description = "Framework for running and organising tests, with HUnit and QuickCheck support";
+       license = stdenv.lib.licenses.bsd3;
+       hydraPlatforms = stdenv.lib.platforms.none;
+     }) {};
+
   "test-framework-doctest" = callPackage
     ({ mkDerivation, base, doctest, test-framework
      , test-framework-hunit
@@ -194751,6 +194950,24 @@ self: {
        license = stdenv.lib.licenses.mit;
      }) {};
 
+  "text-replace" = callPackage
+    ({ mkDerivation, base, containers, hedgehog, neat-interpolation
+     , optparse-applicative, parsec, text
+     }:
+     mkDerivation {
+       pname = "text-replace";
+       version = "0.0.0.1";
+       sha256 = "15qf0pwjhaa2zwdzixil5q1iqs5cwlazggzsgwwq553jlggbf063";
+       isLibrary = true;
+       isExecutable = true;
+       libraryHaskellDepends = [ base containers ];
+       executableHaskellDepends = [ base optparse-applicative parsec ];
+       testHaskellDepends = [ base hedgehog neat-interpolation text ];
+       homepage = "https://github.com/chris-martin/text-replace";
+       description = "Simple text replacements from a list of search/replace pairs";
+       license = stdenv.lib.licenses.asl20;
+     }) {};
+
   "text-short" = callPackage
     ({ mkDerivation, base, binary, bytestring, deepseq, hashable
      , quickcheck-instances, tasty, tasty-hunit, tasty-quickcheck, text
@@ -194806,6 +195023,45 @@ self: {
        license = stdenv.lib.licenses.bsd3;
      }) {};
 
+  "text-show_3_7_1" = callPackage
+    ({ mkDerivation, array, base, base-compat, base-orphans, bifunctors
+     , bytestring, bytestring-builder, containers, contravariant
+     , criterion, deepseq, deriving-compat, generic-deriving
+     , ghc-boot-th, ghc-prim, hspec, hspec-discover, integer-gmp, nats
+     , QuickCheck, quickcheck-instances, semigroups, tagged
+     , template-haskell, text, th-abstraction, th-lift, transformers
+     , transformers-compat, void
+     }:
+     mkDerivation {
+       pname = "text-show";
+       version = "3.7.1";
+       sha256 = "0gbf3cpxz92v4jphmwvz93il7m38qkwirfnk5453517k2s84s899";
+       libraryHaskellDepends = [
+         array base base-compat bifunctors bytestring bytestring-builder
+         containers contravariant generic-deriving ghc-boot-th ghc-prim
+         integer-gmp nats semigroups tagged template-haskell text
+         th-abstraction th-lift transformers transformers-compat void
+       ];
+       testHaskellDepends = [
+         array base base-compat base-orphans bifunctors bytestring
+         bytestring-builder containers contravariant deriving-compat
+         generic-deriving ghc-boot-th ghc-prim hspec integer-gmp nats
+         QuickCheck quickcheck-instances semigroups tagged template-haskell
+         text th-lift transformers transformers-compat void
+       ];
+       testToolDepends = [ hspec-discover ];
+       benchmarkHaskellDepends = [
+         array base base-compat bifunctors bytestring bytestring-builder
+         containers contravariant criterion deepseq generic-deriving
+         ghc-boot-th ghc-prim integer-gmp nats semigroups tagged
+         template-haskell text th-lift transformers transformers-compat void
+       ];
+       homepage = "https://github.com/RyanGlScott/text-show";
+       description = "Efficient conversion of values into Text";
+       license = stdenv.lib.licenses.bsd3;
+       hydraPlatforms = stdenv.lib.platforms.none;
+     }) {};
+
   "text-show-instances" = callPackage
     ({ mkDerivation, base, base-compat, bifunctors, binary, bytestring
      , containers, directory, generic-deriving, ghc-boot-th, ghc-prim
@@ -201444,14 +201700,14 @@ self: {
        license = stdenv.lib.licenses.bsd3;
      }) {};
 
-  "type-of-html_1_3_1_1" = callPackage
+  "type-of-html_1_3_2_0" = callPackage
     ({ mkDerivation, base, blaze-html, bytestring, criterion
      , double-conversion, ghc-prim, hspec, QuickCheck, text
      }:
      mkDerivation {
        pname = "type-of-html";
-       version = "1.3.1.1";
-       sha256 = "0idnj14bsqlz1ww2bvfa07yqi53gh72diaacnlfdrvgil8n11wvb";
+       version = "1.3.2.0";
+       sha256 = "0zayqf18z3h4ix38gyqqvq2g3k74cm5f9gzkg4sh8ijw30xszq8p";
        libraryHaskellDepends = [
          base bytestring double-conversion ghc-prim text
        ];
@@ -211643,6 +211899,34 @@ self: {
        license = stdenv.lib.licenses.bsd3;
      }) {};
 
+  "word2vec-model" = callPackage
+    ({ mkDerivation, attoparsec, base, binary, binary-ieee754
+     , bytestring, conduit, conduit-combinators, conduit-extra, hspec
+     , HUnit, text, unordered-containers, vector
+     }:
+     mkDerivation {
+       pname = "word2vec-model";
+       version = "0.1.0.0";
+       sha256 = "1dz6q7ym5z5l0pkzmvawpdpjh8z6pf5ph26m0b7k9q95q42qypmj";
+       isLibrary = true;
+       isExecutable = true;
+       libraryHaskellDepends = [
+         attoparsec base binary binary-ieee754 bytestring text
+         unordered-containers vector
+       ];
+       executableHaskellDepends = [
+         attoparsec base binary binary-ieee754 bytestring conduit
+         conduit-combinators conduit-extra text unordered-containers vector
+       ];
+       testHaskellDepends = [
+         attoparsec base binary binary-ieee754 bytestring hspec HUnit text
+         unordered-containers vector
+       ];
+       homepage = "https://gonito.net/gitlist/word2vec-model.git";
+       description = "Reading word2vec binary models";
+       license = stdenv.lib.licenses.bsd3;
+     }) {};
+
   "word8" = callPackage
     ({ mkDerivation, base, bytestring, criterion, hspec }:
      mkDerivation {
@@ -217441,7 +217725,7 @@ self: {
        license = stdenv.lib.licenses.mit;
      }) {};
 
-  "yesod-test_1_5_9" = callPackage
+  "yesod-test_1_5_9_1" = callPackage
     ({ mkDerivation, attoparsec, base, blaze-builder, blaze-html
      , blaze-markup, bytestring, case-insensitive, containers, cookie
      , hspec, hspec-core, html-conduit, http-types, HUnit, lifted-base
@@ -217451,8 +217735,8 @@ self: {
      }:
      mkDerivation {
        pname = "yesod-test";
-       version = "1.5.9";
-       sha256 = "1kmqrm5qk3wnmrqsq0jmglabs731dw4d7b0jp3sn1z5lqgxm7kzm";
+       version = "1.5.9.1";
+       sha256 = "05l5n28azbh6r1vsi7xvz1h19if5zrwn1b3jsr2913axfs3d9r3y";
        libraryHaskellDepends = [
          attoparsec base blaze-builder blaze-html blaze-markup bytestring
          case-insensitive containers cookie hspec-core html-conduit
diff --git a/pkgs/development/libraries/libqmatrixclient/default.nix b/pkgs/development/libraries/libqmatrixclient/default.nix
index dc4981798bce..f537013d2fec 100644
--- a/pkgs/development/libraries/libqmatrixclient/default.nix
+++ b/pkgs/development/libraries/libqmatrixclient/default.nix
@@ -6,13 +6,13 @@
 
 stdenv.mkDerivation rec {
   name = "libqmatrixclient-${version}";
-  version = "0.1";
+  version = "0.2";
 
   src = fetchFromGitHub {
     owner  = "QMatrixClient";
     repo   = "libqmatrixclient";
-    rev    = "v${version}";
-    sha256 = "1dlanf0y65zf6n1b1f4jzw04w07sl85wiw01c3yyn2ivp3clr13l";
+    rev    = "v${version}-q0.0.5";
+    sha256 = "1m53yxsqjxv2jq0h1xipwsgaj5rca4fk4cl3azgvmf19l9yn00ck";
   };
 
   buildInputs = [ qtbase ];
diff --git a/pkgs/development/libraries/libtoxcore/default.nix b/pkgs/development/libraries/libtoxcore/default.nix
index af9c38a96346..a742be3c1e4d 100644
--- a/pkgs/development/libraries/libtoxcore/default.nix
+++ b/pkgs/development/libraries/libtoxcore/default.nix
@@ -3,13 +3,13 @@
 
 stdenv.mkDerivation rec {
   name = "libtoxcore-${version}";
-  version = "0.1.10";
+  version = "0.1.11";
 
   src = fetchFromGitHub {
     owner  = "TokTok";
     repo   = "c-toxcore";
     rev    = "v${version}";
-    sha256 = "1d3f7lnlxra2lhih838bvlahxqv50j35g9kfyzspq971sb5z30mv";
+    sha256 = "1fya5gfiwlpk6fxhalv95n945ymvp2iidiyksrjw1xw95fzsp1ij";
   };
 
   cmakeFlags = [
@@ -37,7 +37,8 @@ stdenv.mkDerivation rec {
   doCheck = true;
 
   meta = with stdenv.lib; {
-    description = "P2P FOSS instant messaging application aimed to replace Skype with crypto";
+    description = "P2P FOSS instant messaging application aimed to replace Skype";
+    homepage = https://tox.chat;
     license = licenses.gpl3Plus;
     maintainers = with maintainers; [ peterhoeg ];
     platforms = platforms.all;
diff --git a/pkgs/development/libraries/libxc/default.nix b/pkgs/development/libraries/libxc/default.nix
new file mode 100644
index 000000000000..925c1b6d083d
--- /dev/null
+++ b/pkgs/development/libraries/libxc/default.nix
@@ -0,0 +1,31 @@
+{ stdenv, fetchurl, gfortran, perl }:
+
+let
+  version = "2.2.3";
+in stdenv.mkDerivation {
+  name = "libxc-${version}";
+  src = fetchurl {
+    url = "http://www.tddft.org/programs/octopus/down.php?file=libxc/libxc-${version}.tar.gz";
+    sha256 = "1rv8vsf7zzw0g7j93rqcipzhk2pj1iq71bpkwf7zxivmgavh0arg";
+  };
+
+  buildInputs = [ gfortran ];
+  nativeBuildInputs = [ perl ];
+
+  preConfigure = ''
+    patchShebangs ./
+  '';
+
+  configureFlags = [ "--enable-shared" ];
+
+  doCheck = true;
+  enableParallelBuilding = true;
+
+  meta = with stdenv.lib; {
+    description = "Library of exchange-correlation functionals for density-functional theory";
+    homepage = http://octopus-code.org/wiki/Libxc;
+    license = licenses.lgpl3;
+    platforms = platforms.linux;
+    maintainers = with maintainers; [ markuskowa ];
+  };
+}
diff --git a/pkgs/development/python-modules/mygpoclient/default.nix b/pkgs/development/python-modules/mygpoclient/default.nix
new file mode 100644
index 000000000000..14819b0b66e4
--- /dev/null
+++ b/pkgs/development/python-modules/mygpoclient/default.nix
@@ -0,0 +1,31 @@
+{ stdenv, fetchFromGitHub, buildPythonPackage, nose, minimock }:
+
+buildPythonPackage rec {
+  name = "mygpoclient-${version}";
+  version = "1.8";
+
+  src = fetchFromGitHub {
+    owner = "gpodder";
+    repo = "mygpoclient";
+    rev = version;
+    sha256 = "0aa28wc55x3rxa7clwfv5v5500ffyaq0vkxaa3v01y1r93dxkdvp";
+  };
+
+  buildInputs = [ nose minimock ];
+
+  checkPhase = ''
+    nosetests
+  '';
+
+  meta = with stdenv.lib; {
+    description = "A gpodder.net client library";
+    longDescription = ''
+        The mygpoclient library allows developers to utilize a Pythonic interface
+        to the gpodder.net web services.
+    '';
+    homepage = https://github.com/gpodder/mygpoclient;
+    license = with licenses; [ gpl3 ];
+    platforms = with platforms; linux ++ darwin;
+    maintainers = with maintainers; [ skeidel ];
+  };
+}
diff --git a/pkgs/development/tools/analysis/rr/default.nix b/pkgs/development/tools/analysis/rr/default.nix
index b993a22ccd40..84bcac18b0fd 100644
--- a/pkgs/development/tools/analysis/rr/default.nix
+++ b/pkgs/development/tools/analysis/rr/default.nix
@@ -1,14 +1,14 @@
 { stdenv, fetchFromGitHub, cmake, libpfm, zlib, pkgconfig, python2Packages, which, procps, gdb, capnproto }:
 
 stdenv.mkDerivation rec {
-  version = "5.0.0";
+  version = "5.1.0";
   name = "rr-${version}";
 
   src = fetchFromGitHub {
     owner = "mozilla";
     repo = "rr";
     rev = version;
-    sha256 = "1cc1dbq129qlmrysk7cmaihcd9c93csi79dv3kqsnnprbz480z9i";
+    sha256 = "16v08irycb295jjw5yrcjdagvkgcgg4hl5qz215hrw1ff4g7sazy";
   };
 
   postPatch = ''