summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/python-modules/spectral-cube/default.nix30
1 files changed, 30 insertions, 0 deletions
diff --git a/pkgs/development/python-modules/spectral-cube/default.nix b/pkgs/development/python-modules/spectral-cube/default.nix
new file mode 100644
index 000000000000..3f54fefadf24
--- /dev/null
+++ b/pkgs/development/python-modules/spectral-cube/default.nix
@@ -0,0 +1,30 @@
+{ lib
+, fetchPypi
+, buildPythonPackage
+, astropy
+, radio_beam
+, pytest }:
+
+buildPythonPackage rec {
+  pname = "spectral-cube";
+  version = "0.4.3";
+
+  doCheck = false; # the tests requires several pytest plugins that are not in nixpkgs
+
+  src = fetchPypi {
+    inherit pname version;
+    sha256 = "057g3mzlg5cy4wg2hh3p6gssn93rs6i7pswzhldvcq4k8m8hsl3b";
+  };
+
+  propagatedBuildInputs = [ astropy radio_beam pytest ];
+
+  meta = {
+    description = "Library for reading and analyzing astrophysical spectral data cubes";
+    homepage = http://radio-astro-tools.github.io;
+    license = lib.licenses.bsd3;
+    platforms = lib.platforms.all;
+    maintainers = with lib.maintainers; [ smaret ];
+  };
+}
+
+