about summary refs log tree commit diff
path: root/pkgs/data
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/data')
-rw-r--r--pkgs/data/fonts/iosevka/default.nix4
-rw-r--r--pkgs/data/fonts/orbitron/default.nix50
-rw-r--r--pkgs/data/misc/geolite-legacy/default.nix6
3 files changed, 55 insertions, 5 deletions
diff --git a/pkgs/data/fonts/iosevka/default.nix b/pkgs/data/fonts/iosevka/default.nix
index aded5b1cddfa..cbd963e903df 100644
--- a/pkgs/data/fonts/iosevka/default.nix
+++ b/pkgs/data/fonts/iosevka/default.nix
@@ -1,4 +1,4 @@
-{ stdenv, lib, fetchFromGitHub }:
+{ stdenv, fetchFromGitHub }:
 
 stdenv.mkDerivation rec {
   name = "iosevka-${version}";
@@ -18,7 +18,7 @@ stdenv.mkDerivation rec {
     cp -v iosevka-* $fontdir
   '';
 
-  meta = with lib; {
+  meta = with stdenv.lib; {
     homepage = "http://be5invis.github.io/Iosevka/";
     downloadPage = "https://github.com/be5invis/Iosevka/releases";
     description = ''
diff --git a/pkgs/data/fonts/orbitron/default.nix b/pkgs/data/fonts/orbitron/default.nix
new file mode 100644
index 000000000000..d68bf37f4da8
--- /dev/null
+++ b/pkgs/data/fonts/orbitron/default.nix
@@ -0,0 +1,50 @@
+{ stdenv, fetchFromGitHub }:
+
+stdenv.mkDerivation rec {
+  name = "orbitron-${version}";
+  version = "20110526";
+
+  src = fetchFromGitHub {
+    owner  = "theleagueof";
+    repo   = "orbitron";
+    rev    = "13e6a52";
+    sha256 = "1c6jb7ayr07j1pbnzf3jxng9x9bbqp3zydf8mqdw9ifln1b4ycyf";
+  };
+
+  phases = [ "unpackPhase" "installPhase" ];
+
+  installPhase = ''
+    otfdir=$out/share/fonts/opentype/orbitron
+    ttfdir=$out/share/fonts/ttf/orbitron
+    mkdir -p $otfdir $ttfdir
+    cp -v Orbitron*.otf $otfdir
+    cp -v Orbitron*.ttf $ttfdir
+  '';
+
+  meta = with stdenv.lib; {
+    homepage = "https://www.theleagueofmoveabletype.com/orbitron";
+    downloadPage = "https://www.theleagueofmoveabletype.com/orbitron/download";
+    description = ''
+     Geometric sans-serif for display purposes by Matt McInerney'';
+    longDescription = ''
+     Orbitron is a geometric sans-serif typeface intended for display
+     purposes. It features four weights (light, medium, bold, and
+     black), a stylistic alternative, small caps, and a ton of
+     alternate glyphs.
+
+     Orbitron was designed so that graphic designers in the future
+     will have some alternative to typefaces like Eurostile or Bank
+     Gothic. If you’ve ever seen a futuristic sci-fi movie, you have
+     may noticed that all other fonts have been lost or destroyed in
+     the apocalypse that led humans to flee earth. Only those very few
+     geometric typefaces have survived to be used on spaceship
+     exteriors, space station signage, monopolistic corporate
+     branding, uniforms featuring aerodynamic shoulder pads, etc. Of
+     course Orbitron could also be used on the posters for the movies
+     portraying this inevitable future.
+    '';
+    license = licenses.ofl;
+    platforms = platforms.all;
+    maintainers = [ maintainers.leenaars ];
+  };
+}
diff --git a/pkgs/data/misc/geolite-legacy/default.nix b/pkgs/data/misc/geolite-legacy/default.nix
index bc63ed1ce894..309d88e4f177 100644
--- a/pkgs/data/misc/geolite-legacy/default.nix
+++ b/pkgs/data/misc/geolite-legacy/default.nix
@@ -8,7 +8,7 @@ let
 in
 stdenv.mkDerivation rec {
   name = "geolite-legacy-${version}";
-  version = "2016-06-30";
+  version = "2016-07-04";
 
   srcGeoIP = fetchDB
     "GeoLiteCountry/GeoIP.dat.gz" "GeoIP.dat.gz"
@@ -24,10 +24,10 @@ stdenv.mkDerivation rec {
     "0dq5rh08xgwsrmkniww001b2dpd1d7db4sd385p70hkbbry496l3";
   srcGeoIPASNum = fetchDB
     "asnum/GeoIPASNum.dat.gz" "GeoIPASNum.dat.gz"
-    "02c1ncjq5l0q6zwpahjap26mljfgmmwab1aklsghpmilai28gfzv";
+    "168z6j6adrn80sl3ip41fa0jfv2p26lfa8qil6w17sqhg8f61rnp";
   srcGeoIPASNumv6 = fetchDB
     "asnum/GeoIPASNumv6.dat.gz" "GeoIPASNumv6.dat.gz"
-    "02y5zdxh9zc3rw57qhlglm9i21q9jmr6q7cdy98qb5z53w53dqhh";
+    "0q0vgjgxixcq5qnl5d6hxg3bpsbylmmjkhdp308vbbd68q6fws22";
 
   meta = with stdenv.lib; {
     description = "GeoLite Legacy IP geolocation databases";