about summary refs log tree commit diff
path: root/pkgs/build-support
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/build-support')
-rw-r--r--pkgs/build-support/build-fhs-userenv/env.nix8
-rwxr-xr-xpkgs/build-support/docker/store-path-to-layer.sh2
2 files changed, 6 insertions, 4 deletions
diff --git a/pkgs/build-support/build-fhs-userenv/env.nix b/pkgs/build-support/build-fhs-userenv/env.nix
index c0f741b62886..be83c9da2108 100644
--- a/pkgs/build-support/build-fhs-userenv/env.nix
+++ b/pkgs/build-support/build-fhs-userenv/env.nix
@@ -36,12 +36,14 @@ let
 
   # base packages of the chroot
   # these match the host's architecture, glibc_multi is used for multilib
-  # builds.
+  # builds. glibcLocales must be before glibc or glibc_multi as otherwiese
+  # the wrong LOCALE_ARCHIVE will be used where only C.UTF-8 is available.
   basePkgs = with pkgs;
-    [ (if isMultiBuild then glibc_multi else glibc)
+    [ glibcLocales
+      (if isMultiBuild then glibc_multi else glibc)
       (toString gcc.cc.lib) bashInteractive coreutils less shadow su
       gawk diffutils findutils gnused gnugrep
-      gnutar gzip bzip2 xz glibcLocales
+      gnutar gzip bzip2 xz
     ];
   baseMultiPkgs = with pkgsi686Linux;
     [ (toString gcc.cc.lib)
diff --git a/pkgs/build-support/docker/store-path-to-layer.sh b/pkgs/build-support/docker/store-path-to-layer.sh
index ab956c819040..98c5b8cc2129 100755
--- a/pkgs/build-support/docker/store-path-to-layer.sh
+++ b/pkgs/build-support/docker/store-path-to-layer.sh
@@ -1,4 +1,4 @@
-#! @shell@
+#!@shell@
 
 set -eu