summary refs log tree commit diff
path: root/pkgs/build-support
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/build-support')
-rw-r--r--pkgs/build-support/builder-defs/template-auto-callable.nix16
1 files changed, 13 insertions, 3 deletions
diff --git a/pkgs/build-support/builder-defs/template-auto-callable.nix b/pkgs/build-support/builder-defs/template-auto-callable.nix
index 4801e4253028..d0e6e7e7492f 100644
--- a/pkgs/build-support/builder-defs/template-auto-callable.nix
+++ b/pkgs/build-support/builder-defs/template-auto-callable.nix
@@ -4,16 +4,21 @@ x@{builderDefsPackage
 builderDefsPackage
 (a :  
 let 
-  s = import ./src-for-default.nix;
   helperArgNames = ["stdenv" "fetchurl" "builderDefsPackage"] ++ 
     [(abort "Specify helper argument names")];
+
   buildInputs = map (n: builtins.getAttr n x)
     (builtins.attrNames (builtins.removeAttrs x helperArgNames));
+  sourceInfo = {
+  };
 in
 rec {
-  src = a.fetchUrlFromSrcInfo s;
+  src = a.fetchurl {
+    url = sourceInfo.url;
+    sha256 = sourceInfo.hash;
+  };
 
-  inherit (s) name;
+  inherit (sourceInfo) name version;
   inherit buildInputs;
 
   /* doConfigure should be removed if not needed */
@@ -28,5 +33,10 @@ rec {
     platforms = with a.lib.platforms;
       (abort "Specify platforms");
   };
+  passthru = {
+    updateInfo = {
+      downloadPage = "${abort ''Specify download page''}";
+    };
+  };
 }) x