about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/audio/lsp-plugins/default.nix4
-rw-r--r--pkgs/applications/emulators/ppsspp/default.nix4
-rw-r--r--pkgs/applications/emulators/wineasio/default.nix53
-rw-r--r--pkgs/applications/file-managers/doublecmd/default.nix4
-rw-r--r--pkgs/applications/misc/jquake/default.nix4
-rw-r--r--pkgs/applications/misc/usql/default.nix21
-rw-r--r--pkgs/applications/networking/cluster/arkade/default.nix4
-rw-r--r--pkgs/applications/networking/cluster/atmos/default.nix6
-rw-r--r--pkgs/applications/networking/cluster/glooctl/default.nix4
-rw-r--r--pkgs/applications/networking/giara/default.nix17
-rw-r--r--pkgs/applications/networking/instant-messengers/signal-desktop/default.nix4
-rw-r--r--pkgs/applications/office/beamerpresenter/default.nix8
-rw-r--r--pkgs/applications/science/electronics/nanovna-saver/default.nix4
13 files changed, 96 insertions, 41 deletions
diff --git a/pkgs/applications/audio/lsp-plugins/default.nix b/pkgs/applications/audio/lsp-plugins/default.nix
index c0da4fd228a0..f53f4c972af8 100644
--- a/pkgs/applications/audio/lsp-plugins/default.nix
+++ b/pkgs/applications/audio/lsp-plugins/default.nix
@@ -5,11 +5,11 @@
 
 stdenv.mkDerivation rec {
         pname = "lsp-plugins";
-        version = "1.2.2";
+        version = "1.2.3";
 
         src = fetchurl {
                 url = "https://github.com/sadko4u/${pname}/releases/download/${version}/${pname}-src-${version}.tar.gz";
-                sha256 = "sha256-qIakDWNs8fQmlw/VHwTET2LmIvI+6I6zK88bmsWF4VI=";
+                sha256 = "sha256-ej8t3xk29VLJMO1lvXuzUlD00al8TTkPLL8z62fmTys=";
         };
 
         nativeBuildInputs = [ pkg-config php makeWrapper ];
diff --git a/pkgs/applications/emulators/ppsspp/default.nix b/pkgs/applications/emulators/ppsspp/default.nix
index 6281cbd2c088..2d1f583d7419 100644
--- a/pkgs/applications/emulators/ppsspp/default.nix
+++ b/pkgs/applications/emulators/ppsspp/default.nix
@@ -38,14 +38,14 @@ in
       + lib.optionalString enableQt "-qt"
       + lib.optionalString (!enableQt) "-sdl"
       + lib.optionalString forceWayland "-wayland";
-    version = "1.13.1";
+    version = "1.13.2";
 
     src = fetchFromGitHub {
       owner = "hrydgard";
       repo = "ppsspp";
       rev = "v${finalAttrs.version}";
       fetchSubmodules = true;
-      sha256 = "sha256-WsFy2aSOmkII2Lte5et4W6qj0AXUKWWkYe88T0OQP08=";
+      sha256 = "sha256-Ubbl2KCZ4QlWDtTxl4my0nKNGY25DOkD/iEurzVx4gU=";
     };
 
     postPatch = ''
diff --git a/pkgs/applications/emulators/wineasio/default.nix b/pkgs/applications/emulators/wineasio/default.nix
new file mode 100644
index 000000000000..5a47111610d1
--- /dev/null
+++ b/pkgs/applications/emulators/wineasio/default.nix
@@ -0,0 +1,53 @@
+{ multiStdenv
+, lib
+, fetchFromGitHub
+, libjack2
+, pkg-config
+, wineWowPackages
+, pkgsi686Linux
+}:
+
+multiStdenv.mkDerivation rec {
+  pname = "wineasio";
+  version = "1.1.0";
+
+  src = fetchFromGitHub {
+    owner = pname;
+    repo = pname;
+    rev = "v${version}";
+    hash = "sha256-HEnJj9yfXe+NQuPATMpPvseFs+3TkiMLd1L+fIfQd+o=";
+    fetchSubmodules = true;
+  };
+
+  nativeBuildInputs = [ pkg-config wineWowPackages.stable ];
+
+  buildInputs = [ pkgsi686Linux.libjack2 libjack2 ];
+
+  dontConfigure = true;
+
+  makeFlags = [ "PREFIX=${wineWowPackages.stable}" ];
+
+  buildPhase = ''
+    runHook preBuild
+    make "''${makeFlags[@]}" 32
+    make "''${makeFlags[@]}" 64
+    runHook postBuild
+  '';
+
+  installPhase = ''
+    runHook preInstall
+    install -D build32/wineasio.dll $out/lib/wine/i386-windows/wineasio.dll
+    install -D build32/wineasio.dll.so $out/lib/wine/i386-unix/wineasio.dll.so
+    install -D build64/wineasio.dll $out/lib/wine/x86_64-windows/wineasio.dll
+    install -D build64/wineasio.dll.so $out/lib/wine/x86_64-unix/wineasio.dll.so
+    runHook postInstall
+  '';
+
+  meta = with lib; {
+    homepage = "https://github.com/wineasio/wineasio";
+    description = "ASIO to JACK driver for WINE";
+    license = with licenses; [ gpl2 lgpl21 ];
+    maintainers = with maintainers; [ lovesegfault ];
+    platforms = platforms.linux;
+  };
+}
diff --git a/pkgs/applications/file-managers/doublecmd/default.nix b/pkgs/applications/file-managers/doublecmd/default.nix
index 0222f5be4838..656ec20c4c5d 100644
--- a/pkgs/applications/file-managers/doublecmd/default.nix
+++ b/pkgs/applications/file-managers/doublecmd/default.nix
@@ -13,13 +13,13 @@
 
 stdenv.mkDerivation rec {
   pname = "doublecmd";
-  version = "1.0.6";
+  version = "1.0.7";
 
   src = fetchFromGitHub {
     owner = "doublecmd";
     repo = "doublecmd";
     rev = "v${version}";
-    hash = "sha256-aEWu/bRVOwjK6QTWsMntRYwAfjuwo9SNuH4qkQn0mOY=";
+    hash = "sha256-HscDzeWM9lp6ba+VrXHIFmbWfE8ILg6WDn6q5WCOaOg=";
   };
 
   nativeBuildInputs = [
diff --git a/pkgs/applications/misc/jquake/default.nix b/pkgs/applications/misc/jquake/default.nix
index 192f8f06a047..22e6764beeba 100644
--- a/pkgs/applications/misc/jquake/default.nix
+++ b/pkgs/applications/misc/jquake/default.nix
@@ -4,11 +4,11 @@
 
 stdenv.mkDerivation rec {
   pname = "jquake";
-  version = "1.7.1";
+  version = "1.8.1";
 
   src = fetchurl {
     url = "https://fleneindre.github.io/downloads/JQuake_${version}_linux.zip";
-    sha256 = "sha256-sdTt1+1eAU/DJAszPQnmoaBZThJ9yC9GL1k+OpD+tp4=";
+    sha256 = "sha256-fIxCcqpv0KAXUBbyinTXr/fkAcufVtpr9FUTJkXSgTs=";
   };
 
   nativeBuildInputs = [ unzip copyDesktopItems ];
diff --git a/pkgs/applications/misc/usql/default.nix b/pkgs/applications/misc/usql/default.nix
index edd1bd588dc7..cc02a5d1c899 100644
--- a/pkgs/applications/misc/usql/default.nix
+++ b/pkgs/applications/misc/usql/default.nix
@@ -7,19 +7,28 @@
 
 buildGoModule rec {
   pname = "usql";
-  version = "0.12.0";
+  version = "0.12.13";
 
   src = fetchFromGitHub {
     owner = "xo";
     repo = "usql";
     rev = "v${version}";
-    sha256 = "sha256-OOu3zWK/ccmaEVriXKl7SZUJLLYaJB3tgF+eR9p+TmM=";
+    hash = "sha256-F/eOD7/w8HjJBeiXagaf4yBLZcZVuy93rfVFeSESlZo=";
   };
 
-  vendorSha256 = "sha256-9XyG0Fu3idxGG01MoBr5BMoQSz+dyZFEXRNvvb+XWjA=";
+  vendorHash = "sha256-7rMCqTfUs89AX0VP689BmKsuvLJWU5ANJVki+JMVf7g=";
 
   buildInputs = [ unixODBC icu ];
 
+  # Exclude broken impala driver
+  # The driver breaks too often and is not used.
+  #
+  # See https://github.com/xo/usql/pull/347
+  #
+  excludedPackages = [
+    "impala"
+  ];
+
   # These tags and flags are copied from build-release.sh
   tags = [
     "most"
@@ -47,9 +56,7 @@ buildGoModule rec {
     description = "Universal command-line interface for SQL databases";
     homepage = "https://github.com/xo/usql";
     license = licenses.mit;
-    maintainers = with maintainers; [ georgyo ];
-    # usql does not build on ARM.
-    platforms = [ "x86_64-linux" "x86_64-darwin" ];
+    maintainers = with maintainers; [ georgyo anthonyroussel ];
+    platforms = with platforms; linux ++ darwin;
   };
-
 }
diff --git a/pkgs/applications/networking/cluster/arkade/default.nix b/pkgs/applications/networking/cluster/arkade/default.nix
index 1c1d9b024e62..22938f0fce10 100644
--- a/pkgs/applications/networking/cluster/arkade/default.nix
+++ b/pkgs/applications/networking/cluster/arkade/default.nix
@@ -7,13 +7,13 @@
 
 buildGoModule rec {
   pname = "arkade";
-  version = "0.8.42";
+  version = "0.8.44";
 
   src = fetchFromGitHub {
     owner = "alexellis";
     repo = "arkade";
     rev = version;
-    sha256 = "sha256-bq4tCizdi8TPRWpNaDmD817rOpnSr9aR4tkDWn48K2w=";
+    sha256 = "sha256-2+/CQhaeg/5FUx/igitt2MM3J0p5qYOQpc9zi60Tqkg=";
   };
 
   CGO_ENABLED = 0;
diff --git a/pkgs/applications/networking/cluster/atmos/default.nix b/pkgs/applications/networking/cluster/atmos/default.nix
index 1e4c86bec1e6..78c687457e05 100644
--- a/pkgs/applications/networking/cluster/atmos/default.nix
+++ b/pkgs/applications/networking/cluster/atmos/default.nix
@@ -2,16 +2,16 @@
 
 buildGoModule rec {
   pname = "atmos";
-  version = "1.4.28";
+  version = "1.7.0";
 
   src = fetchFromGitHub {
     owner = "cloudposse";
     repo = pname;
     rev = "v${version}";
-    sha256 = "sha256-AqW//+x1tKzm5dJirXCLFuDBTk3dHHw7c6vwsVsI37U";
+    sha256 = "sha256-SZ/4QKO8PdbHWZ+urOqZPFUb9lFRP+HWbNff1fmwDqI=";
   };
 
-  vendorSha256 = "sha256-bepv8Ns8vcpLpmO7fsRgGijB9B6kQ5HhxUhIuEpGtOY=";
+  vendorSha256 = "sha256-d2Eod1AK6Ei5Az9wPHVqij8K4CVj7Ptewd3dBJ9Wt3o=";
 
   ldflags = [ "-s" "-w" "-X github.com/cloudposse/atmos/cmd.Version=v${version}" ];
 
diff --git a/pkgs/applications/networking/cluster/glooctl/default.nix b/pkgs/applications/networking/cluster/glooctl/default.nix
index 75effcdc8ff5..41398ae2a82c 100644
--- a/pkgs/applications/networking/cluster/glooctl/default.nix
+++ b/pkgs/applications/networking/cluster/glooctl/default.nix
@@ -2,13 +2,13 @@
 
 buildGoModule rec {
   pname = "glooctl";
-  version = "1.12.12";
+  version = "1.12.15";
 
   src = fetchFromGitHub {
     owner = "solo-io";
     repo = "gloo";
     rev = "v${version}";
-    hash = "sha256-aQUN1T6AH1TRj2pPkNFoS5Fmo3NPmmiEXFZfFeXtN1w=";
+    hash = "sha256-HOWBigwW5JagFG1MfcFIXSzveGAj1BWjLbJL9ESLgAQ=";
   };
 
   subPackages = [ "projects/gloo/cli/cmd" ];
diff --git a/pkgs/applications/networking/giara/default.nix b/pkgs/applications/networking/giara/default.nix
index b17430dc09bd..60c2ad8262ca 100644
--- a/pkgs/applications/networking/giara/default.nix
+++ b/pkgs/applications/networking/giara/default.nix
@@ -14,11 +14,11 @@
 , glib-networking
 , libadwaita
 , appstream
+, blueprint-compiler
 }:
-
 python3.pkgs.buildPythonApplication rec {
   pname = "giara";
-  version = "1.0";
+  version = "1.0.1";
 
   format = "other";
 
@@ -27,7 +27,7 @@ python3.pkgs.buildPythonApplication rec {
     owner = "World";
     repo = pname;
     rev = version;
-    hash = "sha256-xDIzgr8zYal0r0sASWqiSZANCMC52LrVmLjlnGAd2Mg=";
+    hash = "sha256-hKaniW+bbuKUrETMQGWwvC2kyudK9tCE/R69dOFzdQM=";
   };
 
   nativeBuildInputs = [
@@ -37,6 +37,7 @@ python3.pkgs.buildPythonApplication rec {
     pkg-config
     ninja
     wrapGAppsHook4
+    blueprint-compiler
   ];
 
   buildInputs = [
@@ -58,16 +59,6 @@ python3.pkgs.buildPythonApplication rec {
     beautifulsoup4
   ];
 
-  patches = [
-    # Proper support for gtk4 and libadwaita
-    # @TODO: Remove when bumping the version.
-    (fetchpatch {
-      name = "giara-gtk4-libadwaita.patch";
-      url = "https://gitlab.gnome.org/World/giara/-/commit/6204427f8b8e3d8c72b669717a3f129ffae401d9.patch";
-      sha256 = "sha256-E8kbVsACPD2gkfNrzYUy0+1U7+/pIkUu4rCkX+xY0us=";
-    })
-  ];
-
   postPatch = ''
     substituteInPlace meson_post_install.py \
       --replace "gtk-update-icon-cache" "gtk4-update-icon-cache"
diff --git a/pkgs/applications/networking/instant-messengers/signal-desktop/default.nix b/pkgs/applications/networking/instant-messengers/signal-desktop/default.nix
index fdedea7244b5..49e2ca360d0c 100644
--- a/pkgs/applications/networking/instant-messengers/signal-desktop/default.nix
+++ b/pkgs/applications/networking/instant-messengers/signal-desktop/default.nix
@@ -9,7 +9,7 @@
 
 stdenv.mkDerivation rec {
   pname = "signal-desktop";
-  version = "5.57.0"; # Please backport all updates to the stable channel.
+  version = "5.58.0"; # Please backport all updates to the stable channel.
   # All releases have a limited lifetime and "expire" 90 days after the release.
   # When releases "expire" the application becomes unusable until an update is
   # applied. The expiration date for the current release can be extracted with:
@@ -19,7 +19,7 @@ stdenv.mkDerivation rec {
 
   src = fetchurl {
     url = "https://updates.signal.org/desktop/apt/pool/main/s/signal-desktop/signal-desktop_${version}_amd64.deb";
-    sha256 = "sha256-42xKqK/7V2GPHk/L396O7UoWn5vTyILVTbLa0Tf6NaY=";
+    sha256 = "sha256-1UM68aDXM0MseQmOAVmX13yD/GLPCmq6wikt8CwEdgc=";
   };
 
   nativeBuildInputs = [
diff --git a/pkgs/applications/office/beamerpresenter/default.nix b/pkgs/applications/office/beamerpresenter/default.nix
index c716323d4fcc..2e4959ce0a52 100644
--- a/pkgs/applications/office/beamerpresenter/default.nix
+++ b/pkgs/applications/office/beamerpresenter/default.nix
@@ -22,17 +22,18 @@
 # choose renderer: mupdf or poppler or both (not recommended)
 , usePoppler ? false
 , useMupdf ? true
+, useExternalRenderer ? false
 }:
 
 stdenv.mkDerivation rec {
   pname = "beamerpresenter";
-  version = "0.2.2";
+  version = "0.2.3";
 
   src = fetchFromGitHub {
     owner = "stiglers-eponym";
     repo = "BeamerPresenter";
     rev = "v${version}";
-    sha256 = "16v263nnnipih3lxg95rmwz0ihnvpl4n1wlj9r6zavnspzlp9dvb";
+    sha256 = "1n9d0i0j67ymnghn8zkqf52c88zby6rqin8aicbw8cpn35fqf5a6";
   };
 
   nativeBuildInputs = [
@@ -67,6 +68,9 @@ stdenv.mkDerivation rec {
     "-DGIT_VERSION=OFF"
     "-DUSE_POPPLER=${if usePoppler then "ON" else "OFF"}"
     "-DUSE_MUPDF=${if useMupdf then "ON" else "OFF"}"
+    "-DUSE_QTPDF=OFF"
+    "-DUSE_MUPDF_THIRD=ON"
+    "-DUSE_EXTERNAL_RENDERER=${if useExternalRenderer then "ON" else "OFF"}"
     "-DUSE_MUJS=OFF"
     "-DUSE_GUMBO=ON"
     "-DUSE_TRANSLATIONS=ON"
diff --git a/pkgs/applications/science/electronics/nanovna-saver/default.nix b/pkgs/applications/science/electronics/nanovna-saver/default.nix
index 67b600b19f17..817a3b1c0870 100644
--- a/pkgs/applications/science/electronics/nanovna-saver/default.nix
+++ b/pkgs/applications/science/electronics/nanovna-saver/default.nix
@@ -6,13 +6,13 @@
 }:
 python3.pkgs.buildPythonApplication rec {
   pname = "nanovna-saver";
-  version = "0.5.1";
+  version = "0.5.2";
 
   src = fetchFromGitHub {
     owner = "NanoVNA-Saver";
     repo = pname;
     rev = "refs/tags/v${version}";
-    sha256 = "sha256-2/A9uFYa682cvK2uzvBLZBDouhS6C6Q91v8Pun7GgSw=";
+    sha256 = "sha256-PP4VHEp6NSSLsuYABr0/S3+YuhpAyvh/xGnQGyszCtM=";
   };
 
   nativeBuildInputs = [ wrapQtAppsHook ];