about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/audio/flac/default.nix4
-rw-r--r--pkgs/applications/graphics/ImageMagick/default.nix4
-rw-r--r--pkgs/applications/misc/cool-old-term/default.nix6
-rw-r--r--pkgs/applications/misc/monero/default.nix3
-rw-r--r--pkgs/applications/misc/slic3r/default.nix1
-rw-r--r--pkgs/applications/networking/browsers/mozilla-plugins/fribid/default.nix2
-rw-r--r--pkgs/applications/networking/browsers/netsurf/libsvgtiny.nix2
-rw-r--r--pkgs/applications/networking/browsers/netsurf/libwapcaplet.nix2
-rw-r--r--pkgs/applications/networking/irc/weechat/devel.nix1
-rw-r--r--pkgs/applications/video/vlc/default.nix15
10 files changed, 29 insertions, 11 deletions
diff --git a/pkgs/applications/audio/flac/default.nix b/pkgs/applications/audio/flac/default.nix
index cb3ec1da97cf..5dd706735216 100644
--- a/pkgs/applications/audio/flac/default.nix
+++ b/pkgs/applications/audio/flac/default.nix
@@ -1,11 +1,11 @@
 { stdenv, fetchurl, libogg }:
 
 stdenv.mkDerivation rec {
-  name = "flac-1.3.0";
+  name = "flac-1.3.1";
 
   src = fetchurl {
     url = "http://downloads.xiph.org/releases/flac/${name}.tar.xz";
-    sha256 = "1p0hh190kqvpkbk1bbajd81jfbmkyl4fn2i7pggk2zppq6m68bgs";
+    sha256 = "4773c0099dba767d963fd92143263be338c48702172e8754b9bc5103efe1c56c";
   };
 
   buildInputs = [ libogg ];
diff --git a/pkgs/applications/graphics/ImageMagick/default.nix b/pkgs/applications/graphics/ImageMagick/default.nix
index 69bc2006666c..8ae4bc2dd1b1 100644
--- a/pkgs/applications/graphics/ImageMagick/default.nix
+++ b/pkgs/applications/graphics/ImageMagick/default.nix
@@ -20,7 +20,7 @@
 
 let
 
-  version = "6.8.9-8";
+  version = "6.9.0-0";
 
   arch =
     if stdenv.system == "i686-linux" then "i686"
@@ -34,7 +34,7 @@ stdenv.mkDerivation rec {
 
   src = fetchurl {
     url = "mirror://imagemagick/releases/${name}.tar.xz";
-    sha256 = "1c792hbwi308lm9xkml319xaa4w3bz6hwy6i92jwrm7kqr4h8di7";
+    sha256 = "1dmrl5x63msdnxsf4cmhz5v4ard2z3jrgp2zhqlb27399j81qcqj";
   };
 
   enableParallelBuilding = true;
diff --git a/pkgs/applications/misc/cool-old-term/default.nix b/pkgs/applications/misc/cool-old-term/default.nix
index 76d78f004024..c56393a1be83 100644
--- a/pkgs/applications/misc/cool-old-term/default.nix
+++ b/pkgs/applications/misc/cool-old-term/default.nix
@@ -1,4 +1,4 @@
-{ stdenv, fetchFromGitHub, qt53 }:
+{ stdenv, fetchFromGitHub, qt5 }:
 
 stdenv.mkDerivation rec {
   version = "0.9";
@@ -11,7 +11,7 @@ stdenv.mkDerivation rec {
     sha256 = "8462f3eded7b2219acc143258544b0dfac32d81e10cac61ff14276d426704c93";
   };
 
-  buildInputs = [ qt53 ];
+  buildInputs = [ qt5 ];
 
   buildPhase = ''
     pushd ./konsole-qml-plugin
@@ -31,7 +31,7 @@ stdenv.mkDerivation rec {
 
     cat > $out/bin/cool-old-term <<EOF
     #!${stdenv.shell}
-    ${qt53}/bin/qmlscene -I $out/lib/cool-old-term/imports $out/share/cool-old-term/app/main.qml
+    ${qt5}/bin/qmlscene -I $out/lib/cool-old-term/imports $out/share/cool-old-term/app/main.qml
     EOF
     chmod a+x $out/bin/cool-old-term
   '';
diff --git a/pkgs/applications/misc/monero/default.nix b/pkgs/applications/misc/monero/default.nix
index 1fe5406384f8..6af9b7dc267d 100644
--- a/pkgs/applications/misc/monero/default.nix
+++ b/pkgs/applications/misc/monero/default.nix
@@ -16,6 +16,9 @@ stdenv.mkDerivation {
   # these tests take a long time and don't
   # always complete in the build environment
   postPatch = "sed -i '/add_subdirectory(tests)/d' CMakeLists.txt";
+
+  NIX_CFLAGS_COMPILE = "-Wno-error=cpp";
+
   doCheck = false;
   checkTarget = "test-release"; # this would be the target
 
diff --git a/pkgs/applications/misc/slic3r/default.nix b/pkgs/applications/misc/slic3r/default.nix
index a057197a92de..727bb0486053 100644
--- a/pkgs/applications/misc/slic3r/default.nix
+++ b/pkgs/applications/misc/slic3r/default.nix
@@ -69,5 +69,6 @@ stdenv.mkDerivation rec {
     license = licenses.agpl3;
     platforms = platforms.linux;
     maintainers = with maintainers; [ bjornfor the-kenny ];
+    broken = true; # requires Perl 5.14
   };
 }
diff --git a/pkgs/applications/networking/browsers/mozilla-plugins/fribid/default.nix b/pkgs/applications/networking/browsers/mozilla-plugins/fribid/default.nix
index 229aa4f23ba1..3b473019600f 100644
--- a/pkgs/applications/networking/browsers/mozilla-plugins/fribid/default.nix
+++ b/pkgs/applications/networking/browsers/mozilla-plugins/fribid/default.nix
@@ -17,6 +17,8 @@ stdenv.mkDerivation rec {
     ./ipc-lazytrace.patch
     ];
 
+  postPatch = "substituteInPlace plugin/pluginutil.c --replace strndup strndup_";
+
   passthru.mozillaPlugin = "/lib/mozilla/plugins";
 
   meta = {
diff --git a/pkgs/applications/networking/browsers/netsurf/libsvgtiny.nix b/pkgs/applications/networking/browsers/netsurf/libsvgtiny.nix
index 300e9965092d..1e9f74a1ffd4 100644
--- a/pkgs/applications/networking/browsers/netsurf/libsvgtiny.nix
+++ b/pkgs/applications/networking/browsers/netsurf/libsvgtiny.nix
@@ -7,6 +7,8 @@ stdenv.mkDerivation {
                (fetchurl { url = "http://mawercer.de/~nix/repos/libsvgtiny-9721.tar.gz"; sha256 = "0c4c8e357c220218a32ef789eb2ba8226a403d4c2b550d7c65f351a0af5d1a71"; });
   # END
 
+  NIX_CFLAGS_COMPILE = "-Wno-error=cpp";
+
   installPhase = "make PREFIX=$out install";
   buildInputs = [pkgconfig gperf libxml2];
 
diff --git a/pkgs/applications/networking/browsers/netsurf/libwapcaplet.nix b/pkgs/applications/networking/browsers/netsurf/libwapcaplet.nix
index 8d19d1c1ef24..5aa15d7b80d0 100644
--- a/pkgs/applications/networking/browsers/netsurf/libwapcaplet.nix
+++ b/pkgs/applications/networking/browsers/netsurf/libwapcaplet.nix
@@ -7,6 +7,8 @@ stdenv.mkDerivation {
                (fetchurl { url = "http://mawercer.de/~nix/repos/libwapcaplet-9721.tar.gz"; sha256 = "7f9f32ca772c939d67f3bc8bf0705544c2b2950760da3fe6a4e069ad0f77d91a"; });
   # END
 
+  NIX_CFLAGS_COMPILE = "-Wno-error=cpp";
+
   installPhase = "make PREFIX=$out install";
   buildInputs = [];
 
diff --git a/pkgs/applications/networking/irc/weechat/devel.nix b/pkgs/applications/networking/irc/weechat/devel.nix
index 34ca4b4d7c6e..a2f32e2b3d3c 100644
--- a/pkgs/applications/networking/irc/weechat/devel.nix
+++ b/pkgs/applications/networking/irc/weechat/devel.nix
@@ -37,5 +37,6 @@ stdenv.mkDerivation rec {
     license     = stdenv.lib.licenses.gpl3;
     maintainers = with stdenv.lib.maintainers; [ lovek323 garbas the-kenny ];
     platforms   = stdenv.lib.platforms.unix;
+    broken      = true; # we have a newer stable that builds
   };
 }
diff --git a/pkgs/applications/video/vlc/default.nix b/pkgs/applications/video/vlc/default.nix
index 71db3d40a46f..f1d3cf836adb 100644
--- a/pkgs/applications/video/vlc/default.nix
+++ b/pkgs/applications/video/vlc/default.nix
@@ -1,14 +1,20 @@
 { stdenv, fetchurl, xz, bzip2, perl, xlibs, libdvdnav, libbluray
 , zlib, a52dec, libmad, faad2, ffmpeg, alsaLib
-, pkgconfig, dbus, fribidi, qt4, freefont_ttf, libebml, libmatroska
+, pkgconfig, dbus, fribidi, freefont_ttf, libebml, libmatroska
 , libvorbis, libtheora, speex, lua5, libgcrypt, libupnp
 , libcaca, pulseaudio, flac, schroedinger, libxml2, librsvg
 , mpeg2dec, udev, gnutls, avahi, libcddb, jack2, SDL, SDL_image
 , libmtp, unzip, taglib, libkate, libtiger, libv4l, samba, liboggz
 , libass, libva, libdvbpsi, libdc1394, libraw1394, libopus
 , libvdpau
+, onlyLibVLC ? false
+, qt4 ? null, qt5 ? null, withQt5 ? false
 }:
 
+with stdenv.lib;
+
+assert (withQt5 -> qt5 != null); assert (!withQt5 -> qt4 != null);
+
 stdenv.mkDerivation rec {
   name = "vlc-${version}";
   version = "2.1.5";
@@ -20,13 +26,13 @@ stdenv.mkDerivation rec {
 
   buildInputs =
     [ xz bzip2 perl zlib a52dec libmad faad2 ffmpeg alsaLib libdvdnav libdvdnav.libdvdread
-      libbluray dbus fribidi qt4 libvorbis libtheora speex lua5 libgcrypt
+      libbluray dbus fribidi libvorbis libtheora speex lua5 libgcrypt
       libupnp libcaca pulseaudio flac schroedinger libxml2 librsvg mpeg2dec
       udev gnutls avahi libcddb jack2 SDL SDL_image libmtp unzip taglib
       libkate libtiger libv4l samba liboggz libass libdvbpsi libva
       xlibs.xlibs xlibs.libXv xlibs.libXvMC xlibs.libXpm xlibs.xcbutilkeysyms
       libdc1394 libraw1394 libopus libebml libmatroska libvdpau
-    ];
+    ] ++ [(if withQt5 then qt5 else qt4)];
 
   nativeBuildInputs = [ pkgconfig ];
 
@@ -36,7 +42,8 @@ stdenv.mkDerivation rec {
       "--enable-dc1394"
       "--enable-ncurses"
       "--enable-vdpau"
-    ];
+    ]
+    ++ optional onlyLibVLC  "--disable-vlc";
 
   preConfigure = ''sed -e "s@/bin/echo@echo@g" -i configure'';