summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/editors/vscode/default.nix8
-rw-r--r--pkgs/applications/networking/mailreaders/notmuch/default.nix2
-rw-r--r--pkgs/applications/science/spyder/default.nix18
-rw-r--r--pkgs/applications/version-management/git-and-tools/default.nix2
-rw-r--r--pkgs/applications/version-management/git-and-tools/grv/default.nix9
-rw-r--r--pkgs/applications/version-management/git-and-tools/grv/deps.nix102
-rw-r--r--pkgs/applications/version-management/git-and-tools/svn-all-fast-export/default.nix43
-rw-r--r--pkgs/applications/version-management/git-and-tools/svn2git-kde/default.nix28
8 files changed, 65 insertions, 147 deletions
diff --git a/pkgs/applications/editors/vscode/default.nix b/pkgs/applications/editors/vscode/default.nix
index 5f1d5c50d4e5..8599ff8e93e4 100644
--- a/pkgs/applications/editors/vscode/default.nix
+++ b/pkgs/applications/editors/vscode/default.nix
@@ -2,7 +2,7 @@
   makeWrapper, libXScrnSaver, libxkbfile, libsecret }:
 
 let
-  version = "1.19.3";
+  version = "1.20.0";
   channel = "stable";
 
   plat = {
@@ -12,9 +12,9 @@ let
   }.${stdenv.system};
 
   sha256 = {
-    "i686-linux" = "0qaijcsjy9sysim19gyqmagg8rmxgamf0l74qj3ap0wsv2v7xixr";
-    "x86_64-linux" = "1kvkcrr1hgnssy2z45h8fdgr9j6w94myr2hvlknwcahzxrnrwr7k";
-    "x86_64-darwin" = "19vkv97yq0alnq4dvs62a2vx3f1mvfz1ic63114s9sd6smikrg0g";
+    "i686-linux" = "0lhfljcdb05v0p3kc6zimgd2z057397blfp56bhr7v7wnsi6i40k";
+    "x86_64-linux" = "138kvqa5cixry62yry0lwzxlk9fs8hb4zqzmsd8ag1jjfma8y45k";
+    "x86_64-darwin" = "1adnwlqf2kw8wfjf86a3xg83j1yqnlsdckksw82b06x3j11g91i8";
   }.${stdenv.system};
 
   archive_fmt = if stdenv.system == "x86_64-darwin" then "zip" else "tar.gz";
diff --git a/pkgs/applications/networking/mailreaders/notmuch/default.nix b/pkgs/applications/networking/mailreaders/notmuch/default.nix
index 0c0f55e63370..c23c264559f8 100644
--- a/pkgs/applications/networking/mailreaders/notmuch/default.nix
+++ b/pkgs/applications/networking/mailreaders/notmuch/default.nix
@@ -71,7 +71,7 @@ stdenv.mkDerivation rec {
     [[ -s "$lib" ]] || die "couldn't find libnotmuch"
 
     badname="$(otool -L "$prg" | awk '$1 ~ /libtalloc/ { print $1 }')"
-    goodname="$(find "${talloc}/lib" -name 'libtalloc.?.?.?.dylib')"
+    goodname="$(find "${talloc}/lib" -name 'libtalloc.*.*.*.dylib')"
 
     [[ -n "$badname" ]]  || die "couldn't find libtalloc reference in binary"
     [[ -n "$goodname" ]] || die "couldn't find libtalloc in nix store"
diff --git a/pkgs/applications/science/spyder/default.nix b/pkgs/applications/science/spyder/default.nix
index 0952b61551e3..04a5def81e69 100644
--- a/pkgs/applications/science/spyder/default.nix
+++ b/pkgs/applications/science/spyder/default.nix
@@ -1,7 +1,7 @@
 { stdenv, fetchPypi, unzip, buildPythonApplication, makeDesktopItem
 # mandatory
-, qtpy, numpydoc, qtconsole, qtawesome, jedi, pycodestyle, psutil
-, pyflakes, rope, sphinx, nbconvert, mccabe
+, numpydoc, qtconsole, qtawesome, jedi, pycodestyle, psutil
+, pyflakes, rope, sphinx, nbconvert, mccabe, pyopengl, cloudpickle
 # optional
 , numpy ? null, scipy ? null, matplotlib ? null
 # optional
@@ -10,17 +10,21 @@
 
 buildPythonApplication rec {
   pname = "spyder";
-  version = "3.2.4";
-  namePrefix = "";
+  version = "3.2.6";
 
   src = fetchPypi {
     inherit pname version;
-    sha256 = "028hg71gfq2yrplwhhl7hl4rbwji1l0zxzghblwmb0i443ki10v3";
+    sha256 = "87d6a4f5ee1aac4284461ee3584c3ade50cb53feb3fe35abebfdfb9be18c526a";
   };
 
+  # Somehow setuptools can't find pyqt5. Maybe because the dist-info folder is missing?
+  postPatch = ''
+    substituteInPlace setup.py --replace 'pyqt5;python_version>="3"' ' '
+  '';
+
   propagatedBuildInputs = [
-    jedi pycodestyle psutil qtpy pyflakes rope numpy scipy matplotlib pylint
-    numpydoc qtconsole qtawesome nbconvert mccabe
+    jedi pycodestyle psutil pyflakes rope numpy scipy matplotlib pylint
+    numpydoc qtconsole qtawesome nbconvert mccabe pyopengl cloudpickle
   ];
 
   # There is no test for spyder
diff --git a/pkgs/applications/version-management/git-and-tools/default.nix b/pkgs/applications/version-management/git-and-tools/default.nix
index 96e2220f5827..e5e36e998ace 100644
--- a/pkgs/applications/version-management/git-and-tools/default.nix
+++ b/pkgs/applications/version-management/git-and-tools/default.nix
@@ -117,7 +117,7 @@ rec {
     git = gitSVN;
   };
 
-  svn2git_kde = callPackage ./svn2git-kde { };
+  svn_all_fast_export = libsForQt5.callPackage ./svn-all-fast-export { };
 
   tig = callPackage ./tig { };
 
diff --git a/pkgs/applications/version-management/git-and-tools/grv/default.nix b/pkgs/applications/version-management/git-and-tools/grv/default.nix
index cbcf4cd9aeb7..be5b58c57334 100644
--- a/pkgs/applications/version-management/git-and-tools/grv/default.nix
+++ b/pkgs/applications/version-management/git-and-tools/grv/default.nix
@@ -1,6 +1,6 @@
 { stdenv, buildGoPackage, fetchFromGitHub, curl, libgit2_0_25, ncurses, pkgconfig, readline }:
 let
-  version = "0.1.1";
+  version = "0.1.2";
 in
 buildGoPackage {
   name = "grv-${version}";
@@ -10,15 +10,16 @@ buildGoPackage {
 
   goPackagePath = "github.com/rgburke/grv";
 
-  goDeps = ./deps.nix;
-
   src = fetchFromGitHub {
     owner = "rgburke";
     repo = "grv";
     rev = "v${version}";
-    sha256 = "0q9gvxfw48d4kjpb2jx7lg577vazjg0n961y6ija5saja5n16mk2";
+    sha256 = "1i8cr5xxdacpby60nqfyj8ijyc0h62029kbds2lq26rb8nn9qih2";
+    fetchSubmodules = true;
   };
 
+  buildFlagsArray = [ "-ldflags=" "-X main.version=${version}" ];
+
   meta = with stdenv.lib; {
     description = " GRV is a terminal interface for viewing git repositories";
     homepage = https://github.com/rgburke/grv;
diff --git a/pkgs/applications/version-management/git-and-tools/grv/deps.nix b/pkgs/applications/version-management/git-and-tools/grv/deps.nix
deleted file mode 100644
index 8de555df2e8f..000000000000
--- a/pkgs/applications/version-management/git-and-tools/grv/deps.nix
+++ /dev/null
@@ -1,102 +0,0 @@
-# This file was generated by https://github.com/kamilchm/go2nix v1.2.1
-[
-  {
-    goPackagePath = "github.com/Sirupsen/logrus";
-    fetch = {
-      type = "git";
-      url = "https://github.com/Sirupsen/logrus";
-      rev = "768a92a02685ee7535069fc1581341b41bab9b72";
-      sha256 = "1m67cxb6p0zgq0xba63qb4vvy6z5d78alya0vnx5djfixygiij53";
-    };
-  }
-  {
-    goPackagePath = "github.com/bradfitz/slice";
-    fetch = {
-      type = "git";
-      url = "https://github.com/bradfitz/slice";
-      rev = "d9036e2120b5ddfa53f3ebccd618c4af275f47da";
-      sha256 = "189h48w3ppvx2kqyxq0s55kxv629lljjxbyqjnlrgg8fy6ya8wgy";
-    };
-  }
-  {
-    goPackagePath = "github.com/gobwas/glob";
-    fetch = {
-      type = "git";
-      url = "https://github.com/gobwas/glob";
-      rev = "51eb1ee00b6d931c66d229ceeb7c31b985563420";
-      sha256 = "090wzpwsjana1qas8ipwh1pj959gvc4b7vwybzi01f3bmd79jwlp";
-    };
-  }
-  {
-    goPackagePath = "github.com/mattn/go-runewidth";
-    fetch = {
-      type = "git";
-      url = "https://github.com/mattn/go-runewidth";
-      rev = "97311d9f7767e3d6f422ea06661bc2c7a19e8a5d";
-      sha256 = "0dxlrzn570xl7gb11hjy1v4p3gw3r41yvqhrffgw95ha3q9p50cg";
-    };
-  }
-  {
-    goPackagePath = "github.com/rgburke/goncurses";
-    fetch = {
-      type = "git";
-      url = "https://github.com/rgburke/goncurses";
-      rev = "9a788ac9d81e61c6a2ca6205ee8d72d738ed12b9";
-      sha256 = "0xqwxscdszbybriyzqmsd2zkzda9anckx56q8gksfy3gwj286gpb";
-    };
-  }
-  {
-    goPackagePath = "github.com/rjeczalik/notify";
-    fetch = {
-      type = "git";
-      url = "https://github.com/rjeczalik/notify";
-      rev = "27b537f07230b3f917421af6dcf044038dbe57e2";
-      sha256 = "05alsqjz2x8jzz2yp8r20zwglcg7y1ywq60zy6icj18qs3abmlp0";
-    };
-  }
-  {
-    goPackagePath = "github.com/tchap/go-patricia";
-    fetch = {
-      type = "git";
-      url = "https://github.com/tchap/go-patricia";
-      rev = "5ad6cdb7538b0097d5598c7e57f0a24072adf7dc";
-      sha256 = "0351x63zqympgfsnjl78cgvqhvipl3kfs1i15hfaw91hqin6dykr";
-    };
-  }
-  {
-    goPackagePath = "go4.org";
-    fetch = {
-      type = "git";
-      url = "https://github.com/camlistore/go4";
-      rev = "fba789b7e39ba524b9e60c45c37a50fae63a2a09";
-      sha256 = "01irxqy8na646b4zbw7v3zwy3yx9m7flhim5c3z4lzq5hiy2h75i";
-    };
-  }
-  {
-    goPackagePath = "golang.org/x/crypto";
-    fetch = {
-      type = "git";
-      url = "https://go.googlesource.com/crypto";
-      rev = "1875d0a70c90e57f11972aefd42276df65e895b9";
-      sha256 = "1kprrdzr4i4biqn7r9gfxzsmijya06i9838skprvincdb1pm0q2q";
-    };
-  }
-  {
-    goPackagePath = "golang.org/x/sys";
-    fetch = {
-      type = "git";
-      url = "https://go.googlesource.com/sys";
-      rev = "3dbebcf8efb6a5011a60c2b4591c1022a759af8a";
-      sha256 = "02pwjyimpm13km3fk0rg2l9p37w7qycdwp74piawwgcgh80qnww9";
-    };
-  }
-  {
-    goPackagePath = "gopkg.in/libgit2/git2go.v25";
-    fetch = {
-      type = "git";
-      url = "https://gopkg.in/libgit2/git2go.v25";
-      rev = "334260d743d713a55ff3c097ec6707f2bb39e9d5";
-      sha256 = "0hfya9z2pg29zbc0s92hj241rnbk7d90jzj34q0dp8b7akz6r1rc";
-    };
-  }
-]
diff --git a/pkgs/applications/version-management/git-and-tools/svn-all-fast-export/default.nix b/pkgs/applications/version-management/git-and-tools/svn-all-fast-export/default.nix
new file mode 100644
index 000000000000..fbafc5257d7b
--- /dev/null
+++ b/pkgs/applications/version-management/git-and-tools/svn-all-fast-export/default.nix
@@ -0,0 +1,43 @@
+{ stdenv, fetchFromGitHub, fetchpatch, qmake, qtbase, qttools, subversion, apr }:
+
+let
+  version = "1.0.11";
+in
+stdenv.mkDerivation {
+  name = "svn-all-fast-export-${version}";
+
+  src = fetchFromGitHub {
+    owner = "svn-all-fast-export";
+    repo = "svn2git";
+    rev = version;
+    sha256 = "0lhnw8f15j4wkpswhrjd7bp9xkhbk32zmszaxayzfhbdl0g7pzwj";
+  };
+
+  # https://github.com/svn-all-fast-export/svn2git/pull/40
+  patches = [
+    (fetchpatch {
+      name = "pr40.patch";
+      sha256 = "1qndhk5csf7kddk3giailx7r0cdipq46lj73nkcws43n4n93synk";
+      url = https://github.com/svn-all-fast-export/svn2git/pull/40.diff;
+    })
+  ];
+
+  nativeBuildInputs = [ qmake qttools ];
+  buildInputs = [ apr.dev subversion.dev qtbase ];
+
+  qmakeFlags = [
+    "VERSION=${version}"
+    "APR_INCLUDE=${apr.dev}/include/apr-1"
+    "SVN_INCLUDE=${subversion.dev}/include/subversion-1"
+  ];
+
+  installPhase = "make install INSTALL_ROOT=$out";
+
+  meta = with stdenv.lib; {
+    homepage = https://github.com/svn-all-fast-export/svn2git;
+    description = "A fast-import based converter for an svn repo to git repos";
+    license = licenses.gpl3;
+    platforms = platforms.all;
+    maintainers = [ maintainers.flokli ];
+  };
+}
diff --git a/pkgs/applications/version-management/git-and-tools/svn2git-kde/default.nix b/pkgs/applications/version-management/git-and-tools/svn2git-kde/default.nix
deleted file mode 100644
index e52fdb6375bf..000000000000
--- a/pkgs/applications/version-management/git-and-tools/svn2git-kde/default.nix
+++ /dev/null
@@ -1,28 +0,0 @@
-{ stdenv, fetchgit, qt4, qmake4Hook, subversion, apr }:
-
-stdenv.mkDerivation rec {
-  name = "svn2git-kde-1.0.5";
-
-  src = fetchgit {
-    url = http://git.gitorious.org/svn2git/svn2git.git;
-    rev = "149d6c6e14a1724c96999328683a9264fc508264";
-    sha256 = "0gjxhnraizlwyidn66rczwc01f6sfx4ndmsj86ssqml3p0d4sl6q";
-  };
-
-  NIX_CFLAGS_COMPILE = [ "-I${apr.dev}/include/apr-1" "-I${subversion.dev}/include/subversion-1" "-DVER=\"${src.rev}\"" ];
-
-  patchPhase = ''
-    sed -i 's|/bin/cat|cat|' ./src/repository.cpp
-  '';
-
-  installPhase = ''
-    mkdir -p $out/bin
-    cp svn-all-fast-export $out/bin
-  '';
-
-  buildInputs = [ subversion apr qt4 ];
-
-  nativeBuildInputs = [ qmake4Hook ];
-
-  meta.broken = true;
-}