summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/misc/cura/default.nix6
-rw-r--r--pkgs/applications/misc/curaengine/default.nix6
-rw-r--r--pkgs/applications/misc/josm/default.nix4
-rw-r--r--pkgs/applications/networking/browsers/chromium/browser.nix4
-rw-r--r--pkgs/applications/networking/browsers/chromium/upstream-info.nix18
-rw-r--r--pkgs/applications/networking/ids/bro/default.nix4
-rw-r--r--pkgs/applications/networking/instant-messengers/telegram/tdesktop/default.nix7
-rw-r--r--pkgs/applications/science/math/caffe/default.nix21
-rw-r--r--pkgs/applications/science/math/cbc/default.nix6
-rw-r--r--pkgs/applications/science/math/cntk/default.nix28
-rw-r--r--pkgs/applications/science/math/cntk/fix_std_bind.patch11
-rw-r--r--pkgs/applications/science/math/mxnet/default.nix13
-rw-r--r--pkgs/applications/virtualization/containerd/default.nix4
13 files changed, 76 insertions, 56 deletions
diff --git a/pkgs/applications/misc/cura/default.nix b/pkgs/applications/misc/cura/default.nix
index b9a160564a5d..edb10a0f6671 100644
--- a/pkgs/applications/misc/cura/default.nix
+++ b/pkgs/applications/misc/cura/default.nix
@@ -2,13 +2,13 @@
 
 mkDerivation rec {
   name = "cura-${version}";
-  version = "3.1.0";
+  version = "3.2.1";
 
   src = fetchFromGitHub {
     owner = "Ultimaker";
     repo = "Cura";
     rev = version;
-    sha256 = "1x732bzxdxnz1av8jlv5kzs08jpmsg6bz9i88jr63kw32d901xsm";
+    sha256 = "0yaya0ww92qjm7g31q85m5f95nwdapldjx1kdf1ar4yzwh4r15rp";
   };
 
   buildInputs = [ qtbase qtquickcontrols ];
@@ -28,7 +28,7 @@ mkDerivation rec {
 
   meta = with lib; {
     description = "3D printer / slicing GUI built on top of the Uranium framework";
-    homepage = "https://github.com/Ultimaker/Cura";
+    homepage = https://github.com/Ultimaker/Cura;
     license = licenses.agpl3;
     platforms = platforms.linux;
     maintainers = with maintainers; [ abbradar ];
diff --git a/pkgs/applications/misc/curaengine/default.nix b/pkgs/applications/misc/curaengine/default.nix
index 575889ad2c6f..c3a19e6551a2 100644
--- a/pkgs/applications/misc/curaengine/default.nix
+++ b/pkgs/applications/misc/curaengine/default.nix
@@ -2,13 +2,13 @@
 
 stdenv.mkDerivation rec {
   name = "curaengine-${version}";
-  version = "3.0.3";
+  version = "3.2.1";
 
   src = fetchFromGitHub {
     owner = "Ultimaker";
     repo = "CuraEngine";
     rev = version;
-    sha256 = "0x1ss3hppw6062rmmxh0dpnm5cg6r2mp01k0nxyw5riiljj59ydy";
+    sha256 = "1yqpp6qhixzni3ik11vbk5kcdrhlz2j4ylzmh8f6c86r4d73a0cp";
   };
 
   nativeBuildInputs = [ cmake ];
@@ -18,7 +18,7 @@ stdenv.mkDerivation rec {
 
   meta = with stdenv.lib; {
     description = "A powerful, fast and robust engine for processing 3D models into 3D printing instruction";
-    homepage = "https://github.com/Ultimaker/CuraEngine";
+    homepage = https://github.com/Ultimaker/CuraEngine;
     license = licenses.agpl3;
     platforms = platforms.linux;
     maintainers = with maintainers; [ abbradar ];
diff --git a/pkgs/applications/misc/josm/default.nix b/pkgs/applications/misc/josm/default.nix
index b908941d2bc9..aec6dc2f58c8 100644
--- a/pkgs/applications/misc/josm/default.nix
+++ b/pkgs/applications/misc/josm/default.nix
@@ -2,11 +2,11 @@
 
 stdenv.mkDerivation rec {
   name = "josm-${version}";
-  version = "13265";
+  version = "13367";
 
   src = fetchurl {
     url = "https://josm.openstreetmap.de/download/josm-snapshot-${version}.jar";
-    sha256 = "0mmpxmf17lw1j1m1gfz2jrm3qj2416zgbwgcy7xbvn6qcd8k7dr5";
+    sha256 = "1yf7cx8159njxid9qa0id7zfkr7dn83rrkgxp9kzkjn25aqji4cf";
   };
 
   buildInputs = [ jre8 makeWrapper ];
diff --git a/pkgs/applications/networking/browsers/chromium/browser.nix b/pkgs/applications/networking/browsers/chromium/browser.nix
index e35d894e0e7e..404f25969097 100644
--- a/pkgs/applications/networking/browsers/chromium/browser.nix
+++ b/pkgs/applications/networking/browsers/chromium/browser.nix
@@ -5,7 +5,9 @@ with stdenv.lib;
 mkChromiumDerivation (base: rec {
   name = "chromium-browser";
   packageName = "chromium";
-  buildTargets = [ "mksnapshot" "chrome_sandbox" "chrome" ];
+  ## mojo_platform_bindings is built ahead of chrome, because of spurious
+  ## build errors, see https://github.com/NixOS/nixpkgs/issues/35296
+  buildTargets = [ "mksnapshot" "mojo_platform_bindings" "chrome_sandbox" "chrome" ];
 
   outputs = ["out" "sandbox"];
 
diff --git a/pkgs/applications/networking/browsers/chromium/upstream-info.nix b/pkgs/applications/networking/browsers/chromium/upstream-info.nix
index bc9105acc77f..bca9e1c9a1c1 100644
--- a/pkgs/applications/networking/browsers/chromium/upstream-info.nix
+++ b/pkgs/applications/networking/browsers/chromium/upstream-info.nix
@@ -1,18 +1,18 @@
 # This file is autogenerated from update.sh in the same directory.
 {
   beta = {
-    sha256 = "1ggj1a7v2n4v34kb8gx2hcswlayryr9g62zqlry26bwmvz6qzsx9";
-    sha256bin64 = "1ah8088d8p674dj5bijk5maapmiq9iap1w2i81dl0hhpyqxx3h3i";
-    version = "65.0.3325.73";
+    sha256 = "1kdv6r3cmy7lqynnk4ylkn81x91wkv2k3hqh41sb50h65s7h9b3y";
+    sha256bin64 = "18bralcc4frapglcfa5az3z8i74calrblf4zzavisvpkmnil7ypa";
+    version = "65.0.3325.88";
   };
   dev = {
-    sha256 = "13klppyl6rbkd3ffp8y8d95l4mc72gmj45y34wynyfap6b4z1lmh";
-    sha256bin64 = "0w1ipy858p9lbpcrjhs44kncgw7c5qv1929h0w65ybgsggjqh0gz";
-    version = "66.0.3343.3";
+    sha256 = "1ykg5c3bayv6pwz74dglxcmbsalz6p04c3r0y15xkw2iyv5jjcam";
+    sha256bin64 = "1phw755ra3pckvhapm26amr6b3652k8f7sxanjyq118zkpga21w2";
+    version = "66.0.3350.0";
   };
   stable = {
-    sha256 = "0mf4qjmrjnxs7mx9c5pymavmib7l2a2kxiy0kqk3mma1y90qnc7k";
-    sha256bin64 = "0idij274g53lzvgz9h5xxi8l841vvvr78hp25ndbmpv4a2p1d83b";
-    version = "64.0.3282.167";
+    sha256 = "0q0q1whspmzyln04gxhgl3jd2vrgb4imh8r9qw6c06i3b63j3l2z";
+    sha256bin64 = "1sq8mmdw32n00swm4q9q5q3vw6q5sp8yiaxag4rbzvxkfnr3vi4g";
+    version = "64.0.3282.186";
   };
 }
diff --git a/pkgs/applications/networking/ids/bro/default.nix b/pkgs/applications/networking/ids/bro/default.nix
index 7ae3e8c73611..577252bc69e0 100644
--- a/pkgs/applications/networking/ids/bro/default.nix
+++ b/pkgs/applications/networking/ids/bro/default.nix
@@ -2,11 +2,11 @@
 , geoip, gperftools, python, swig }:
 
 stdenv.mkDerivation rec {
-  name = "bro-2.5.2";
+  name = "bro-2.5.3";
 
   src = fetchurl {
     url = "http://www.bro.org/downloads/${name}.tar.gz";
-    sha256 = "0w5rynw278nl6pdl5s7gsmxjwkl6z1g5pcm6byg930k26yyb35db";
+    sha256 = "09b227j1c0ggihbhbyphd7lnh26mpz07z1s0h148dg6fwqagm13k";
   };
 
   nativeBuildInputs = [ cmake flex bison file ];
diff --git a/pkgs/applications/networking/instant-messengers/telegram/tdesktop/default.nix b/pkgs/applications/networking/instant-messengers/telegram/tdesktop/default.nix
index 34f0d16a7b43..67b116274a2d 100644
--- a/pkgs/applications/networking/instant-messengers/telegram/tdesktop/default.nix
+++ b/pkgs/applications/networking/instant-messengers/telegram/tdesktop/default.nix
@@ -1,6 +1,6 @@
 { mkDerivation, lib, fetchgit, fetchpatch
 , pkgconfig, gyp, cmake, makeWrapper
-, qtbase, qtimageformats, gtk3, libappindicator-gtk3
+, qtbase, qtimageformats, gtk3, libappindicator-gtk3, libnotify
 , dee, ffmpeg, openalSoft, minizip, libopus, alsaLib, libpulseaudio, range-v3
 }:
 
@@ -31,6 +31,11 @@ mkDerivation rec {
     })
   ];
 
+  postPatch = ''
+    substituteInPlace Telegram/SourceFiles/platform/linux/linux_libs.cpp --replace '"appindicator"' '"${libappindicator-gtk3}/lib/libappindicator3.so"'
+    substituteInPlace Telegram/SourceFiles/platform/linux/linux_libnotify.cpp --replace '"notify"' '"${libnotify}/lib/libnotify.so"'
+  '';
+
   nativeBuildInputs = [ pkgconfig gyp cmake makeWrapper ];
 
   buildInputs = [
diff --git a/pkgs/applications/science/math/caffe/default.nix b/pkgs/applications/science/math/caffe/default.nix
index 8dc3e3ce43dc..d7357c5048d5 100644
--- a/pkgs/applications/science/math/caffe/default.nix
+++ b/pkgs/applications/science/math/caffe/default.nix
@@ -7,17 +7,19 @@
 , hdf5-cpp
 , leveldb
 , lmdb
-, opencv
+, opencv3
 , protobuf
 , snappy
-, atlas
 , doxygen
+, openblas
 , cudaSupport ? true, cudatoolkit
 , cudnnSupport ? false, cudnn ? null
+, ncclSupport ? false, nccl ? null
 , pythonSupport ? false, python ? null, numpy ? null
 }:
 
 assert cudnnSupport -> cudaSupport;
+assert ncclSupport -> cudaSupport;
 assert pythonSupport -> (python != null && numpy != null);
 
 stdenv.mkDerivation rec {
@@ -35,14 +37,19 @@ stdenv.mkDerivation rec {
 
   nativeBuildInputs = [ cmake doxygen ];
 
-  cmakeFlags = [
-    "-DCUDA_ARCH_NAME=All"
-    (if pythonSupport then "-Dpython_version=${python.version}" else "-DBUILD_python=OFF")
-  ] ++ lib.optional (!cudaSupport) "-DCPU_ONLY=ON";
+  cmakeFlags =
+    [ (if pythonSupport then "-Dpython_version=${python.version}" else "-DBUILD_python=OFF")
+      "-DBLAS=open"
+    ] ++ (if cudaSupport then [
+           "-DCUDA_ARCH_NAME=All"
+           "-DCUDA_HOST_COMPILER=${cudatoolkit.cc}/bin/cc"
+         ] else [ "-DCPU_ONLY=ON" ])
+      ++ lib.optional ncclSupport "-DUSE_NCCL=ON";
 
-  buildInputs = [ boost google-gflags glog protobuf hdf5-cpp lmdb leveldb snappy opencv atlas ]
+  buildInputs = [ boost google-gflags glog protobuf hdf5-cpp lmdb leveldb snappy opencv3 openblas ]
                 ++ lib.optional cudaSupport cudatoolkit
                 ++ lib.optional cudnnSupport cudnn
+                ++ lib.optional ncclSupport nccl
                 ++ lib.optionals pythonSupport [ python numpy ];
 
   propagatedBuildInputs = lib.optional pythonSupport python.pkgs.protobuf;
diff --git a/pkgs/applications/science/math/cbc/default.nix b/pkgs/applications/science/math/cbc/default.nix
index 7643c912db4b..6de77d81be6f 100644
--- a/pkgs/applications/science/math/cbc/default.nix
+++ b/pkgs/applications/science/math/cbc/default.nix
@@ -1,11 +1,11 @@
 { lib, stdenv, fetchurl, zlib, bzip2 }:
 
 stdenv.mkDerivation {
-  name = "cbc-2.9.5";
+  name = "cbc-2.9.9";
 
   src = fetchurl {
-    url = "http://www.coin-or.org/download/source/Cbc/Cbc-2.9.5.tgz";
-    sha256 = "0kmsg9qpajh5jhnql04m6akpdjzlppxfz99q320vw5bkzgl3i18w";
+    url = "http://www.coin-or.org/download/source/Cbc/Cbc-2.9.9.tgz";
+    sha256 = "1w8axdzm05xf5y13c31w7rc5z6ywxqxiwafnxcq3p195kgj0915a";
   };
 
   configureFlags = "-C";
diff --git a/pkgs/applications/science/math/cntk/default.nix b/pkgs/applications/science/math/cntk/default.nix
index bef695fc650a..07740f4c8aea 100644
--- a/pkgs/applications/science/math/cntk/default.nix
+++ b/pkgs/applications/science/math/cntk/default.nix
@@ -12,28 +12,22 @@ let
   cub = fetchFromGitHub {
     owner = "NVlabs";
     repo = "cub";
-    rev = "1.4.1";
-    sha256 = "1lcdwblz03c0yq1lxndg566kg14b5qm14x5qixjbmz6wq85kgmqc";
+    rev = "1.7.4";
+    sha256 = "0ksd5n1lxqhm5l5cd2lps4cszhjkf6gmzahaycs7nxb06qci8c66";
   };
 
 in stdenv.mkDerivation rec {
   name = "CNTK-${version}";
-  version = "2.2";
+  version = "2.4";
 
   # Submodules
   src = fetchgit {
     url = "https://github.com/Microsoft/CNTK";
     rev = "v${version}";
-    sha256 = "0q4knrwiyphb2fbqf9jzqvkz2jzj6jmbmang3lavdvsh7z0n8zz9";
+    sha256 = "0m28wb0ljixcpi14g3gcfiraimh487yxqhd9yrglgyvjb69x597y";
   };
 
-  patches = [
-    # Fix "'exp' was not declared"
-    (fetchpatch {
-      url = "https://github.com/imriss/CNTK/commit/ef1cca6df95cc507deb8471df2c0dd8cbfeef23b.patch";
-      sha256 = "0z7xyrxwric0c4h7rfs05f544mcq6d10wgs0vvfcyd2pcf410hy7";
-    })
-  ];
+  patches = [ ./fix_std_bind.patch ];
 
   nativeBuildInputs = [ cmake ];
 
@@ -48,8 +42,10 @@ in stdenv.mkDerivation rec {
     "--with-boost=${boost.dev}"
     "--with-protobuf=${protobuf}"
     "--with-mpi=${openmpi}"
+    "--cuda=${if cudaSupport then "yes" else "no"}"
+    # FIXME
+    "--asgd=no"
   ] ++ lib.optionals cudaSupport [
-    "--cuda=yes"
     "--with-cuda=${cudatoolkit}"
     "--with-gdk-include=${cudatoolkit}/include"
     "--with-gdk-nvml-lib=${nvidia_x11}/lib"
@@ -85,16 +81,12 @@ in stdenv.mkDerivation rec {
     cp bin/cntk $out/bin
   '';
 
-  hardeningDisable = [ "format" ];
-
-  # on 2.2: fatal error: tensorboard/tensorboard.pb.h: No such file or directory
-  enableParallelBuilding = false;
+  enableParallelBuilding = true;
 
   meta = with lib; {
-    homepage = "https://github.com/Microsoft/CNTK";
+    homepage = https://github.com/Microsoft/CNTK;
     description = "An open source deep-learning toolkit";
     license = if onebitSGDSupport then licenses.unfreeRedistributable else licenses.mit;
     maintainers = with maintainers; [ abbradar ];
-    broken = true; # Never succeeded to build.
   };
 }
diff --git a/pkgs/applications/science/math/cntk/fix_std_bind.patch b/pkgs/applications/science/math/cntk/fix_std_bind.patch
new file mode 100644
index 000000000000..df97a0c66669
--- /dev/null
+++ b/pkgs/applications/science/math/cntk/fix_std_bind.patch
@@ -0,0 +1,11 @@
+diff -ru3 CNTK-old/Source/CNTKv2LibraryDll/EvaluatorWrapper.h CNTK-new/Source/CNTKv2LibraryDll/EvaluatorWrapper.h
+--- CNTK-old/Source/CNTKv2LibraryDll/EvaluatorWrapper.h	1970-01-01 03:00:01.000000000 +0300
++++ CNTK-new/Source/CNTKv2LibraryDll/EvaluatorWrapper.h	2018-02-25 18:16:16.330269647 +0300
+@@ -9,6 +9,7 @@
+ #include <boost/noncopyable.hpp>
+ #include <memory>
+ #include <vector>
++#include <functional>
+ 
+ #include "CNTKLibrary.h"
+ #include "CNTKLibraryC.h"
diff --git a/pkgs/applications/science/math/mxnet/default.nix b/pkgs/applications/science/math/mxnet/default.nix
index d2f3d0c5f337..ce9c214b3f0c 100644
--- a/pkgs/applications/science/math/mxnet/default.nix
+++ b/pkgs/applications/science/math/mxnet/default.nix
@@ -8,7 +8,7 @@ assert cudnnSupport -> cudaSupport;
 
 stdenv.mkDerivation rec {
   name = "mxnet-${version}";
-  version = "0.11.0";
+  version = "1.1.0";
 
   # Submodules needed
   src = fetchgit {
@@ -23,9 +23,12 @@ stdenv.mkDerivation rec {
               ++ lib.optionals cudaSupport [ cudatoolkit nvidia_x11 ]
               ++ lib.optional cudnnSupport cudnn;
 
-  cmakeFlags = [
-    (if cudaSupport then "-DCUDA_ARCH_NAME=All" else "-DUSE_CUDA=OFF")
-  ] ++ lib.optional (!cudnnSupport) "-DUSE_CUDNN=OFF";
+  cmakeFlags =
+    (if cudaSupport then [
+      "-DCUDA_ARCH_NAME=All"
+      "-DCUDA_HOST_COMPILER=${cudatoolkit.cc}/bin/cc"
+    ] else [ "-DUSE_CUDA=OFF" ])
+    ++ lib.optional (!cudnnSupport) "-DUSE_CUDNN=OFF";
 
   installPhase = ''
     install -Dm755 libmxnet.so $out/lib/libmxnet.so
@@ -36,7 +39,7 @@ stdenv.mkDerivation rec {
 
   meta = with stdenv.lib; {
     description = "Lightweight, Portable, Flexible Distributed/Mobile Deep Learning with Dynamic, Mutation-aware Dataflow Dep Scheduler";
-    homepage = "https://mxnet.incubator.apache.org/";
+    homepage = https://mxnet.incubator.apache.org/;
     maintainers = with maintainers; [ abbradar ];
     license = licenses.asl20;
     platforms = platforms.linux;
diff --git a/pkgs/applications/virtualization/containerd/default.nix b/pkgs/applications/virtualization/containerd/default.nix
index 86b6535e5396..8f456a2a49a8 100644
--- a/pkgs/applications/virtualization/containerd/default.nix
+++ b/pkgs/applications/virtualization/containerd/default.nix
@@ -5,13 +5,13 @@ with lib;
 
 stdenv.mkDerivation rec {
   name = "containerd-${version}";
-  version = "1.0.1";
+  version = "1.0.2";
 
   src = fetchFromGitHub {
     owner = "containerd";
     repo = "containerd";
     rev = "v${version}";
-    sha256 = "0kfafqi66yp4qy738pl11f050hfrx9m4kc670qpx7fmf9ii7q6p2";
+    sha256 = "1x6mmk69jksh4m9rjd8qwpp0qc7jmimpkq9pw9237p0v63p9yci0";
   };
 
   hardeningDisable = [ "fortify" ];