summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/editors/emacs-21/builder.sh12
-rw-r--r--pkgs/applications/editors/emacs-21/crt.patch41
-rw-r--r--pkgs/applications/editors/emacs-21/default.nix28
-rw-r--r--pkgs/applications/editors/emacs-22/builder.sh27
-rw-r--r--pkgs/applications/editors/emacs-22/default.nix48
-rw-r--r--pkgs/applications/misc/qgis/1.0.1-2.nix4
-rw-r--r--pkgs/applications/networking/instant-messengers/carrier/2.5.0.nix2
-rw-r--r--pkgs/applications/networking/instant-messengers/psi/default.nix (renamed from pkgs/applications/networking/instant-messengers/psi/0.12.1.nix)15
-rw-r--r--pkgs/applications/version-management/codeville/0.8.0.nix2
-rw-r--r--pkgs/applications/version-management/monotone-viz/mtn-head.nix2
-rw-r--r--pkgs/applications/version-management/viewmtn/0.10.nix2
-rw-r--r--pkgs/applications/virtualization/qemu/linux-img/0.2.nix4
12 files changed, 18 insertions, 169 deletions
diff --git a/pkgs/applications/editors/emacs-21/builder.sh b/pkgs/applications/editors/emacs-21/builder.sh
deleted file mode 100644
index acd98aefd048..000000000000
--- a/pkgs/applications/editors/emacs-21/builder.sh
+++ /dev/null
@@ -1,12 +0,0 @@
-source $stdenv/setup
-
-myglibc=`cat ${NIX_GCC}/nix-support/orig-libc`
-echo "glibc: $myglibc" 
-
-postConfigure() {
-  cp $myglibc/lib/crt1.o src
-  cp $myglibc/lib/crti.o src
-  cp $myglibc/lib/crtn.o src
-}
-
-genericBuild
diff --git a/pkgs/applications/editors/emacs-21/crt.patch b/pkgs/applications/editors/emacs-21/crt.patch
deleted file mode 100644
index 93f17643a1af..000000000000
--- a/pkgs/applications/editors/emacs-21/crt.patch
+++ /dev/null
@@ -1,41 +0,0 @@
-Only in emacs-21.3: configure.in~
-Only in emacs-21.3: patchfile
-Only in emacs-21.3/src: Makefile.in~
-diff -rc emacs-orig/src/s/gnu-linux.h emacs-21.3/src/s/gnu-linux.h
-*** emacs-orig/src/s/gnu-linux.h	2001-09-28 17:50:04.000000000 +0200
---- emacs-21.3/src/s/gnu-linux.h	2004-10-06 13:13:19.000000000 +0200
-***************
-*** 173,179 ****
-  /* GNU/Linux usually has crt0.o in a non-standard place */
-  #define START_FILES pre-crt0.o /usr/lib/crt0.o
-  #else
-! #define START_FILES pre-crt0.o /usr/lib/crt1.o /usr/lib/crti.o
-  #endif
-  
-  #ifdef __ELF__
---- 173,179 ----
-  /* GNU/Linux usually has crt0.o in a non-standard place */
-  #define START_FILES pre-crt0.o /usr/lib/crt0.o
-  #else
-! #define START_FILES pre-crt0.o crt1.o crti.o
-  #endif
-  
-  #ifdef __ELF__
-***************
-*** 225,231 ****
-  #else
-  #undef LIB_GCC
-  #define LIB_GCC
-! #define LIB_STANDARD -lgcc -lc -lgcc /usr/lib/crtn.o
-  #endif
-  
-  /* Don't use -g in test compiles in configure.
---- 225,231 ----
-  #else
-  #undef LIB_GCC
-  #define LIB_GCC
-! #define LIB_STANDARD -lgcc -lc -lgcc crtn.o
-  #endif
-  
-  /* Don't use -g in test compiles in configure.
-Only in emacs-21.3/src/s: gnu-linux.h~
diff --git a/pkgs/applications/editors/emacs-21/default.nix b/pkgs/applications/editors/emacs-21/default.nix
deleted file mode 100644
index 9fc16594e26f..000000000000
--- a/pkgs/applications/editors/emacs-21/default.nix
+++ /dev/null
@@ -1,28 +0,0 @@
-{ xawSupport ? true
-, xpmSupport ? true
-, xaw3dSupport ? false
-, stdenv, fetchurl, ncurses, x11, libXaw ? null, libXpm ? null, Xaw3d ? null
-}:
-
-assert xawSupport && !xaw3dSupport -> libXaw != null;
-assert xawSupport && xaw3dSupport -> Xaw3d != null;
-assert xpmSupport -> libXpm != null;
-
-stdenv.mkDerivation {
-  name = "emacs-21.4a";
-  builder = ./builder.sh;
-  src = fetchurl {
-    url = http://nixos.org/tarballs/emacs-21.4a.tar.gz;
-    md5 = "8f9d97cbd126121bd5d97e5e31168a87";
-  };
-  patches = [./crt.patch];
-  buildInputs = [
-    ncurses x11
-    (if xawSupport then if xaw3dSupport then Xaw3d else libXaw else null)
-    (if xpmSupport then libXpm else null)
-  ];
-
-  meta = {
-    description = "All Hail Emacs, the ultimate editor";
-  };
-}
diff --git a/pkgs/applications/editors/emacs-22/builder.sh b/pkgs/applications/editors/emacs-22/builder.sh
deleted file mode 100644
index 7a82f6552efc..000000000000
--- a/pkgs/applications/editors/emacs-22/builder.sh
+++ /dev/null
@@ -1,27 +0,0 @@
-source $stdenv/setup
-
-preConfigure() {
-    libc=$(cat ${NIX_GCC}/nix-support/orig-libc)
-    echo "libc: $libc"
-
-    case "${system}" in
-	x86_64-*)	glibclibdir=lib64 ;;
-	*)		glibclibdir=lib ;;
-    esac
-
-    for i in src/s/*.h src/m/*.h; do
-        substituteInPlace $i \
-            --replace /usr/${glibclibdir}/crt1.o $libc/${glibclibdir}/crt1.o \
-            --replace /usr/${glibclibdir}/crti.o $libc/${glibclibdir}/crti.o \
-            --replace /usr/${glibclibdir}/crtn.o $libc/${glibclibdir}/crtn.o \
-            --replace /usr/lib/crt1.o $libc/${glibclibdir}/crt1.o \
-            --replace /usr/lib/crti.o $libc/${glibclibdir}/crti.o \
-            --replace /usr/lib/crtn.o $libc/${glibclibdir}/crtn.o
-    done
-
-    for i in Makefile.in ./src/Makefile.in ./lib-src/Makefile.in ./leim/Makefile.in; do
-        substituteInPlace $i --replace /bin/pwd pwd
-    done
-}
-
-genericBuild
diff --git a/pkgs/applications/editors/emacs-22/default.nix b/pkgs/applications/editors/emacs-22/default.nix
deleted file mode 100644
index da3c4babbf6b..000000000000
--- a/pkgs/applications/editors/emacs-22/default.nix
+++ /dev/null
@@ -1,48 +0,0 @@
-{ xawSupport ? true
-, xpmSupport ? true
-, xaw3dSupport ? false
-, gtkGUI ? false
-, stdenv, fetchurl, x11, libXaw ? null, libXpm ? null, Xaw3d ? null
-, pkgconfig ? null, gtk ? null
-, ncurses
-}:
-
-assert xawSupport && !xaw3dSupport -> libXaw != null;
-assert xawSupport && xaw3dSupport -> Xaw3d != null;
-assert xpmSupport -> libXpm != null;
-assert gtkGUI -> pkgconfig != null && gtk != null;
-
-stdenv.mkDerivation rec {
-  name = "emacs-22.3";
-
-  builder = ./builder.sh;
-  
-  src = fetchurl {
-    url = "mirror://gnu/emacs/${name}.tar.gz";
-    sha256 = "05hd89bchcpwzcx5la0alcp0wb7xywvnf98dxrshrqlfvccvgnbv";
-  };
-  
-  buildInputs = [ncurses x11]
-    ++ stdenv.lib.optional xawSupport (if xaw3dSupport then Xaw3d else libXaw)
-    ++ stdenv.lib.optional xpmSupport libXpm
-    ++ stdenv.lib.optionals gtkGUI [pkgconfig gtk];
-  
-  configureFlags =
-    stdenv.lib.optional gtkGUI "--with-x-toolkit=gtk";
-
-  meta = {
-    description = "GNU Emacs, *the* text editor";
-
-    longDescription = ''
-      GNU Emacs is an extensible, customizable text editor—and more.
-      At its core is an interpreter for Emacs Lisp, a dialect of the
-      Lisp programming language with extensions to support text
-      editing.
-    '';
-
-    homepage = http://www.gnu.org/software/emacs/;
-    license = "GPLv3+";
-
-    platforms = stdenv.lib.platforms.linux;  # GTK & co. are needed.
-  };
-}
diff --git a/pkgs/applications/misc/qgis/1.0.1-2.nix b/pkgs/applications/misc/qgis/1.0.1-2.nix
index 142e3b65013c..af28a381fba0 100644
--- a/pkgs/applications/misc/qgis/1.0.1-2.nix
+++ b/pkgs/applications/misc/qgis/1.0.1-2.nix
@@ -12,12 +12,12 @@ composableDerivation.composableDerivation {} {
                   "-DWITH_INTERNAL_SQLITE3=TRUE"
                 ];
 
-  name = "qgis-${version}";
+  name = "qgis-1.0.1-2";
 
   # src = args.fetchsvn { url=https://svn.qgis.org/repos/qgis/trunk/qgis;
   #                md5="ac0560e0a2d4e6258c8639f1e9b56df3"; rev="7704"; };
   src = fetchurl {
-    url = "http://download.osgeo.org/qgis/src/qgis_${version}.tar.gz";
+    url = "http://download.osgeo.org/qgis/src/qgis_1.0.1-2.tar.gz";
     sha256 = "07yyic9sn1pz20wjk7k560jwqz6b19rhf2gawybz38xq1f8rjwd4";
   };
 
diff --git a/pkgs/applications/networking/instant-messengers/carrier/2.5.0.nix b/pkgs/applications/networking/instant-messengers/carrier/2.5.0.nix
index 257d3d09f71b..0428ccdc7f32 100644
--- a/pkgs/applications/networking/instant-messengers/carrier/2.5.0.nix
+++ b/pkgs/applications/networking/instant-messengers/carrier/2.5.0.nix
@@ -39,7 +39,7 @@ rec {
     ++ (lib.optional externalPurple2 "postInstall")
   ;
       
-  name = "carrier-" + version;
+  name = "carrier-2.5.0";
   meta = {
     description = "Carrier - PidginIM GUI fork with user-friendly development model";
     homepage = http://funpidgin.sf.net; 
diff --git a/pkgs/applications/networking/instant-messengers/psi/0.12.1.nix b/pkgs/applications/networking/instant-messengers/psi/default.nix
index 110189598f6c..0db1af883cb8 100644
--- a/pkgs/applications/networking/instant-messengers/psi/0.12.1.nix
+++ b/pkgs/applications/networking/instant-messengers/psi/default.nix
@@ -1,19 +1,24 @@
-args : with args;
+{ stdenv, fetchurl, aspell, qt4, zlib, sox, libX11, xproto, libSM, libICE, qca2 }:
+
 stdenv.mkDerivation rec {
+  name = "psi-0.12.1";
+  
   src = fetchurl {
-    url = mirror://sourceforge/psi/psi-0.12.1.tar.bz2;
+    url = "mirror://sourceforge/psi/${name}.tar.bz2";
     sha256 = "0zi71fcia9amcasa6zrvfyghdpqa821iv2rkj53bq5dyvfm2y0m8";
   };
 
   buildInputs = [aspell qt4 zlib sox libX11 xproto libSM libICE qca2];
 
   NIX_CFLAGS_COMPILE="-I${qca2}/include/QtCrypto";
+  
   NIX_LDFLAGS="-lqca";
 
-  configureFlags = [ " --with-zlib-inc=${zlib}/include "
-    " --disable-bundled-qca" ];
+  configureFlags =
+    [ " --with-zlib-inc=${zlib}/include "
+      " --disable-bundled-qca"
+    ];
 
-  name = "psi-" + version;
   meta = {
     description = "Psi, an XMPP (Jabber) client";
   };
diff --git a/pkgs/applications/version-management/codeville/0.8.0.nix b/pkgs/applications/version-management/codeville/0.8.0.nix
index 57552bac2fca..d72f753a26e0 100644
--- a/pkgs/applications/version-management/codeville/0.8.0.nix
+++ b/pkgs/applications/version-management/codeville/0.8.0.nix
@@ -16,7 +16,7 @@ rec {
   /* doConfigure should be specified separately */
   phaseNames = ["installPythonPackage" (makeManyWrappers ''$out/bin/*'' ''--prefix PYTHONPATH : $(toPythonPath $out)'')];
       
-  name = "codeville-" + version;
+  name = "codeville-0.8.0";
   meta = {
     description = "Codeville - RCS with powerful merge.";
   };
diff --git a/pkgs/applications/version-management/monotone-viz/mtn-head.nix b/pkgs/applications/version-management/monotone-viz/mtn-head.nix
index 6693795edd90..eb5228e09fdb 100644
--- a/pkgs/applications/version-management/monotone-viz/mtn-head.nix
+++ b/pkgs/applications/version-management/monotone-viz/mtn-head.nix
@@ -20,7 +20,7 @@ rec {
     autoconf -I .
   '') ["minInit" "addInputs" "doUnpack"];
       
-  name = "monotone-viz-" + version;
+  name = "monotone-viz-mtn-head";
   meta = {
     description = "Monotone commit tree visualizer";
     maintainers = [args.lib.maintainers.raskin];
diff --git a/pkgs/applications/version-management/viewmtn/0.10.nix b/pkgs/applications/version-management/viewmtn/0.10.nix
index 08351ffa91dc..169bd407b7d7 100644
--- a/pkgs/applications/version-management/viewmtn/0.10.nix
+++ b/pkgs/applications/version-management/viewmtn/0.10.nix
@@ -38,7 +38,7 @@ rec {
     ln -s $fullOut/static $out/share/viewmtn/
   '') ["minInit" "defEnsureDir" "addInputs" "doUnpack"];
 
-  name = "viewmtn-" + version;
+  name = "viewmtn-0.10";
   meta = {
     description = "Monotone web interface";
   };
diff --git a/pkgs/applications/virtualization/qemu/linux-img/0.2.nix b/pkgs/applications/virtualization/qemu/linux-img/0.2.nix
index 0d5e94ded959..748f67c7448e 100644
--- a/pkgs/applications/virtualization/qemu/linux-img/0.2.nix
+++ b/pkgs/applications/virtualization/qemu/linux-img/0.2.nix
@@ -13,11 +13,11 @@ args : with args;
 let 
 doCopy = fullDepEntry ("
   ensureDir \$out/share/qemu-images
-  cp linux-${version}.img  \$out/share/qemu-images/
+  cp linux-0.2.img \$out/share/qemu-images/
 ") [minInit doUnpack defEnsureDir];
 in
 stdenv.mkDerivation rec {
-	name = "QEmu-Linux-Image-"+version;
+	name = "QEmu-Linux-Image-0.2";
 	builder = writeScript (name + "-builder")
 		(textClosure localDefs [doCopy doForceShare doPropagate]);
 	meta = {