summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/misc/buku/default.nix5
1 files changed, 3 insertions, 2 deletions
diff --git a/pkgs/applications/misc/buku/default.nix b/pkgs/applications/misc/buku/default.nix
index fea813021d25..ea3ca107d24d 100644
--- a/pkgs/applications/misc/buku/default.nix
+++ b/pkgs/applications/misc/buku/default.nix
@@ -1,7 +1,7 @@
 { stdenv, pythonPackages, fetchFromGitHub }:
 
 with pythonPackages; buildPythonApplication rec {
-  version = "3.0";
+  version = "3.0"; # When updating to 3.1, make sure to remove the marked line in preCheck
   name = "buku-${version}";
 
   src = fetchFromGitHub {
@@ -29,7 +29,8 @@ with pythonPackages; buildPythonApplication rec {
     # Fixes two tests for wrong encoding
     export PYTHONIOENCODING=utf-8
 
-    # Should be upstream, see https://github.com/jarun/Buku/pull/167
+    ### Remove this for 3.1 ###
+    # See https://github.com/jarun/Buku/pull/167 (merged)
     substituteInPlace setup.py \
       --replace "hypothesis==3.7.0" "hypothesis>=3.7.0"