summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/editors/manuskript/default.nix22
1 files changed, 20 insertions, 2 deletions
diff --git a/pkgs/applications/editors/manuskript/default.nix b/pkgs/applications/editors/manuskript/default.nix
index 93813152a164..fc27e4a00f7e 100644
--- a/pkgs/applications/editors/manuskript/default.nix
+++ b/pkgs/applications/editors/manuskript/default.nix
@@ -17,11 +17,17 @@ python3Packages.buildPythonApplication rec {
     zlib
   ];
 
+  patchPhase = ''
+    substituteInPlace manuskript/ui/welcome.py \
+      --replace sample-projects $out/share/${name}/sample-projects
+   '';
+
   buildPhase = '''';
 
   installPhase = ''
-    mkdir -p $out
-    cp -av * $out/
+    mkdir -p $out/share/${name}
+    cp -av  bin/ i18n/ libs/ manuskript/ resources/ icons/ $out
+    cp -r sample-projects/ $out/share/${name}
   '';
 
   doCheck = false;
@@ -29,6 +35,18 @@ python3Packages.buildPythonApplication rec {
   meta = {
     description = "A open-source tool for writers";
     homepage = http://www.theologeek.ch/manuskript;
+    longDescription = ''
+    Manuskript is a tool for those writer who like to organize and
+    plan everything before writing.  The snowflake method can help you
+    grow your idea into a book, by leading you step by step and asking
+    you questions to go deeper. While writing, keep track of notes
+    about every characters, plot, event, place in your story.
+
+    Develop complex characters and keep track of all useful infos.
+    Create intricate plots, linked to your characters, and use them to
+    outline your story. Organize your ideas about the world your
+    characters live in.
+    '';
     license = stdenv.lib.licenses.gpl3;
     maintainers = [ stdenv.lib.maintainers.steveej ];
     platforms = stdenv.lib.platforms.linux;