summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/misc/synergy/default.nix2
-rw-r--r--pkgs/applications/misc/xchm/default.nix6
-rw-r--r--pkgs/applications/networking/browsers/chromium/default.nix6
-rw-r--r--pkgs/applications/networking/browsers/icecat-3/default.nix4
-rw-r--r--pkgs/applications/office/ledger/default.nix46
-rw-r--r--pkgs/applications/version-management/monotone-viz/mtn-head.nix2
-rw-r--r--pkgs/applications/virtualization/qemu/0.11.0.nix18
7 files changed, 74 insertions, 10 deletions
diff --git a/pkgs/applications/misc/synergy/default.nix b/pkgs/applications/misc/synergy/default.nix
index e7f24b37f161..0493fe44631d 100644
--- a/pkgs/applications/misc/synergy/default.nix
+++ b/pkgs/applications/misc/synergy/default.nix
@@ -12,7 +12,7 @@ stdenv.mkDerivation {
   };
   */
 
-  buildInputs = [x11 xextproto libXtst inputproto];
+  buildInputs = [x11 xextproto libXtst inputproto libXi];
 
   patches = [ (fetchurl {
     url = http://mawercer.de/~nix/syncergy-gcc43.patch.gz;
diff --git a/pkgs/applications/misc/xchm/default.nix b/pkgs/applications/misc/xchm/default.nix
index adbb6f371eb7..b574b5fa5ec9 100644
--- a/pkgs/applications/misc/xchm/default.nix
+++ b/pkgs/applications/misc/xchm/default.nix
@@ -1,10 +1,10 @@
 {stdenv, fetchurl, wxGTK, chmlib}:
 
 stdenv.mkDerivation {
-  name = "xchm-1.9";
+  name = "xchm-1.17";
   src = fetchurl {
-    url = mirror://sourceforge/xchm/xchm-1.14.tar.gz;
-    sha256 = "0gx8h8iabfrawx86f3im36favwl18afwx6z7w9gkjamihcm1an1w";
+    url = mirror://sourceforge/xchm/xchm-1.17.tar.gz;
+    sha256 = "0yizisn4833nnpd4apallyg8iv334y00hv3awbsbc0ks2zf93x0n";
   };
   buildInputs = [wxGTK chmlib];
 
diff --git a/pkgs/applications/networking/browsers/chromium/default.nix b/pkgs/applications/networking/browsers/chromium/default.nix
index e7855c552ec3..64157f66f2f8 100644
--- a/pkgs/applications/networking/browsers/chromium/default.nix
+++ b/pkgs/applications/networking/browsers/chromium/default.nix
@@ -26,17 +26,17 @@ assert stdenv.system == "i686-linux" || stdenv.system == "x86_64-linux" ;
 
 stdenv.mkDerivation rec {
   name = "chrome-${version}";
-  version = "31080";
+  version = "31663";
   src = 
     if stdenv.system == "x86_64-linux" then 
       fetchurl {
         url = "http://build.chromium.org/buildbot/snapshots/chromium-rel-linux-64/${version}/chrome-linux.zip";
-        sha256 = "1km6mrhzgdlhy7pl60g8wh8hlxp0ymv6rqpp3aqd94mqj9g5asm9";
+        sha256 = "0dl3kvfwlg7clq8v67wx8xydsj181qmmpg877s75ys9h1gb01gr6";
       } 
     else if stdenv.system == "i686-linux" then 
       fetchurl {
         url = "http://build.chromium.org/buildbot/snapshots/chromium-rel-linux/${version}/chrome-linux.zip";
-        sha256 = "12awdamkkcb8kq2z7kila00yhn9msihq7b6970k9hghbwq95hjrk";
+        sha256 = "1d8fmw0rar44nabqw9sfv84vfw4a2hb9mi1j7a60nwb23wzl80s8";
       } 
     else null;
 
diff --git a/pkgs/applications/networking/browsers/icecat-3/default.nix b/pkgs/applications/networking/browsers/icecat-3/default.nix
index 038531419b13..c0948c9dca98 100644
--- a/pkgs/applications/networking/browsers/icecat-3/default.nix
+++ b/pkgs/applications/networking/browsers/icecat-3/default.nix
@@ -4,13 +4,13 @@
 , freetype, fontconfig
 , application ? "browser" }:
 
-let version = "3.5.4"; in
+let version = "3.5.5"; in
 stdenv.mkDerivation {
   name = "icecat-${version}";
 
   src = fetchurl {
     url = "mirror://gnu/gnuzilla/${version}/icecat-${version}.tar.bz2";
-    sha256 = "0j506l2qg30xg11zlfk8b2jwrp8bghc286j21gx0ws2qy6snagnr";
+    sha256 = "1mwk81vkay007k1rcx9hdmfl2540lj5nrxxv3zagifbaala89c3d";
   };
 
   buildInputs = [
diff --git a/pkgs/applications/office/ledger/default.nix b/pkgs/applications/office/ledger/default.nix
new file mode 100644
index 000000000000..c6c2fd4d1b19
--- /dev/null
+++ b/pkgs/applications/office/ledger/default.nix
@@ -0,0 +1,46 @@
+# TODO: fix a problem with patchelf(?)
+
+{stdenv, fetchurl, emacs, gmp, pcre}:
+
+let
+
+  pname = "ledger";
+  version = "2.6.1";
+  name = "${pname}-${version}";
+
+in
+
+stdenv.mkDerivation {
+  inherit name;
+
+  src = fetchurl {
+    url = "mirror://sourceforge/${pname}/${name}.tar.gz";
+    sha256 = "96830d77d3aa6bf6c5778f5dd52169f9b5203fb7daad0e12831abeb35b14f27a";
+  };
+
+  buildInputs = [ emacs gmp pcre ];
+
+  # Something goes wrong with pathelf...
+  # this is a small workaround: adds a small shell script for
+  # setting LD_LIBRARY_PATH
+  postInstall = ''
+    cd $out/bin
+    mv ledger ledger.bin
+    echo "#!/bin/sh" > ledger
+    echo "LD_LIBRARY_PATH=$out/lib $out/bin/ledger.bin "'"$@"' >> ledger
+    chmod +x ledger
+  '';
+
+  meta = {
+    description =
+     "A double-entry accounting system with a command-line reporting interface";
+    longDescription = ''
+      Ledger is a powerful, double-entry accounting system that is accessed
+      from the UNIX command-line. This may put off some users, as there is
+      no flashy UI, but for those who want unparalleled reporting access to
+      their data, there really is no alternative.
+    '';
+    homepage = http://wiki.github.com/jwiegley/ledger;
+    license = "BSD";
+  };
+}
diff --git a/pkgs/applications/version-management/monotone-viz/mtn-head.nix b/pkgs/applications/version-management/monotone-viz/mtn-head.nix
index 919f17f54617..6693795edd90 100644
--- a/pkgs/applications/version-management/monotone-viz/mtn-head.nix
+++ b/pkgs/applications/version-management/monotone-viz/mtn-head.nix
@@ -5,7 +5,7 @@ rec {
     dbs = ["monotone.ca"];
     selector = "0e9194c89eb87e62ac7d54c7b88b10b94b07fa41";
     branch = "net.venge.monotone-viz.automate";
-    sha256 = "b9189ccd64c02d158517e97bce079e87843e7b1948c5c61c534aa0b885c711ac";
+    sha256 = "d7980c9729b0a58f0dd27768b8eae46b45462fe72a88534b8aa159d889b4d624";
   } + "/";
 
   buildInputs = [ocaml lablgtk libgnomecanvas gtk graphviz glib 
diff --git a/pkgs/applications/virtualization/qemu/0.11.0.nix b/pkgs/applications/virtualization/qemu/0.11.0.nix
new file mode 100644
index 000000000000..bbcf18064525
--- /dev/null
+++ b/pkgs/applications/virtualization/qemu/0.11.0.nix
@@ -0,0 +1,18 @@
+{stdenv, fetchurl, SDL, zlib, which}:
+
+stdenv.mkDerivation {
+  name = "qemu-0.11.0";
+
+  src = fetchurl {
+    url = http://download.savannah.gnu.org/releases/qemu/qemu-0.11.0.tar.gz;
+    sha256 = "1w3n61lzwvqg1ygn0vs8syybbmbcbk7lfyya098k201lp5rpwamw";
+  };
+
+  patchFlags = "-p2";
+  
+  buildInputs = [SDL zlib which];
+  
+  meta = {
+    description = "QEmu processor emulator";
+  };
+}