summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/altcoins/default.nix4
-rw-r--r--pkgs/applications/altcoins/dero.nix27
-rw-r--r--pkgs/applications/altcoins/sumokoin.nix35
-rw-r--r--pkgs/applications/editors/android-studio/default.nix6
-rw-r--r--pkgs/applications/networking/syncthing012/default.nix35
-rw-r--r--pkgs/applications/networking/syncthing012/deps.nix128
-rw-r--r--pkgs/applications/networking/syncthing013/default.nix39
-rw-r--r--pkgs/applications/video/qmediathekview/default.nix2
8 files changed, 70 insertions, 206 deletions
diff --git a/pkgs/applications/altcoins/default.nix b/pkgs/applications/altcoins/default.nix
index 757c6e276fdf..37df75ae110e 100644
--- a/pkgs/applications/altcoins/default.nix
+++ b/pkgs/applications/altcoins/default.nix
@@ -26,6 +26,8 @@ rec {
 
   dashpay = callPackage ./dashpay.nix { };
 
+  dero = callPackage ./dero.nix { };
+
   dogecoin  = callPackage ./dogecoin.nix { withGui = true; };
   dogecoind = callPackage ./dogecoin.nix { withGui = false; };
 
@@ -59,6 +61,8 @@ rec {
 
   stellar-core = callPackage ./stellar-core.nix { };
 
+  sumokoin = callPackage ./sumokoin.nix { };
+
   zcash = callPackage ./zcash {
     withGui = false;
     openssl = openssl_1_1_0;
diff --git a/pkgs/applications/altcoins/dero.nix b/pkgs/applications/altcoins/dero.nix
new file mode 100644
index 000000000000..f3e24b6c015b
--- /dev/null
+++ b/pkgs/applications/altcoins/dero.nix
@@ -0,0 +1,27 @@
+{ lib, stdenv, fetchFromGitHub, cmake, pkgconfig, unbound, openssl, boost
+, libunwind, lmdb, miniupnpc, readline }:
+
+stdenv.mkDerivation rec {
+  name = "dero-${version}";
+  version = "0.11.3";
+
+  src = fetchFromGitHub {
+    owner = "deroproject";
+    repo = "dero";
+    rev = "v${version}";
+    sha256 = "0cv4yg2lkmkdhlc3753gnbg1nzldk2kxwdyizwhvanq3ycqban4b";
+  };
+
+  nativeBuildInputs = [ cmake pkgconfig ];
+  buildInputs = [ boost miniupnpc openssl lmdb unbound readline ];
+
+  enableParallelBuilding = true;
+
+  meta = with lib; {
+    description = "Secure, private blockchain with smart contracts based on Monero";
+    homepage = "https://dero.io/";
+    license = licenses.bsd3;
+    maintainers = with maintainers; [ fpletz ];
+    platforms = platforms.linux;
+  };
+}
diff --git a/pkgs/applications/altcoins/sumokoin.nix b/pkgs/applications/altcoins/sumokoin.nix
new file mode 100644
index 000000000000..026008b2761a
--- /dev/null
+++ b/pkgs/applications/altcoins/sumokoin.nix
@@ -0,0 +1,35 @@
+{ lib, stdenv, fetchFromGitHub, cmake, unbound, openssl, boost
+, libunwind, lmdb, miniupnpc }:
+
+stdenv.mkDerivation rec {
+  name = "sumokoin-${version}";
+  version = "0.2.0.0";
+
+  src = fetchFromGitHub {
+    owner = "sumoprojects";
+    repo = "sumokoin";
+    rev = "v${version}";
+    sha256 = "0ndgcawhxh3qb3llrrilrwzhs36qpxv7f53rxgcansbff9b3za6n";
+  };
+
+  nativeBuildInputs = [ cmake ];
+  buildInputs = [ unbound openssl boost libunwind lmdb miniupnpc ];
+
+  postPatch = ''
+    substituteInPlace src/blockchain_db/lmdb/db_lmdb.cpp --replace mdb_size_t size_t
+  '';
+
+  cmakeFlags = [
+    "-DLMDB_INCLUDE=${lmdb}/include"
+  ];
+
+  enableParallelBuilding = true;
+
+  meta = with lib; {
+    description = "Sumokoin is a fork of Monero and a truely fungible cryptocurrency";
+    homepage = "https://www.sumokoin.org/";
+    license = licenses.bsd3;
+    maintainers = with maintainers; [ fpletz ];
+    platforms = platforms.linux;
+  };
+}
diff --git a/pkgs/applications/editors/android-studio/default.nix b/pkgs/applications/editors/android-studio/default.nix
index 4cd0553e4d2e..725841e47b49 100644
--- a/pkgs/applications/editors/android-studio/default.nix
+++ b/pkgs/applications/editors/android-studio/default.nix
@@ -27,9 +27,9 @@ in rec {
 
   preview = mkStudio {
     pname = "android-studio-preview";
-    version = "3.1.0.9"; # "Android Studio 3.1 Beta 1"
-    build = "173.4567466";
-    sha256Hash = "01c6a46pk5zbhwk2w038nm68fkx86nafiw1v2i5rdr93mxvx9cag";
+    version = "3.1.0.10"; # "Android Studio 3.1 Beta 2"
+    build = "173.4580418";
+    sha256Hash = "0s56vbyq6b1q75ss6pqvhzwqzb6xbp6841f3y5cwhrch2xalxjkc";
 
     meta = stable.meta // {
       description = "The Official IDE for Android (preview version)";
diff --git a/pkgs/applications/networking/syncthing012/default.nix b/pkgs/applications/networking/syncthing012/default.nix
deleted file mode 100644
index cd6fcc28a50a..000000000000
--- a/pkgs/applications/networking/syncthing012/default.nix
+++ /dev/null
@@ -1,35 +0,0 @@
-{ stdenv, lib, buildGoPackage, fetchFromGitHub }:
-
-buildGoPackage rec {
-  name = "syncthing-${version}";
-  version = "0.12.15";
-  rev = "v${version}";
-
-  goPackagePath = "github.com/syncthing/syncthing";
-
-  src = fetchFromGitHub {
-    inherit rev;
-    owner = "syncthing";
-    repo = "syncthing";
-    sha256 = "0g4sj509h45iq6g7b0pl88rbbn7c7s01774yjc6bl376x1xrl6a1";
-  };
-
-  goDeps = ./deps.nix;
-
-  postPatch = ''
-    # Mostly a cosmetic change
-    sed -i 's,unknown-dev,${version},g' cmd/syncthing/main.go
-  '';
-
-  preBuild = ''
-    export buildFlagsArray+=("-tags" "noupgrade release")
-  '';
-
-  meta = {
-    knownVulnerabilities = [ "CVE-2017-1000420" ];
-    homepage = https://www.syncthing.net/;
-    description = "Open Source Continuous File Synchronization";
-    license = stdenv.lib.licenses.mpl20;
-    platforms = with stdenv.lib.platforms; linux ++ freebsd ++ openbsd ++ netbsd;
-  };
-}
diff --git a/pkgs/applications/networking/syncthing012/deps.nix b/pkgs/applications/networking/syncthing012/deps.nix
deleted file mode 100644
index 44e18c2f606d..000000000000
--- a/pkgs/applications/networking/syncthing012/deps.nix
+++ /dev/null
@@ -1,128 +0,0 @@
-[
-  {
-    goPackagePath = "golang.org/x/crypto";
-    fetch = {
-      type = "git";
-      url = "https://go.googlesource.com/crypto";
-      rev = "575fdbe86e5dd89229707ebec0575ce7d088a4a6";
-      sha256 = "1kgv1mkw9y404pk3lcwbs0vgl133mwyp294i18jg9hp10s5d56xa";
-    };
-  }
-  {
-    goPackagePath = "golang.org/x/net";
-    fetch = {
-      type = "git";
-      url = "https://go.googlesource.com/net";
-      rev = "62ac18b461605b4be188bbc7300e9aa2bc836cd4";
-      sha256 = "0lwwvbbwbf3yshxkfhn6z20gd45dkvnmw2ms36diiy34krgy402p";
-    };
-  }
-  {
-    goPackagePath = "github.com/rcrowley/go-metrics";
-    fetch = {
-      type = "git";
-      url = "https://github.com/rcrowley/go-metrics";
-      rev = "1ce93efbc8f9c568886b2ef85ce305b2217b3de3";
-      sha256 = "06gg72krlmd0z3zdq6s716blrga95pyj8dc2f2psfbknbkyrkfqa";
-    };
-  }
-  {
-    goPackagePath = "github.com/kardianos/osext";
-    fetch = {
-      type = "git";
-      url = "https://github.com/kardianos/osext";
-      rev = "29ae4ffbc9a6fe9fb2bc5029050ce6996ea1d3bc";
-      sha256 = "1mawalaz84i16njkz6f9fd5jxhcbxkbsjnav3cmqq2dncv2hyv8a";
-    };
-  }
-  {
-    goPackagePath = "github.com/bkaradzic/go-lz4";
-    fetch = {
-      type = "git";
-      url = "https://github.com/bkaradzic/go-lz4";
-      rev = "74ddf82598bc4745b965729e9c6a463bedd33049";
-      sha256 = "1vdid8v0c2v2qhrg9rzn3l7ya1h34jirrxfnir7gv7w6s4ivdvc1";
-    };
-  }
-  {
-    goPackagePath = "github.com/calmh/luhn";
-    fetch = {
-      type = "git";
-      url = "https://github.com/calmh/luhn";
-      rev = "0c8388ff95fa92d4094011e5a04fc99dea3d1632";
-      sha256 = "1hfj1lx7wdpifn16zqrl4xml6cj5gxbn6hfz1f46g2a6bdf0gcvs";
-    };
-  }
-  {
-    goPackagePath = "golang.org/x/text";
-    fetch = {
-      type = "git";
-      url = "https://go.googlesource.com/text";
-      rev = "5eb8d4684c4796dd36c74f6452f2c0fa6c79597e";
-      sha256 = "1cjwm2pv42dbfqc6ylr7jmma902zg4gng5aarqrbjf1k2nf2vs14";
-    };
-  }
-  {
-    goPackagePath = "github.com/vitrun/qart";
-    fetch = {
-      type = "git";
-      url = "https://github.com/vitrun/qart";
-      rev = "ccb109cf25f0cd24474da73b9fee4e7a3e8a8ce0";
-      sha256 = "0bhp768b8ha6f25dmhwn9q8m2lkbn4qnjf8n7pizk25jn5zjdvc8";
-    };
-  }
-  {
-    goPackagePath = "github.com/calmh/du";
-    fetch = {
-      type = "git";
-      url = "https://github.com/calmh/du";
-      rev = "3c0690cca16228b97741327b1b6781397afbdb24";
-      sha256 = "1mv6mkbslfc8giv47kyl97ny0igb3l7jya5hc75sm54xi6g205wa";
-    };
-  }
-  {
-    goPackagePath = "github.com/calmh/xdr";
-    fetch = {
-      type = "git";
-      url = "https://github.com/calmh/xdr";
-      rev = "e467b5aeb65ca8516fb3925c84991bf1d7cc935e";
-      sha256 = "1bi4b2xkjzcr0vq1wxz14i9943k71sj092dam0gdmr9yvdrg0nra";
-    };
-  }
-  {
-    goPackagePath = "github.com/juju/ratelimit";
-    fetch = {
-      type = "git";
-      url = "https://github.com/juju/ratelimit";
-      rev = "772f5c38e468398c4511514f4f6aa9a4185bc0a0";
-      sha256 = "02rs61ay6sq499lxxszjsrxp33m6zklds1xrmnr5fk73vpqfa28p";
-    };
-  }
-  {
-    goPackagePath = "github.com/thejerf/suture";
-    fetch = {
-      type = "git";
-      url = "https://github.com/thejerf/suture";
-      rev = "99c1f2d613756768fc4299acd9dc621e11ed3fd7";
-      sha256 = "094ksr2nlxhvxr58nbnzzk0prjskb21r86jmxqjr3rwg4rkwn6d4";
-    };
-  }
-  {
-    goPackagePath = "github.com/golang/snappy";
-    fetch = {
-      type = "git";
-      url = "https://github.com/golang/snappy";
-      rev = "723cc1e459b8eea2dea4583200fd60757d40097a";
-      sha256 = "0bprq0qb46f5511b5scrdqqzskqqi2z8b4yh3216rv0n1crx536h";
-    };
-  }
-  {
-    goPackagePath = "github.com/syndtr/goleveldb";
-    fetch = {
-      type = "git";
-      url = "https://github.com/syndtr/goleveldb";
-      rev = "1a9d62f03ea92815b46fcaab357cfd4df264b1a0";
-      sha256 = "04ywbif36fiah4fw0x2abr5q3p4fdhi6q57d5icc2mz03q889vhb";
-    };
-  }
-]
diff --git a/pkgs/applications/networking/syncthing013/default.nix b/pkgs/applications/networking/syncthing013/default.nix
deleted file mode 100644
index e1a0dc38c11f..000000000000
--- a/pkgs/applications/networking/syncthing013/default.nix
+++ /dev/null
@@ -1,39 +0,0 @@
-{ stdenv, fetchgit, go }:
-
-stdenv.mkDerivation rec {
-  version = "0.13.10";
-  name = "syncthing-${version}";
-
-  src = fetchgit {
-    url = https://github.com/syncthing/syncthing;
-    rev = "refs/tags/v${version}";
-    sha256 = "07q3j6mnrza719rnvbkdsmvlkyr2pch5sj2l204m5iy5mxaghpx7";
-  };
-
-  buildInputs = [ go ];
-
-  buildPhase = ''
-    mkdir -p src/github.com/syncthing
-    ln -s $(pwd) src/github.com/syncthing/syncthing
-    export GOPATH=$(pwd)
-
-    # Syncthing's build.go script expects this working directory
-    cd src/github.com/syncthing/syncthing
-
-    go run build.go -no-upgrade -version v${version} install all
-  '';
-
-  installPhase = ''
-    mkdir -p $out/bin
-    cp bin/* $out/bin
-  '';
-
-  meta = {
-    knownVulnerabilities = [ "CVE-2017-1000420" ];
-    homepage = https://www.syncthing.net/;
-    description = "Open Source Continuous File Synchronization";
-    license = stdenv.lib.licenses.mpl20;
-    maintainers = with stdenv.lib.maintainers; [pshendry];
-    platforms = with stdenv.lib.platforms; linux ++ freebsd ++ openbsd ++ netbsd;
-  };
-}
diff --git a/pkgs/applications/video/qmediathekview/default.nix b/pkgs/applications/video/qmediathekview/default.nix
index 9d34ab72f0cf..13f93800f6e2 100644
--- a/pkgs/applications/video/qmediathekview/default.nix
+++ b/pkgs/applications/video/qmediathekview/default.nix
@@ -27,7 +27,7 @@ stdenv.mkDerivation rec {
     description = "An alternative Qt-based front-end for the database maintained by the MediathekView project";
     inherit (src.meta) homepage;
     license = licenses.gpl3Plus;
-    platforms = [ "i686-linux" "x86_64-linux" ];
+    platforms = platforms.linux;
     maintainers = with maintainers; [ dotlambda ];
   };
 }