summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/networking/corebird/default.nix33
1 files changed, 33 insertions, 0 deletions
diff --git a/pkgs/applications/networking/corebird/default.nix b/pkgs/applications/networking/corebird/default.nix
new file mode 100644
index 000000000000..f047bb42e7c6
--- /dev/null
+++ b/pkgs/applications/networking/corebird/default.nix
@@ -0,0 +1,33 @@
+{ stdenv, fetchFromGitHub, gtk3, json_glib, sqlite, libsoup, gettext, vala_0_32
+, automake, autoconf, libtool, pkgconfig, gnome3, gst_all_1, wrapGAppsHook }:
+
+stdenv.mkDerivation rec {
+  version = "1.3.1";
+  name = "corebird-${version}";
+
+  src = fetchFromGitHub {
+    owner = "baedert";
+    repo = "corebird";
+    rev = version;
+    sha256 = "1a7b6hinl5p7yanf75a0khki2fvd04km1xlkwnspgx75cmnbnn5z";
+  };
+
+  preConfigure = ''
+    ./autogen.sh
+  '';
+
+  nativeBuildInputs = [ automake autoconf libtool pkgconfig wrapGAppsHook ];
+
+  buildInputs = [
+    gtk3 json_glib sqlite libsoup gettext vala_0_32 gnome3.rest
+  ] ++ (with gst_all_1; [ gstreamer gst-plugins-base gst-plugins-good gst-plugins-bad gst-libav ]);
+
+  meta = {
+    description = "Native Gtk+ Twitter client for the Linux desktop";
+    longDescription = "Corebird is a modern, easy and fun Twitter client.";
+    homepage = http://corebird.baedert.org;
+    license = stdenv.lib.licenses.gpl3;
+    platforms = stdenv.lib.platforms.linux;
+    maintainers = [ stdenv.lib.maintainers.jonafato ];
+  };
+}