summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/audio/dirt/default.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/pkgs/applications/audio/dirt/default.nix b/pkgs/applications/audio/dirt/default.nix
new file mode 100644
index 000000000000..b5436fde7e9f
--- /dev/null
+++ b/pkgs/applications/audio/dirt/default.nix
@@ -0,0 +1,21 @@
+{ stdenv, fetchFromGitHub, libsndfile, libsamplerate, liblo, jack2 }:
+
+stdenv.mkDerivation rec {
+  name = "dirt-git";
+  src = fetchFromGitHub {
+    repo = "Dirt";
+    owner = "tidalcycles";
+    rev = "cfc5e85318defda7462192b5159103c823ce61f7";
+    sha256 = "1shbyp54q64g6bsl6hhch58k3z1dyyy9ph6cq2xvdf8syy00sisz";
+  };
+  buildInputs = [ libsndfile libsamplerate liblo jack2 ];
+  configurePhase = ''
+    export DESTDIR=$out
+  '';
+
+  meta = {
+    description = "An unimpressive thingie for playing bits of samples with some level of accuracy";
+    homepage = "https://github.com/tidalcycles/Dirt";
+    license = stdenv.lib.licenses.gpl3;
+  };
+}