summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/networking/p2p/firestr/default.nix35
-rw-r--r--pkgs/applications/networking/p2p/firestr/return.patch13
-rw-r--r--pkgs/applications/version-management/git-and-tools/default.nix2
-rw-r--r--pkgs/applications/version-management/git-and-tools/git-imerge/default.nix27
4 files changed, 77 insertions, 0 deletions
diff --git a/pkgs/applications/networking/p2p/firestr/default.nix b/pkgs/applications/networking/p2p/firestr/default.nix
new file mode 100644
index 000000000000..49d15f59c7fa
--- /dev/null
+++ b/pkgs/applications/networking/p2p/firestr/default.nix
@@ -0,0 +1,35 @@
+{ stdenv, fetchFromGitHub, cmake, boost, botan, snappy, libopus, libuuid, qt5
+, libXScrnSaver, openssl }:
+
+stdenv.mkDerivation {
+  name = "firestr-0.8";
+
+  buildInputs = [ cmake boost botan snappy libopus libuuid qt5 libXScrnSaver openssl ];
+
+  src = fetchFromGitHub {
+    owner  = "mempko";
+    repo   = "firestr";
+    rev    = "f888890f71d49953d05bccdd27a1c4f6690e165c";
+    sha256 = "0s2kdi8rw3i3f8gbiy0ykyi6xj5n8p80m0d1i86mhh8jpagvbfzb";
+  };
+
+  patches = ./return.patch;
+
+  postPatch =
+    ''
+      substituteInPlace CMakeLists.txt \
+        --replace "set(Boost_USE_STATIC_LIBS on)" "" \
+        --replace "/usr/include/botan" "${botan}/include/botan" \
+        --replace "libopus.a"       "libopus.so" \
+        --replace "libsnappy.a"     "libsnappy.so" \
+        --replace "libbotan-1.10.a" "libbotan-1.10.so.0"
+    '';
+
+  meta = with stdenv.lib;
+    { description = "Grass computing platform";
+      homepage = http://firestr.com/;
+      license = licenses.gpl3;
+      maintainers = [ maintainers.emery ];
+      platforms = platforms.linux;
+    };
+}
diff --git a/pkgs/applications/networking/p2p/firestr/return.patch b/pkgs/applications/networking/p2p/firestr/return.patch
new file mode 100644
index 000000000000..c3e469ae92b0
--- /dev/null
+++ b/pkgs/applications/networking/p2p/firestr/return.patch
@@ -0,0 +1,13 @@
+diff --git a/src/message/master_post.cpp b/src/message/master_post.cpp
+index c3a5ea9..7c821b9 100644
+--- a/src/message/master_post.cpp
++++ b/src/message/master_post.cpp
+@@ -56,7 +56,7 @@ namespace fire
+ 
+         metadata::encryption_type to_message_encryption_type(sc::encryption_type s)
+         {
+-            metadata::encryption_type r;
++            metadata::encryption_type r = metadata::encryption_type::asymmetric;
+             switch(s)
+             {
+                 case sc::encryption_type::plaintext: r = metadata::encryption_type::plaintext; break;
diff --git a/pkgs/applications/version-management/git-and-tools/default.nix b/pkgs/applications/version-management/git-and-tools/default.nix
index 8b3558e0adf0..56a6618e5310 100644
--- a/pkgs/applications/version-management/git-and-tools/default.nix
+++ b/pkgs/applications/version-management/git-and-tools/default.nix
@@ -102,4 +102,6 @@ rec {
   git-extras = callPackage ./git-extras { };
 
   git-cola = callPackage ./git-cola { };
+
+  git-imerge = callPackage ./git-imerge { };
 }
diff --git a/pkgs/applications/version-management/git-and-tools/git-imerge/default.nix b/pkgs/applications/version-management/git-and-tools/git-imerge/default.nix
new file mode 100644
index 000000000000..91180b33cde9
--- /dev/null
+++ b/pkgs/applications/version-management/git-and-tools/git-imerge/default.nix
@@ -0,0 +1,27 @@
+{ stdenv, fetchurl, pythonPackages }:
+
+stdenv.mkDerivation rec {
+  name = "git-imerge-${version}";
+  version = "0.7.0";
+
+  src = fetchurl {
+    url = "https://github.com/mhagger/git-imerge/archive/${version}.tar.gz";
+    sha256 = "00nwn3rfhf15wsv01lfji5412d7yz827ric916lnyp662d6gx206";
+  };
+
+  buildInputs = [ pythonPackages.python pythonPackages.wrapPython ];
+
+  installPhase = ''
+    mkdir -p $out/bin
+    make install PREFIX=$out
+    wrapPythonPrograms
+  '';
+
+  meta = with stdenv.lib; {
+    homepage = https://github.com/mhagger/git-imerge;
+    description = "Perform a merge between two branches incrementally";
+    license = licenses.gpl2;
+    platforms = platforms.all;
+    maintainers = [ maintainers.spwhitt ];
+  };
+}