summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/audio/distrho/default.nix24
-rw-r--r--pkgs/applications/editors/eclipse/default.nix2
-rw-r--r--pkgs/applications/misc/spacefm/default.nix36
3 files changed, 31 insertions, 31 deletions
diff --git a/pkgs/applications/audio/distrho/default.nix b/pkgs/applications/audio/distrho/default.nix
index a8c710f2099e..e6d5971b6fd2 100644
--- a/pkgs/applications/audio/distrho/default.nix
+++ b/pkgs/applications/audio/distrho/default.nix
@@ -2,12 +2,12 @@
 , libxslt, lv2, pkgconfig, premake3, xlibs }:
 
 stdenv.mkDerivation rec {
-  name = "distrho-ports-git-2015-01-28";
+  name = "distrho-ports-git-2015-05-04";
 
   src = fetchgit {
     url = "https://github.com/DISTRHO/DISTRHO-Ports.git";
-    rev = "b4e2dc24802fe6804c60fcd2559a0bca46b7709c";
-    sha256 = "661ff6f7cda71a8dd08cbcea3f560e99f0fc2232053cbc9a2aaba854137805c6";
+    rev = "3f13db5dc7722ed0dcbb5256d7fac1ac9165c2d8";
+    sha256 = "6f740f6a8af714436ef75b858944e8122490a2faa04591a201105e84bca42fa0";
   };
 
   patchPhase = ''
@@ -22,13 +22,11 @@ stdenv.mkDerivation rec {
 
   buildPhase = ''
     sh ./scripts/premake-update.sh linux
-    make standalone
     make lv2
   '';
 
   installPhase = ''
     mkdir -p $out/bin
-    cp bin/standalone/* $out/bin/
     mkdir -p $out/lib/lv2
     cp -a bin/lv2/* $out/lib/lv2/
   '';
@@ -38,18 +36,14 @@ stdenv.mkDerivation rec {
     description = "A collection of cross-platform audio effects and plugins";
     longDescription = ''
       Includes:
-      3BandEQ bitmangler drowaudio-distortion drowaudio-flanger
-      drowaudio-tremolo eqinox juce_pitcher sDelay TAL-Filter
-      TAL-NoiseMaker TAL-Reverb-2 TAL-Vocoder-2 ThePilgrim
-      Wolpertinger argotlunar capsaicin drowaudio-distortionshaper
-      drowaudio-reverb drumsynth highlife JuceDemoPlugin PingPongPan
-      TAL-Dub-3 TAL-Filter-2 TAL-Reverb TAL-Reverb-3 TheFunction vex
+      Dexed  drowaudio-distortion drowaudio-distortionshaper drowaudio-flanger
+      drowaudio-reverb drowaudio-tremolo drumsynt EasySSP  eqinox
+      JuceDemoPlugin klangfalter LUFSMeter luftikus obxd pitchedDelay
+      stereosourceseparation TAL-Dub-3 TAL-Filter TAL-Filter-2 TAL-NoiseMaker
+      TAL-Reverb TAL-Reverb-2 TAL-Reverb-3 TAL-Vocoder-2 TheFunction
+      ThePilgrim Vex Wolpertinger
     '';
     maintainers = [ maintainers.goibhniu ];
     platforms = platforms.linux;
-
-    # The old repo was removed and split into multiple repos. More
-    # work is required to get everything to build and work.
-    broken = true;
   };
 }
diff --git a/pkgs/applications/editors/eclipse/default.nix b/pkgs/applications/editors/eclipse/default.nix
index 8964d6c64800..0373791dccaa 100644
--- a/pkgs/applications/editors/eclipse/default.nix
+++ b/pkgs/applications/editors/eclipse/default.nix
@@ -298,7 +298,7 @@ in {
         };
       "i686-linux" = fetchurl {
           url = http://download.eclipse.org/eclipse/downloads/drops4/R-4.4.2-201502041700/eclipse-SDK-4.4.2-linux-gtk.tar.gz;
-          sha256 = "9f4238ce9f887a1a57bbc6c6898e43357d14a6d74f59385327813c5e82aa735d";
+          sha256 = "1hacyjjwhhxi7r3xyhpqgjqpd5r0irw9bfkalz5s5l6shb0lq4i7";
         };
     };
   };
diff --git a/pkgs/applications/misc/spacefm/default.nix b/pkgs/applications/misc/spacefm/default.nix
index b88e4c567cc1..ea7663c24069 100644
--- a/pkgs/applications/misc/spacefm/default.nix
+++ b/pkgs/applications/misc/spacefm/default.nix
@@ -1,30 +1,36 @@
-{ pkgs, fetchurl, stdenv, gtk3, udev, desktop_file_utils, shared_mime_info
-, intltool, pkgconfig, makeWrapper
-}:
+{ pkgs, fetchurl, stdenv, gtk3, udev, desktop_file_utils, shared_mime_info , intltool, pkgconfig, makeWrapper, ffmpegthumbnailer, jmtpfs, ifuse, lsof, udisks }:
 
-let
-  version = "0.9.2";
-
-in stdenv.mkDerivation rec {
+stdenv.mkDerivation rec {
   name = "spacefm-${version}";
+  version = "1.0.1";
 
   src = fetchurl {
-    url = "https://github.com/IgnorantGuru/spacefm/blob/pkg/${version}/${name}.tar.xz?raw=true";
-    sha256 = "3767137d74aa78597ffb42a6121784e91a4276efcd5d718b3793b9790f82268c";
+    url = "https://github.com/IgnorantGuru/spacefm/archive/${version}.tar.gz";
+    sha256 = "0mps6akwzr4mkljgywpimwgqf6ajnd7gq615877h20wyjf4h46vz";
   };
 
-  buildInputs = [ gtk3 udev desktop_file_utils shared_mime_info intltool pkgconfig makeWrapper ];
+  configureFlags = [
+    "--with-bash-path=${pkgs.bash}/bin/bash"
+    "--with-preferable-sudo=${pkgs.sudo}/bin/sudo"
+  ];
+
+  buildInputs = [ gtk3 udev desktop_file_utils shared_mime_info intltool pkgconfig makeWrapper ffmpegthumbnailer jmtpfs ifuse lsof udisks ];
 
   preFixup = ''
     wrapProgram "$out/bin/spacefm" \
       --prefix XDG_DATA_DIRS : "$GSETTINGS_SCHEMAS_PATH"
   '';
 
-  meta = {
-    description = "Multi-panel tabbed file and desktop manager for Linux with built-in VFS, udev- or HAL-based device manager, customizable menu system, and bash integration";
-    platforms = pkgs.lib.platforms.linux;
-    license = pkgs.lib.licenses.gpl3;
+  meta = with stdenv.lib;  {
+    description = "A multi-panel tabbed file manager";
+    longDescription = "Multi-panel tabbed file and desktop manager for Linux
+      with built-in VFS, udev- or HAL-based device manager,
+      customizable menu system, and bash integration
+    ";
+    homepage = http://ignorantguru.github.io/spacefm/;
+    platforms = platforms.linux;
+    license = licenses.gpl3;
+    maintainers = [ maintainers.jagajaga ];
   };
 
 }
-