summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/altcoins/default.nix1
-rw-r--r--pkgs/applications/altcoins/parity/beta.nix7
-rw-r--r--pkgs/applications/altcoins/parity/default.nix8
-rw-r--r--pkgs/applications/altcoins/parity/patches/vendored-sources-1.9.patch101
4 files changed, 4 insertions, 113 deletions
diff --git a/pkgs/applications/altcoins/default.nix b/pkgs/applications/altcoins/default.nix
index 9915e0a301a1..1a0e77dc12f1 100644
--- a/pkgs/applications/altcoins/default.nix
+++ b/pkgs/applications/altcoins/default.nix
@@ -85,7 +85,6 @@ rec {
   };
 
   parity = callPackage ./parity { };
-  parity-beta = callPackage ./parity/beta.nix { };
   parity-ui = callPackage ./parity-ui { };
 
   particl-core = callPackage ./particl/particl-core.nix { boost = boost165; miniupnpc = miniupnpc_2; withGui = false; };
diff --git a/pkgs/applications/altcoins/parity/beta.nix b/pkgs/applications/altcoins/parity/beta.nix
deleted file mode 100644
index 9cbab6ad0955..000000000000
--- a/pkgs/applications/altcoins/parity/beta.nix
+++ /dev/null
@@ -1,7 +0,0 @@
-let
-  version     = "1.10.2";
-  sha256      = "1a1rbwlwi60nfv6m1rdy5baq5lcafc8nw96y45pr1674i48gkp0l";
-  cargoSha256 = "0l3rjkinzppfq8fi8h24r35rb552fzzman5a6yk33wlsdj2lv7yh";
-  patches     = [ ./patches/vendored-sources-1.10.patch ];
-in
-  import ./parity.nix { inherit version sha256 cargoSha256 patches; }
diff --git a/pkgs/applications/altcoins/parity/default.nix b/pkgs/applications/altcoins/parity/default.nix
index d85fc25355c8..3ba2495d45a2 100644
--- a/pkgs/applications/altcoins/parity/default.nix
+++ b/pkgs/applications/altcoins/parity/default.nix
@@ -1,7 +1,7 @@
 let
-  version     = "1.9.7";
-  sha256      = "1h9rmyqkdv2v83g12dadgqflq1n1qqgd5hrpy20ajha0qpbiv3ph";
-  cargoSha256 = "0ss5jw43850r8l34prai5vk1zd5d5fjyg4rcav1asbq6v683bww0";
-  patches     = [ ./patches/vendored-sources-1.9.patch ];
+  version     = "1.10.6";
+  sha256      = "1x2sm262z8fdkx8zin6r8nwbb7znziw9nm224pr6ap3p0jmv7fcq";
+  cargoSha256 = "1wf1lh32f9dlhv810gdcssv92g1yximx09lw63m0mxcjbn9813bs";
+  patches     = [ ./patches/vendored-sources-1.10.patch ];
 in
   import ./parity.nix { inherit version sha256 cargoSha256 patches; }
diff --git a/pkgs/applications/altcoins/parity/patches/vendored-sources-1.9.patch b/pkgs/applications/altcoins/parity/patches/vendored-sources-1.9.patch
deleted file mode 100644
index 3e1ba2429f2d..000000000000
--- a/pkgs/applications/altcoins/parity/patches/vendored-sources-1.9.patch
+++ /dev/null
@@ -1,101 +0,0 @@
-diff --git a/.cargo/config b/.cargo/config
-new file mode 100644
-index 000000000..0efb69724
---- /dev/null 
-+++ b/.cargo/config
-@@ -0,0 +1,94 @@
-+[source."https://github.com/alexcrichton/mio-named-pipes"]
-+git = "https://github.com/alexcrichton/mio-named-pipes"
-+branch = "master"
-+replace-with = "vendored-sources"
-+
-+[source."https://github.com/js-dist-paritytech/parity-stable-1-9-shell.git"]
-+git = "https://github.com/js-dist-paritytech/parity-stable-1-9-shell.git"
-+branch = "master"
-+replace-with = "vendored-sources"
-+
-+[source."https://github.com/js-dist-paritytech/parity-stable-1-9-v1.git"]
-+git = "https://github.com/js-dist-paritytech/parity-stable-1-9-v1.git"
-+branch = "master"
-+replace-with = "vendored-sources"
-+
-+[source."https://github.com/nikvolf/parity-tokio-ipc"]
-+git = "https://github.com/nikvolf/parity-tokio-ipc"
-+branch = "master"
-+replace-with = "vendored-sources"
-+
-+[source."https://github.com/nikvolf/tokio-named-pipes"]
-+git = "https://github.com/nikvolf/tokio-named-pipes"
-+branch = "master"
-+replace-with = "vendored-sources"
-+
-+[source."https://github.com/paritytech/app-dirs-rs"]
-+git = "https://github.com/paritytech/app-dirs-rs"
-+branch = "master"
-+replace-with = "vendored-sources"
-+
-+[source."https://github.com/paritytech/bn"]
-+git = "https://github.com/paritytech/bn"
-+branch = "master"
-+replace-with = "vendored-sources"
-+
-+[source."https://github.com/paritytech/hidapi-rs"]
-+git = "https://github.com/paritytech/hidapi-rs"
-+branch = "master"
-+replace-with = "vendored-sources"
-+
-+[source."https://github.com/paritytech/hyper"]
-+git = "https://github.com/paritytech/hyper"
-+branch = "master"
-+replace-with = "vendored-sources"
-+
-+[source."https://github.com/paritytech/jsonrpc.git"]
-+git = "https://github.com/paritytech/jsonrpc.git"
-+branch = "parity-1.9"
-+replace-with = "vendored-sources"
-+
-+[source."https://github.com/paritytech/libusb-rs"]
-+git = "https://github.com/paritytech/libusb-rs"
-+branch = "master"
-+replace-with = "vendored-sources"
-+
-+[source."https://github.com/paritytech/libusb-sys"]
-+git = "https://github.com/paritytech/libusb-sys"
-+branch = "master"
-+replace-with = "vendored-sources"
-+
-+[source."https://github.com/paritytech/rust-ctrlc.git"]
-+git = "https://github.com/paritytech/rust-ctrlc.git"
-+branch = "master"
-+replace-with = "vendored-sources"
-+
-+[source."https://github.com/paritytech/rust-rocksdb"]
-+git = "https://github.com/paritytech/rust-rocksdb"
-+branch = "master"
-+replace-with = "vendored-sources"
-+
-+[source."https://github.com/paritytech/rust-secp256k1"]
-+git = "https://github.com/paritytech/rust-secp256k1"
-+branch = "master"
-+replace-with = "vendored-sources"
-+
-+[source."https://github.com/paritytech/rust-snappy"]
-+git = "https://github.com/paritytech/rust-snappy"
-+branch = "master"
-+replace-with = "vendored-sources"
-+
-+[source."https://github.com/paritytech/trezor-sys"]
-+git = "https://github.com/paritytech/trezor-sys"
-+branch = "master"
-+replace-with = "vendored-sources"
-+
-+[source."https://github.com/tailhook/rotor"]
-+git = "https://github.com/tailhook/rotor"
-+branch = "master"
-+replace-with = "vendored-sources"
-+
-+[source."https://github.com/tomusdrw/ws-rs"]
-+git = "https://github.com/tomusdrw/ws-rs"
-+branch = "master"
-+replace-with = "vendored-sources"
-+