about summary refs log tree commit diff
path: root/overlays/patches/gnupg/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'overlays/patches/gnupg/default.nix')
-rw-r--r--overlays/patches/gnupg/default.nix8
1 files changed, 8 insertions, 0 deletions
diff --git a/overlays/patches/gnupg/default.nix b/overlays/patches/gnupg/default.nix
new file mode 100644
index 000000000000..35000019c0b0
--- /dev/null
+++ b/overlays/patches/gnupg/default.nix
@@ -0,0 +1,8 @@
+{ gnupg, ... } @ args:
+
+(gnupg.override (builtins.removeAttrs args [ "gnupg" ])).overrideAttrs (
+  { patches ? [], ... }:
+  {
+    patches = patches ++ [ ./VERY-BAD-allow-signing-with-expired-keys.patch ];
+  }
+)