about summary refs log tree commit diff
path: root/overlays/patches/emacs/rust-mode/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'overlays/patches/emacs/rust-mode/default.nix')
-rw-r--r--overlays/patches/emacs/rust-mode/default.nix10
1 files changed, 10 insertions, 0 deletions
diff --git a/overlays/patches/emacs/rust-mode/default.nix b/overlays/patches/emacs/rust-mode/default.nix
new file mode 100644
index 000000000000..01bfffb42579
--- /dev/null
+++ b/overlays/patches/emacs/rust-mode/default.nix
@@ -0,0 +1,10 @@
+{ rust-mode, fetchpatch }:
+
+rust-mode.overrideAttrs ({ patches ? [], ... }: {
+  patches = patches ++ [
+    (fetchpatch {
+      url = "https://github.com/rust-lang/rust-mode/commit/eca22f13e751bb4b1468192e0c92c6289f2cbeb4.patch";
+      sha256 = "1fg8vicq6ay88x9hjxah9mq6ily4ry8lh1jfpm3njrpjy63cix8j";
+    })
+  ];
+})