about summary refs log tree commit diff
path: root/overlays/patches/emacs/overlay/hydra/emacsen.nix
diff options
context:
space:
mode:
Diffstat (limited to 'overlays/patches/emacs/overlay/hydra/emacsen.nix')
-rw-r--r--overlays/patches/emacs/overlay/hydra/emacsen.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/overlays/patches/emacs/overlay/hydra/emacsen.nix b/overlays/patches/emacs/overlay/hydra/emacsen.nix
new file mode 100644
index 000000000000..7207c9688ad2
--- /dev/null
+++ b/overlays/patches/emacs/overlay/hydra/emacsen.nix
@@ -0,0 +1,16 @@
+{ nixpkgs }:
+let
+  pkgs = import nixpkgs {
+    overlays = [
+      (import ../default.nix)
+    ];
+  };
+  inherit (pkgs) lib;
+
+in {
+  inherit (pkgs) emacsUnstable emacsUnstable-nox;
+  inherit (pkgs) emacsGit emacsGit-nox;
+  inherit (pkgs) emacsPgtk;
+} // lib.optionalAttrs (lib.hasAttr "libgccjit" pkgs) {
+  inherit (pkgs) emacsGcc emacsPgtkGcc;
+}