about summary refs log tree commit diff
path: root/overlays/patches/dino/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'overlays/patches/dino/default.nix')
-rw-r--r--overlays/patches/dino/default.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/overlays/patches/dino/default.nix b/overlays/patches/dino/default.nix
new file mode 100644
index 000000000000..0ca4220f2f42
--- /dev/null
+++ b/overlays/patches/dino/default.nix
@@ -0,0 +1,21 @@
+{ lib, dino, fetchpatch, ... } @ args:
+
+(dino.override (builtins.removeAttrs args [
+  "dino" "fetchpatch"
+])).overrideAttrs ({ patches ? [], ... }: {
+  patches = patches ++ [
+    (fetchpatch {
+      url = "https://github.com/dino/dino/commit/6be319f8f9b1f19d2b775aa04660d9f2c3a04dd0.patch";
+      sha256 = "sha256-i7lJk5/1y/qwI53kChocWjlvS2ThRGrUTLxCMbyBgqs=";
+    })
+    (fetchpatch {
+      url = "https://github.com/dino/dino/commit/f85bf7af3d355794a2a5208aea21efeb5b6e529d.patch";
+      sha256 = "0y8dldydvj75i2n53brki9czvzw1qwlk5646k3xrx5pnl31c7p5b";
+    })
+  ];
+
+  postInstall = ''
+    mkdir -p $out/share/man/man1
+    mv ../doc/dino.1 $out/share/man/man1
+  '';
+})