about summary refs log tree commit diff
path: root/overlays/patches/cgit/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'overlays/patches/cgit/default.nix')
-rw-r--r--overlays/patches/cgit/default.nix36
1 files changed, 36 insertions, 0 deletions
diff --git a/overlays/patches/cgit/default.nix b/overlays/patches/cgit/default.nix
new file mode 100644
index 000000000000..d200e5aed43e
--- /dev/null
+++ b/overlays/patches/cgit/default.nix
@@ -0,0 +1,36 @@
+{ cgit, fetchpatch }:
+
+cgit.overrideAttrs ({ patches ? [], ... }: {
+  patches = patches ++ [
+    ./ui-commit-use-Git-raw-note-format.patch
+    (fetchpatch {
+      url = "https://inbox.vuxu.org/cgit/20200723210744.10221-1-hi@alyssa.is/raw";
+      sha256 = "1kxwph84n2la612r8cphy9fkbd851k0cys3mqp5ij3a69qkfdcg9";
+    })
+    (fetchpatch {
+      url = "https://inbox.vuxu.org/cgit/20190101114453.4876-2-e@80x24.org/raw";
+      sha256 = "1s3hpbj3r25wqis2rnjqmm0ld9cvnfaml76l90wm4yc5pymi894d";
+    })
+    (fetchpatch {
+      url = "https://inbox.vuxu.org/cgit/20190101114453.4876-3-e@80x24.org/raw";
+      sha256 = "03gw981bix86b2il6nl98z6dbk1c0hsrgbpc3p4rv5iz122c6kfl";
+    })
+    (fetchpatch {
+      url = "https://inbox.vuxu.org/cgit/20190101114453.4876-4-e@80x24.org/raw";
+      sha256 = "19k2qbqr8iwsslmjgvyjy5hah7mrqvcw1dj8axbk8nyvqd3njw1q";
+    })
+    (fetchpatch {
+      url = "https://inbox.vuxu.org/cgit/20190101114453.4876-5-e@80x24.org/raw";
+      sha256 = "12kbwfkxnlzf86n35p60h6y83mf82zdw0hiq01i6fl4pimg72bly";
+    })
+    (fetchpatch {
+      url = "https://inbox.vuxu.org/cgit/20210319202337.21676-6-e@80x24.org/raw";
+      sha256 = "1zn247v0scab3xbnzgzl52b7p02wdh8c5jl45q7a9iszn6rhk3m3";
+    })
+    (fetchpatch {
+      url = "https://git.causal.agency/cgit-pink/patch/?id=8f9034884bb592a0514d85771bd0096b1584b552";
+      sha256 = "0wvckndjmxar3vgqdc3jdnpzy0xgrdlqgfaasixl3x87sdnf4kg7";
+    })
+    ./use-buffered-stdio.patch
+  ];
+})