summary refs log tree commit diff
path: root/nixos/tests/tomcat.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/tests/tomcat.nix')
-rw-r--r--nixos/tests/tomcat.nix5
1 files changed, 2 insertions, 3 deletions
diff --git a/nixos/tests/tomcat.nix b/nixos/tests/tomcat.nix
index 92680d82ba89..475c947e72d9 100644
--- a/nixos/tests/tomcat.nix
+++ b/nixos/tests/tomcat.nix
@@ -23,9 +23,8 @@ import ./make-test.nix ({ pkgs, ...} : {
     startAll;
 
     $server->waitForUnit("tomcat");
-    $server->sleep(30); # Dirty, but it takes a while before Tomcat handles to requests properly
     $client->waitForUnit("network.target");
-    $client->succeed("curl --fail http://server/examples/servlets/servlet/HelloWorldExample");
-    $client->succeed("curl --fail http://server/examples/jsp/jsp2/simpletag/hello.jsp");
+    $client->waitUntilSucceeds("curl --fail http://server/examples/servlets/servlet/HelloWorldExample");
+    $client->waitUntilSucceeds("curl --fail http://server/examples/jsp/jsp2/simpletag/hello.jsp");
   '';
 })