about summary refs log tree commit diff
path: root/nixos/tests/samba.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/tests/samba.nix')
-rw-r--r--nixos/tests/samba.nix5
1 files changed, 2 insertions, 3 deletions
diff --git a/nixos/tests/samba.nix b/nixos/tests/samba.nix
index d6658ef0400b..e446284fc0ef 100644
--- a/nixos/tests/samba.nix
+++ b/nixos/tests/samba.nix
@@ -37,12 +37,11 @@ import ./make-test.nix ({ pkgs, ... }:
   testScript =
     ''
       $server->start;
-      $server->waitForUnit("samba-smbd");
-      $server->waitForUnit("samba-nmbd");
+      $server->waitForUnit("samba.target");
       $server->succeed("mkdir -p /public; echo bar > /public/foo");
 
       $client->start;
-      $client->waitForUnit("network.target");
+      $client->waitForUnit("remote-fs.target");
       $client->succeed("[[ \$(cat /public/foo) = bar ]]");
     '';
 })