summary refs log tree commit diff
path: root/nixos/tests/run-in-machine.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/tests/run-in-machine.nix')
-rw-r--r--nixos/tests/run-in-machine.nix10
1 files changed, 10 insertions, 0 deletions
diff --git a/nixos/tests/run-in-machine.nix b/nixos/tests/run-in-machine.nix
new file mode 100644
index 000000000000..75bd161ec9ef
--- /dev/null
+++ b/nixos/tests/run-in-machine.nix
@@ -0,0 +1,10 @@
+{ nixpkgs ? <nixpkgs>
+, system ? builtins.currentSystem
+}:
+
+with import ../lib/testing.nix { inherit system; };
+
+runInMachine {
+  drv = (import nixpkgs { inherit system; }).aterm;
+  machine = { config, pkgs, ... }: { services.sshd.enable = true; };
+}