summary refs log tree commit diff
path: root/nixos/tests/quagga.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/tests/quagga.nix')
-rw-r--r--nixos/tests/quagga.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/nixos/tests/quagga.nix b/nixos/tests/quagga.nix
index b9644b4768c0..613180942c41 100644
--- a/nixos/tests/quagga.nix
+++ b/nixos/tests/quagga.nix
@@ -8,7 +8,7 @@
 import ./make-test.nix ({ pkgs, ... }:
   let
 
-    ifAddr = node: iface: (pkgs.lib.head node.config.networking.interfaces.${iface}.ip4).address;
+    ifAddr = node: iface: (pkgs.lib.head node.config.networking.interfaces.${iface}.ipv4.addresses).address;
 
     ospfConf = ''
       interface eth2