about summary refs log tree commit diff
path: root/nixos/tests/predictable-interface-names.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/tests/predictable-interface-names.nix')
-rw-r--r--nixos/tests/predictable-interface-names.nix6
1 files changed, 6 insertions, 0 deletions
diff --git a/nixos/tests/predictable-interface-names.nix b/nixos/tests/predictable-interface-names.nix
index 83883477a5cc..bab091d57acf 100644
--- a/nixos/tests/predictable-interface-names.nix
+++ b/nixos/tests/predictable-interface-names.nix
@@ -17,6 +17,12 @@ in pkgs.lib.listToAttrs (pkgs.lib.crossLists (predictable: withNetworkd: {
       networking.useNetworkd = withNetworkd;
       networking.dhcpcd.enable = !withNetworkd;
       networking.useDHCP = !withNetworkd;
+
+      # Check if predictable interface names are working in stage-1
+      boot.initrd.postDeviceCommands = ''
+        ip link
+        ip link show eth0 ${if predictable then "&&" else "||"} exit 1
+      '';
     };
 
     testScript = ''