about summary refs log tree commit diff
path: root/nixos/tests/openstack-image.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/tests/openstack-image.nix')
-rw-r--r--nixos/tests/openstack-image.nix4
1 files changed, 4 insertions, 0 deletions
diff --git a/nixos/tests/openstack-image.nix b/nixos/tests/openstack-image.nix
index c7b28126e508..d0225016ab76 100644
--- a/nixos/tests/openstack-image.nix
+++ b/nixos/tests/openstack-image.nix
@@ -19,6 +19,10 @@ let
       ];
     }).config.system.build.openstackImage;
 
+  sshKeys = import ./ssh-keys.nix pkgs;
+  snakeOilPrivateKey = sshKeys.snakeOilPrivateKey.text;
+  snakeOilPublicKey = sshKeys.snakeOilPublicKey;
+
 in {
   metadata = makeEc2Test {
     name = "openstack-ec2-metadata";