summary refs log tree commit diff
path: root/nixos/tests/openssh.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/tests/openssh.nix')
-rw-r--r--nixos/tests/openssh.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/nixos/tests/openssh.nix b/nixos/tests/openssh.nix
index b2d254e9d9d9..230b45206847 100644
--- a/nixos/tests/openssh.nix
+++ b/nixos/tests/openssh.nix
@@ -17,7 +17,7 @@ in {
         services.openssh.enable = true;
         security.pam.services.sshd.limits =
           [ { domain = "*"; item = "memlock"; type = "-"; value = 1024; } ];
-        users.extraUsers.root.openssh.authorizedKeys.keys = [
+        users.users.root.openssh.authorizedKeys.keys = [
           snakeOilPublicKey
         ];
       };
@@ -29,7 +29,7 @@ in {
         services.openssh = { enable = true; startWhenNeeded = true; };
         security.pam.services.sshd.limits =
           [ { domain = "*"; item = "memlock"; type = "-"; value = 1024; } ];
-        users.extraUsers.root.openssh.authorizedKeys.keys = [
+        users.users.root.openssh.authorizedKeys.keys = [
           snakeOilPublicKey
         ];
       };