summary refs log tree commit diff
path: root/nixos/tests/nfs.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/tests/nfs.nix')
-rw-r--r--nixos/tests/nfs.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/nixos/tests/nfs.nix b/nixos/tests/nfs.nix
index 36cd6a395779..6ed1995f262a 100644
--- a/nixos/tests/nfs.nix
+++ b/nixos/tests/nfs.nix
@@ -40,7 +40,7 @@ in
 
   testScript =
     ''
-      $server->waitForUnit("nfsd");
+      $server->waitForUnit("nfs-server");
       $server->succeed("systemctl start network-online.target");
       $server->waitForUnit("network-online.target");
 
@@ -54,8 +54,8 @@ in
       $client2->succeed("echo bla > /data/bar");
       $server->succeed("test -e /data/bar");
 
-      # Test whether restarting ‘nfsd’ works correctly.
-      $server->succeed("systemctl restart nfsd");
+      # Test whether restarting ‘nfs-server’ works correctly.
+      $server->succeed("systemctl restart nfs-server");
       $client2->succeed("echo bla >> /data/bar"); # will take 90 seconds due to the NFS grace period
 
       # Test whether we can get a lock.