about summary refs log tree commit diff
path: root/nixos/tests/misc.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/tests/misc.nix')
-rw-r--r--nixos/tests/misc.nix6
1 files changed, 6 insertions, 0 deletions
diff --git a/nixos/tests/misc.nix b/nixos/tests/misc.nix
index 0f57b9f61261..76298f1abd47 100644
--- a/nixos/tests/misc.nix
+++ b/nixos/tests/misc.nix
@@ -63,6 +63,12 @@ import ./make-test.nix {
           $machine->succeed('[ "`hostname`" = machine ]');
           $machine->succeed('[ "`hostname -s`" = machine ]');
       };
+
+      # Test whether systemd-udevd automatically loads modules for our hardware.
+      subtest "udev-auto-load", sub {
+          $machine->waitForUnit('systemd-udev-settle.service');
+          $machine->succeed('lsmod | grep psmouse');
+      };
     '';
 
 }