about summary refs log tree commit diff
path: root/nixos/tests/mesos.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/tests/mesos.nix')
-rw-r--r--nixos/tests/mesos.nix4
1 files changed, 3 insertions, 1 deletions
diff --git a/nixos/tests/mesos.nix b/nixos/tests/mesos.nix
index 34671df047c8..007d7ac21603 100644
--- a/nixos/tests/mesos.nix
+++ b/nixos/tests/mesos.nix
@@ -66,9 +66,11 @@ import ./make-test.nix ({ pkgs, ...} : rec {
   testScript =
     ''
       startAll;
+      $master->waitForUnit("zookeeper.service");
       $master->waitForUnit("mesos-master.service");
+      $slave->waitForUnit("docker.service");
       $slave->waitForUnit("mesos-slave.service");
-
+      $master->waitForOpenPort(2181);
       $master->waitForOpenPort(5050);
       $slave->waitForOpenPort(5051);