summary refs log tree commit diff
path: root/nixos/tests/logstash.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/tests/logstash.nix')
-rw-r--r--nixos/tests/logstash.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/nixos/tests/logstash.nix b/nixos/tests/logstash.nix
index 317ea063e17c..edece352cafe 100644
--- a/nixos/tests/logstash.nix
+++ b/nixos/tests/logstash.nix
@@ -19,8 +19,8 @@ import ./make-test.nix ({ pkgs, ...} : {
                 exec { command => "echo dragons" interval => 1 type => "test" }
               '';
               filterConfig = ''
-                if [type] == "test" {
-                  grep { match => ["message", "flowers"] drop => true }
+                if [message] =~ /dragons/ {
+                  drop {}
                 }
               '';
               outputConfig = ''