about summary refs log tree commit diff
path: root/nixos/tests/login.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/tests/login.nix')
-rw-r--r--nixos/tests/login.nix9
1 files changed, 6 insertions, 3 deletions
diff --git a/nixos/tests/login.nix b/nixos/tests/login.nix
index ed7d97867179..0a7d25c37aca 100644
--- a/nixos/tests/login.nix
+++ b/nixos/tests/login.nix
@@ -1,8 +1,11 @@
-config: { pkgs, ... }:
+import ./make-test.nix ({ pkgs, latestKernel ? false, ... }:
 
 {
 
-  machine = config;
+  machine =
+    { config, pkgs, lib, ... }:
+    { boot.kernelPackages = lib.mkIf latestKernel pkgs.linuxPackages_latest;
+    };
 
   testScript =
     ''
@@ -58,4 +61,4 @@ config: { pkgs, ... }:
       };
     '';
 
-}
+})