summary refs log tree commit diff
path: root/nixos/tests/kexec.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/tests/kexec.nix')
-rw-r--r--nixos/tests/kexec.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/nixos/tests/kexec.nix b/nixos/tests/kexec.nix
new file mode 100644
index 000000000000..b8da332b919b
--- /dev/null
+++ b/nixos/tests/kexec.nix
@@ -0,0 +1,18 @@
+# Test whether fast reboots via kexec work.
+
+{ pkgs, ... }:
+
+{
+
+  machine = { config, pkgs, ... }:
+    { virtualisation.vlans = [ ]; };
+
+  testScript =
+    ''
+      $machine->waitForUnit("multi-user.target");
+      $machine->execute("systemctl kexec &");
+      $machine->{connected} = 0;
+      $machine->waitForUnit("multi-user.target");
+    '';
+
+}