about summary refs log tree commit diff
path: root/nixos/tests/installer.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/tests/installer.nix')
-rw-r--r--nixos/tests/installer.nix4
1 files changed, 3 insertions, 1 deletions
diff --git a/nixos/tests/installer.nix b/nixos/tests/installer.nix
index f491b0460330..64f98141cc0e 100644
--- a/nixos/tests/installer.nix
+++ b/nixos/tests/installer.nix
@@ -252,12 +252,13 @@ let
   makeInstallerTest = name:
     { createPartitions, preBootCommands ? "", extraConfig ? ""
     , testChannel ? false, grubVersion ? 2, grubDevice ? "/dev/vda"
-    , grubIdentifier ? "uuid"
+    , grubIdentifier ? "uuid", enableOCR ? false
     }:
     makeTest {
       inherit iso;
       name = "installer-" + name;
       nodes = if testChannel then { inherit webserver; } else { };
+      inherit enableOCR;
       testScript = testScriptFun {
         inherit createPartitions preBootCommands testChannel grubVersion
                 grubDevice grubIdentifier extraConfig;
@@ -364,6 +365,7 @@ in {
           preLVM = true;
         };
       '';
+      enableOCR = true;
       preBootCommands = ''
         $machine->start;
         $machine->waitForText(qr/Enter passphrase/);